
Help for PowWow
Overview
PowWow is a unique personal communications program for the Internet.    It allows you to 
call your friends, chat with up to seven (7) people by keyboard or voice, send and receive 
files, play MS-Windows .WAV format sound files, and browse the World-Wide Web together 
as a group.    All you need to know in order to reach another PowWow user is his or her email 
address.    PowWow will automatically connect with them, provided PowWow is running on 
their computer.

PowWow comes with a file named README.1ST which contains late-breaking news and 
other information not covered in the PowWow Users Guide.    Please check this file before 
continuing with this manual.

The latest version of PowWow, along with technical support and information about Tribal 
Voice, may be found on the Tribal Voice World-Wide Web server at http://www.tribal.com.

Running PowWow
To allow other people to connect to you, you must have PowWow running.    After WinSock 
has been initialized, double-click on the PowWow icon.    A dialog box will appear requesting 
your Local User I.D. and password.    Enter your email address as your Local User I.D.    You 
may choose any password of up to seven (7) characters.    Select OK.    The PowWow main 
screen will appear.    At the bottom of the screen the message "attempting to register with 
PowWow server" will appear followed "Registration accepted by Server" if your Internet 
connection is properly functioning.    PowWow is now active and ready for connections to or 
from other PowWow users.    If you are not intending to immediately connect with someone, 
minimize PowWow so it remains active in case someone wishes to connect with you.
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Edit Menu
The Edit menu includes commands that enable you to change the text in the PowWow edit 
windows.

For more information, select the Edit menu command name.

Clear Deletes text without moving it to the clipboard.



File Menu
The File menu includes commands that enable you to send files, and exit PowWow.

For more information, select the File menu command name.

Send Send a file to one of the people you are currently chatting with.
Exit Shut down connections and exit PowWow application.



Glossary
cruise leader - see Leader

domain name - The name of a particular network of computers attached to the Internet.    For example, all 
of Tribal Voices networked computers have a domain name of tribal.com.

dynamic IP address - An internet protocol address that changes each time a connection is made to an 
Internet service provider.    This type of connection is usually used with dial-up Internet accounts 
accessed via modem.

fixed IP address - An internet protocol address which remains the same.    Networked computers and 
other computers with a dedicated connection to the Internet typically have fixed IP addresses.

IP address - A numeric address used to identify a computer or other device (printer, router, and so forth) 
over the Internet.    IP addresses are composed of four sets of numbers with values of 0-255.    For 
example:    204.227.15.1 is the IP address for the Tribal Voices World-Wide Web server.

Leader - The person who first initiates a PowWow session.    The Leader has control of cruising the World-
Wide Web.

Local User I.D. - Your PowWow address.

Remote User I.D. - Anyone elses PowWow address.

SLIP - stands for Serial Line Interface Protocol.    A common method for connecting to the Internet using a 
modem.

static IP address - see fixed IP address 

TCP/IP - Stands for Transmission Control Protocol/Internet Protocol.    The method by which computers 
communicate with each other over the Internet.

URL - stands for Uniform Resource Locator.    A standard method of displaying the name of a FTP or 
World-Wide Web server.



Exiting
To exit PowWow select Exit from the File menu.



Edit Clear Command
The Clear command allows you to clear the send and receive windows of all text and moves 
the cursor to the top left hand corner of the send window.    All text currently in the window 
will be lost.



File Send Command
PowWow can send a file to one of the people with whom you are chatting.    Once you are 
connected and chatting the Send option will be enabled.    Select FILE=>SEND from the Main 
Menu to select a file to send.    If you are chatting with more than one person you will be 
prompted to pick a person to send the file to.    That person will be notified you wish to send 
them a file and prompted to accept or refuse the file.    If accepted, the file will be sent and a 
status window will show the progress of the file transfer.    When the receiver has finished 
receiving the file the status window closes.    The file download directory may be set by 
selecting the SETUP=>FILES AND DIRECTORIES option.    If no download directory is specified 
the file will be stored in the same directory as PowWow.

You may continue chatting while the file transfer is active.



File Exit Command
The Exit command will close all current connections to and from PowWow and will shut down
the PowWow application.



Setup Menu
The Setup menu includes commands that enable you to configure PowWow and save the 
configuration for PowWow.

For more information, select the Setup menu command name.

Local Info
Font
PowWow Book
Runtime
Files and Directories
Voice Settings
Answering Machine
Tribal Association
Sound Options
Browser Selection
Save Settings
Save Window Info



Connect Menu
To connect to another person using PowWow select the connect option and either enter the 
email address of the person you wish to contact or select one of the email addresses from 
the list in your PowWow book by dropping down the list box.

If the email address you have entered allows for a Direct Connection (i.e. the person has a 
fixed, rather than dynamic IP address and the host portion of the email address specifies the
machine on which they are running PowWow) you can select the Direct Connection option.    
This avoids the PowWow IP lookup process and saves 15 seconds or more in the initial 
connect time.    If you do not know whether the person you wish to contact has a fixed IP 
address, do not select the Direct    Connection option.    The lookup function will still work.

To add a newly-entered connection to your PowWow book check the Add Connection option 
before selecting OK.    This also saves the Direct Connection setting for the connection.

If you are away from your machine and would like for PowWow to automatically answer and 
send a message to those trying to contact you you can turn on the Answering Machine.

PowWow allows you to chat with someone privately so that what you type is sent only to 
that person and what they type is sent only to you.

For more information, select the Connect menu command name.

Connect
Disconnect
View Log
Add Connections
Answering Machine
Private Chat



Utility Menu
PowWow allows several people to browse the World-Wide Web together as a group using 
Netscape Navigator Version 1.1N or later, or Microsoft Internet Explorer.    This allows you to 
lead people through the Internet via your browser.    In order to lead the person you are 
chatting with, select the UTILITY=>LAUNCH CRUISE option from the Main Menu.    If your 
browser is not running it will be launched and a connection to it established by PowWow.    
Once the connection is established, the people you are chatting with will be notified you 
would like to lead them in browsing the Internet.    They can accept or refuse the cruise 
request.    If accepted the web browser will be launched on their computer systems.    Once 
the connections are established on all sides, whenever the Leader opens a new URL the 
'followers' will go to the same location.

If you stop cruising from PowWow, the connections to the browser will be discontinued but 
the browser will remain running.

To direct your browser to go to the PowWow White Pages at Tribal Voice select the White 
Pages menu option.    Your browser will be launched and directed to the White Pages web 
page where you can find a list of others running PowWow.

To initiate a voice connection with one of the people you are chatting with select the Voice 
Chat menu item.    If you are chatting with more than one other person you will be prompted 
to select who you would like to talk to.    This will open a connection for the exchange of 
voice data.    To end the voice chat session de-select the Voice Chat menu item.

To send your voice message select the Talk menu item and speak into your microphone.    
The voice data will begin to be sent as soon as you select the Talk menu item.    To stop 
sending your voice message de-select the Talk menu item.

PowWow allows you to play a sound on the machines of those you are chatting with.    From 
the menu select Sounds and then select one of the sounds listed.    The sound will then play 
on your machine and on the machines of those you are talking with.

You can add your own sounds to PowWow to play on the machines of those you are chatting 
with as long as they have the same files in their PowWow directories.

For more information, select the Utility menu command name.

Launch Cruise
Stop Cruising
White Pages
Voice Chat
Talk
Sounds
Sound Add



Local Info
Use the Local Info setup to specify your PowWow I.D. so people can contact you using 
PowWow.    The address should be the same as your email address and take the form of 
name@domain.org.    When someone attempts to connect to you, PowWow will verify that 
the name being requested matches the name in the PowWow registry database.

The password you select is saved with the PowWow I.D. in the PowWow registry database.    
On subsequent registrations the registration will not change the IP address for this address if
the correct password is not used.

The save password option allows you to save the current password in the POWOW.INI file so 
that you will not have to re-enter each time. 

The PowWow I.D. and Password fields are required in order to register PowWow.    The other 
following fields are optional.

The Real Name / Handle field allows you to enter a name or handle (nickname) of up to 30 
characters to identify yourself to the people you are chatting with.    This name will be 
displayed along with the PowWow I.D. when requesting a connection to others and used as 
the title for your text window on the machines of those you are chatting with.

The HomePage field allows you to enter a URL for your HomePage.    If you enter a HomePage
then the people you are chatting with will have an icon, showing a home,    that they can 
select to get your URL.    Upon receiving the URL their browser will be sent to your HomePage
location.

The JPEG Picture field can be filled in with the path and filename of a JPEG file, 10KB max., 
that is a picture, drawing or representation of yourself that you would like to make available 
for those you are chatting with to view if the wish to.    If you enter a JPEG Picture filename 
the people you are chatting with will have an icon, showing an eye, that the can select to get
your picture file.    Upon receiving the JPEG Picture file the picture will be displayed in its own 
window on the receivers machine with your name or PowWow I.D. as the title.



Font Setup
Select the font to use for the chat windows.



PowWow Book
The PowWow book setup allows you to manage your list of connection addresses.    Here you 
can add and remove connections.

In the list of connections a ',L' at the end of the email address specifies lookup should be 
performed when connecting to this PowWow I.D. while a ',D' specifies the email address is 
direct and lookup is unnecessary



Runtime Setup
The Runtime Setup allows you to set the defaults for request responses and window buffer 
sizes.

Each request type (talk, file transfer, cruise, and voice) can be set to either prompt you 
when a request is received or to automatically refuse the request.

The buffer sizes can be set to your desired buffer size in kilobytes (KB) for each PowWow 
chat window, provided your system has enough memory to accommodate your requested 
size buffer.



Files and Directories
Through the Files and Directories Setup option you can specify the download directory, 
sound file, and PowWow Book location for PowWow.

The download directory specifies which directory will be used for files that are downloaded 
through PowWow.    The default is the directory from which PowWow is run.

The sound file is the sound that will be played when a request is received within PowWow.    If
your system does not support playing .WAV files a beep will sound instead.

The PowWow Book location is the directory path PowWow loads its PowWow book from.    The 
default is the directory from which PowWow    is run.



Save Settings
Saving the current settings will save the currently configured settings under the setup menu.



Save Window Info
Saving the current size and position of the PowWow window.



Connect
To connect to another person using PowWow select the connect option and either enter the 
email address of the person you wish to contact or select one of the email addresses from 
the list in your PowWow book by dropping down the list box.

You can also enter a Subject to discuss which will be displayed in the chat request box on the
other persons screen.

If the email address you have entered allows for a direct connection (i.e. the person has a 
fixed, not dynamic, IP address) you can select the direct connection option.    This avoids the 
PowWow IP lookup process and saves 5 seconds or more in the initial connect time.    If you 
do not know whether the person you wish to contact has a fixed IP address, do not select the
direct option.    The lookup function will still work.

To add a newly entered connection to your PowWow book check the Add Connection option 
prior to selecting OK.    This will also save your selection for the direct versus lookup setting 
for this connection.



Disconnect
Select disconnect to discontinue chatting with someone and stop all file transfer and cruise 
connections.    This will break the connection to the person you were chatting or attempting 
to chat with.    If you are chatting with more than one person you will be prompted to select 
the person(s) to disconnect from.    Select All to disconnect from everyone.



Launch Cruise

PowWow has the ability to communicate with the Netscape Navigator Version 1.1N or later, 
and Microsoft Internet Explorer.    This allows you to lead a group of PowWow users through 
the Internet with your browser.    In order to lead the people you are chatting with, select the 
UTILITY=>LAUNCH CRUISE option.    If your browser is not already running then it will be 
launched and a connection to it established.    Once the connection to the browser completes
successfully the people you are chatting with will be notified that you would like to lead 
them in browsing the Internet.    They can then accept or refuse the cruise request.    If 
accepted the browser will be launched on their computers.    Once the connections are 
established on both sides whenever the Leader opens a new URL the 'follower' will be routed
to the same location.

If you stop cruising, the connections to the browser will be dropped but the browser will 
remain running.



Stop Cruising
If you stop cruising the connections to the browser will be dropped, but the browser will 
remain running.



Support
Please email technical questions, comments and suggestions to support@tribal.com.



About Tribal Voice
Tribal Voice is an organization run by Native Americans from many tribes dedicated to 
providing a Native American presence in the high-tech industry through free and low-cost 
computer software and services.    All Tribal Voice products are Native American in concept, 
architecture and implementation.

Tribal Voice is endowed by the Native American Trust and the McAfee Foundation.

PowWow is the copyrighted property of Tribal Voice.    It may be used free-of-charge for 
personal use by individuals and educational institutions.    Anyone else wishing to use 
PowWow should contact Tribal Voice for licensing information.

Tribal Voice
627 West Midland Avenue
Woodland Park, CO    80863-1100
TEL 1-(719) 687-0480
FAX 1-(719) 687-0716
EMAIL sales@tribal.com



Window Menu
This is where PowWows window behavior can be set.

Selecting Always on Top forces PowWow to remain on top of all other windows on your 
desktop.    By default this option is off.

For more information, select the Window menu command name.

Always on Top



Always on Top
Selecting Always on Top forces PowWow to remain on top of all other windows on your 
desktop.    By default this option is off.



View Log
Each time someone contacts you PowWow saves the date, time, Remote User I.D., and 
Subject field into a log file.    The log file can be checked to see if someone tried to contact 
you while you were away and PowWow was running.

You can view the log file by selecting CONNECT=>VIEW LOG from the Main Menu.    PowWow 
will then launch the Microsoft NotePad to view the log file.    If NotePad is not available the 
log file cannot be viewed from within PowWow.    We recommend reviewing and purging the 
log on a monthly to weekly basis, depending upon your PowWow usage.



Add Connections
You can add the Remote User I.D.s of the person you are chatting with to your PowWow book
by selecting CONNECT=>ADD CONNECTIONS from the Main Menu.    If you are chatting with 
more than one person, you will be prompted to select which person(s) to add to your 
PowWow Book.    Selecting All adds everyone.



Voice Settings
Select the resolution/quality of sound to use in sending and receiving voice data.    It is 
suggested that you base this on the speed of your connection to the internet.    A 
communication speed of at least 28.8Kbps and a 486 or better computer is needed to use 
the voice feature of PowWow.

For lower quality sound but faster transmission of the data select the Low Resolution setting.

Medium Resolution has fairly good sound quality but takes about twice as much time to send
as low resolution.

And High Resolution is best reserved for those with very fast connections to the internet 
such as ISDN or T-1 lines.    High Resolution takes about twice as long to send as Medium 
Resolution data.



Answering Machine Configuration
This edit area is where you can enter the message that you would like displayed to those 
who try to connect to you when you have the Answering Machine mode turned on.    You may
enter up to 255 characters for the message.    The Answering Machine can be turned on by 
selecting CONNECT=>ANSWERING MACHINE from the Main Menu.



Answering Machine Mode
If you are away from your machine and would like for PowWow to automatically answer and 
send a message to those trying to contact you you can turn on the Answering Machine.

When someone attempts to contact you PowWow will automatically send the message you 
have configured under SETTINGS=>ANSWERING MACHINE to the remote end.    Once the 
other end has acknowledged the message the connection will be broken.



White Pages
This option directs your web browser to go to the PowWow White Pages at Tribal Voice, your 
web browser will be launched if necessary and directed to the White Pages web page where 
you can find a list of others running PowWow.    You can then search for others to chat with or
add yourself to the list so that others will contact you.



Voice Chat
PowWow allows you to initiate a voice connection with one of the people you are chatting 
with.    Once a voice connection is established you can take turns sending voice messages 
back and forth.    A communication speed of at least 28.8Kbps and a 486 or better computer 
is needed to use the voice chat feature of PowWow.

If you are chatting with more than one other person you will be prompted to select who you 
would like to talk to.    A connection will then be established for the exchange of voice data.    
To end the voice chat session de-select the Voice Chat menu item.



Talk
To send your voice message select the Talk menu item and speak into your microphone.    As 
long as the Talk option is selected PowWow will continue to send the voice data. To stop 
sending your voice message de-select the Talk menu item.    When you have the Talk option 
selected you will not be able to hear what the other person is saying, so it is recommended 
that you take turns speaking.    There may be a slight delay in transmission due to traffic and
routing on the Internet.



Sounds
PowWow allows you to play a sound on the machines of those you are chatting with.    From 
the menu select Sounds and then select one of the sounds listed.    The sound will then play 
on your machine and on the machines of those you are talking with.

If you do not want others to be able to play sounds on your machine you can select the 
SETTINGS=>SOUND OPTIONS menu option and de-select the Play Sounds options.



Private Chat
You can chat with someone privately so that what you type is sent only to that person and 
what they type is sent only to you.

To chat with someone privately, select CONNECT=>PRIVATE CHAT from the Main Menu.    If 
youre chatting with more than one person you will be prompted for which person to chat 
privately.      Or you can click the P button on their menu bar.



Tribal Association
Here you can enter the URL of an additional PowWow White Pages server with which to 
register.    You can register with any World-Wide Web server running the PowWow White 
Pages software.    This may be a server for an Internet service provider, educational 
institution, business, or other organization.

NOTE:Registering with other PowWow White Pages servers will work only if you have gone 
to them and added yourself to their White Pages database.



Browser Selection
Here you can tell PowWow which World-Wide Web browser to use when cruising with 
PowWow.    Specifying the complete path will considerably speed up the launching of the web
browser.

PowWow requires Netscape Navigator Version 1.1N or Microsoft Internet Explorer to be able 
to use the cruise feature.



Sound Options
From the Sound Options menu you can tell PowWow whether or not to play Microsoft .WAV
sound files from yourself or other users and select a male voice or female voice to be played
in other peoples PowWow when you send sounds to them.



Sound Add
To add sounds to PowWow, select    UTILITIES=>SOUND ADD from the Main Menu.    You will 
then be prompted to enter the Sound I.D. and Sound Path and Filename for sound to add to 
PowWow. 

The Sound I.D. is the description of the sound that appears within PowWow and is also used 
to identify which .WAV file to play.    The Sound I.D. can be up to twenty (20) characters long 
and contain any mixture of alphanumeric characters, punctuation marks, and spaces.

The Sound Path and Filename tells PowWow the name of the .WAV file and where it is 
located on your computer system.    If no path is specified, PowWow will search the PowWow 
directory and then the environment path for the .WAV file to be played.

NOTE:Any sound files you add must first be sent to other users and given the same 
Filename before they can be heard by anyone else.    You can use PowWows file 
transfer function to send sound files.






