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About Corel WEB.SiteManager

Corel WEB.SiteManager provides Web site administrators (“webmasters”) with maintenance, monitoring,
diagnostic, and repair facilities for their Internet and Intranet sites. 

Corel WEB.SiteManager    provides and intuitive drag and drop interface making it easy for the 
webmaster to monitor, verify, repair and update the content of the Web site.

There are no server extensions required to run the application. Corel WEB.SiteManager supports local 
and remote servers via the HTTP and file access protocols.



Getting Started - Overview

Corel WEB.SiteManager is a graphical Web site management tool that allows you to manage the pages,
hypertext links, and the file structure of the Web site.

After starting the application, the Open dialog box appears. Sites can be loaded either via the local file 
system or by opening it through HTTP access. 
There is also an option of re-opening the most recently examined sites from the File Menu or by choosing 
the site from the drop-down list on the toolbar and clicking the Go button. 

To open a new site, select Open on the File Menu or click the Open button on the toolbar.

Tips
For Web sites that are more complex, there is an option to set the number of levels to be opened at the 
bottom of the open sites dialog. 

Do you want to stop the site being from loaded at a certain point? Simply click the stop button located on 
the toolbar.

Use one of Corel WEB.SiteManager ’s Link Wizards to repair broken hypertext links and leave 
messages when files have been moved, copied, renamed, or deleted.



Opening an Internet Site

To open an Internet site, select Open on the File Menu or click the Open button on the toolbar. Select the 
Open an Internet Site option in the Open dialog box, type in the URL of the site and click OK. 

The Advanced section allows you to specify the site root and default Home Page name. If you are working
on a sub-section of the Web site and there are links to Web pages outside the sub-section but still within 
the site root they will be displayed as external links. You must specify the Site Root in order for the links to
these pages to be verified correctly once external links are checked. If the Default Page Name is not 
specified, Corel WEB.SiteManager will assume it to be “unknown_name.html”.

To specify Proxy Server details click the Proxy button or select the HTTP Options tab from Preferences on
the File Menu.

Through HTTP you can connect to and analyze any site that you can access with your Web browser. By 
using HTTP Access, one can view and understand the structure of a Web site and detect broken links on 
a remotely located site. 

If you also have file-level access, you can take advantage of the product’s advanced management 
features by selecting the Open Local Site option in the Open dialog box.

At any point during loading a site you can Stop SiteManager from Reading it.



Opening a Local Site

To open a local site, select Open on the File Menu or click the Open button on the toolbar. Select the 
Open a Local Site option in the Open dialog box, type in or browse to select the path of the site and click 
OK. 

The Advanced section allows you to specify the site root and default Home Page name. If you are working
on a sub-section of the Web site and there are links to Web pages outside the sub-section but still within 
the site root they will be displayed as external links. You must specify the Site Root in order for the links to
these pages to be verified correctly once external links are checked. If the Default Page Name is not 
specified, Corel WEB.SiteManager will assume it to be “index.html”.

File-level access allows you to take advantage of Corel WEB.SiteManager’s advanced management 
features.
Use these advanced features to Drag and Drop, Delete, and Rename files and folders and, using the 
Link Wizard, either update broken links or leave bookmarks for visitors who access the site.

At any point during loading a site you can Stop SiteManager from Reading it.



File View - Overview
The File View is located on the left when either Page View, List View, Source View, or Browser View is
displayed on the right of the screen. It lists the files and folders on the current Web site. Files and Folders 
are displayed in a tree format which enables a more complete view of the site. A folder is opened by 
clicking the + sign located beside it.
Double-clicking a file in File View opens it in the selected editor.

Synchronizing File View with Others Views

By selecting Keep Views Synchronized on the View Menu, the file that has the focus on the right side of 
the screen will stay synchronized with the file that is selected in File View. 
If the Keep Views Synchronized option has been selected, single-clicking a file in File View gives the 
following: 

If Page View is on the right of the screen, then clicking the file in File View makes it the document of 
focus on the right.
If List View is on the right of the screen, then clicking the file in File View will highlight it on the right, 
providing the file type is currently being displayed in List View.
If Source View is on the right of the screen, then clicking the file in File View causes the source code to 
be displayed on the right.
If Browser View is on the right of the screen, then clicking the file in File View launches Corel 
WEB.SiteManager’s built-in Browser on the right.

If the Keep Views Synchronized option has not been selected, it is possible to synchronize two views by 
right-clicking the file in File View and selecting Synchronize Views.

Operations available with File View:
    Drag and Drop
    Create
    Rename
    Delete
    Cut and Paste

Other views offered by Corel WEB.SiteManager:
    Page View
    List View
    Source View
    Browser View



Drag and Drop

With the Drag and Drop feature, you can either move or copy a file or folder to a new location.

To move a file or folder…
Using the left mouse button, click the file or folder you want to work with. You must make sure the place 
you want to drag the file or folder to is visible. Drag the file or folder to the destination. The Link Wizard 
now appears asking you whether you want to repair hypertext links automatically. The following options 
are available:
-Automatically repair the affected links?
-Move the item but do not repair any links?
-Leave a “This page has moved” message
Make your selection and click OK.

In most cases you’ll want to automatically repair the affected links. For more information see the Link 
Wizard.

Note
Using drag and drop you can move or copy files into sub-folders of the current folder. For more extensive 
modifications you can use Corel WEB.SiteManager's Cut and Paste feature.

To copy a file or folder…
Using the left mouse button, click the file or folder you want to work with. You must make sure the place 
you want to drag the file or folder to is visible. While holding down the Control key, drag the file or folder to
the destination. The Link Wizard now appears asking whether you want to repair hypertext links 
automatically. The following options are available:
-Automatically repair the affected links?
-Move the item but do not repair any links?
Make your selection click OK.

In most cases you’ll want Corel WEB.SiteManager to automatically repair the affected links. For more 
information see the Link Wizard.

Other operations available with File View:
    Creating Directories
    Renaming Files and Directories
    Deleting Files and Directories
    Cut and Paste Operations



Creating Folders

To create a new folder, click the new folder button on the toolbar. Type the name of the new folder (the 
default name is New Folder) and press the Enter key. 
If you find that a large number of files have been gathering in a particular folder you might consider re-
organizing the files by creating sub-folders within the current folder and moving related files into these 
sub-folders. By organizing your files this way, it will be easier to locate files in the future. 

Tip
If you use the Drag and Drop or Cut and Paste Operations features, the Link Wizard will automatically 
repair broken links for you.

Other operations available with File View:
    Drag and Drop
    Renaming Files and Directories
    Deleting Files and Directories
    Cut and Paste Operations



Renaming Files and Folders

To rename a file or folder, click your selection using the right mouse button and click Rename in the pop-
up list. Type in the new name you want to give the file or folder and press the Enter key. The Link Wizard 
now appears asking you whether you want to repair hypertext links automatically. The following options 
are available:

-Automatically repair the affected links?
-Move the item but do not repair any links?

Make your selection and click OK.

Other operations available with File View:
    Drag and Drop
    Creating Directories
    Deleting Files and Directories
    Cut and Paste Operations



Deleting Files and Folders
Select the file or folder you want to delete and either press the Delete key or select Delete on the File 
Menu. The Link Wizard now appears advising you that you can leave a message to visitors who have 
made bookmarks to the deleted file.

Other operations available with File View:
    Drag and Drop
    Creating Directories
    Renaming Files and Directories
    Cut and Paste Operations



Cut and Paste Operations

To copy a file or folder…

In File View, click the file or folder you want to copy.
Select Copy on the Edit menu or click the Copy button on the toolbar at the top of the screen.
Open the folder or disk where you want to put the copy.
On the Edit menu or from the toolbar at the top of the screen, click Paste.

Tip
As you work with the files in your site, the Link Wizard will appear whenever you perform an operation 
that may affect the links in your site. Click here        for more information.

To move a file or folder…

In File View on the left side of the screen, click the file or folder you want to move.
On the Edit menu from the toolbar at the top of the screen, click Cut. 
Open the folder where you want to put the file or folder.
On the Edit menu or from the toolbar at the top of the screen, click Paste. 

Tip
As you work with the files in your site, the Link Wizard will appear whenever you perform an operation 
that may affect the links in your site. Click here        for more information.

Other operations available with File View:
    Drag and Drop
    Creating Directories
    Renaming Files and Directories
    Deleting Files and Directories



     Page View - Overview

Corel WEB.SiteManager's Page View allows you to visualize and understand the links and relationships 
between the files on your site. Its graphical representation lets you instantly identify different types of links
to and from your pages. Links to HTML files are shown by the globe icon and broken links are 
represented by a red circle with an X inside. Links to other files are shown by icons specific to the file 
type. A plus (+) sign beside the icon indicates that further links exist. When you double-click an icon, links 
to and from that file will be shown.    

Click here        to see how Corel WEB.SiteManager identifies the various file types and links going to 
and from your site. 

Placing the cursor over any of the files in Page View allows you to see more information about the Web 
page itself. This information includes title, author, location of the file, and whether the page uses Frames, 
Java, ActiveX, or Forms. Click here        to see the icons for the different page properties. If the site is still
being loaded and the file has not yet been parsed, then a message will also appear to that effect.

With Page View you can also quickly identify problems like broken links and orphan files within the 
structure of your site. 

Corel WEB.SiteManager also provides the option to synchronize Page View with File View.

Filters available with Page View:
    Show Duplicate Links
    Show External Links
    Show Links to Picture Files
    Show Unrecognized Files

Other views offered by Corel WEB.SiteManager:
    File View
    List View
    Source View
    Browser View



Expanding and Collapsing Links

If a file has further links (expandable), a plus (+) sign will be located to the left of its icon. The links can 
then be displayed by clicking on the (+) icon. 
To collapse this view, click the negative (-) sign located to the left of its icon.
Click here        to see how Corel WEB.SiteManager identifies different file types.



Changing the Reference Document

To make a particular file the Reference Document, either double click its icon or, using the right mouse 
button, click the icon and select Move to Center.



 Source View - Overview
The Source View allows you to see the contents of a selected file. It also allows you to make spot 
modifications to the chosen file. Once saved, changes made in Source View are automatically reflected 
in the other views. Corel WEB.SiteManager also provides the option to synchronize Source View with 
File View.

Four basic colours are used to show the file’s contents:

Blue - shows links to other HTML tags

Green - displays links to other files

Black - represents regular text

Red - used to show broken links

Tools available for use with Source View:
    Find and Replace
    Global Find and Replace
    Keyboard Layout
    Saving Changes

Other views offered by Corel WEB.SiteManager:
    File View
    Page View
    List View
    Browser View



Find and Replace

To Find text…

Click the beginning of the document.

On the Edit menu, click Find.

Type in the text you wish to find and click the Find button. If the text is found , it will be highlighted on the 
Source View screen.

To find the next instance of the text, click Find Next, press F3, or on the Edit menu, click Find.

To Replace text…

Click the beginning of the document.

On the Edit menu, click Replace.

Type in the text you wish to replace and move to the Replace with text box and type in the desired 
replacement text. Once the text has been entered, click the replace button. If the text is found , it will be 
highlighted on the Source View screen.

You are then prompted to replace the next instance or all instances of the text. A message appears at the 
end informing you how many replacements were made.

Tip
To exclude text that is part of an HTML tag use the option to search display text only. In this case, the title 
and all HTML tags (text that is located between <> signs) are ignored.

Other tools available for use with Source View:
    Global Find and Replace
    Keyboard Layout



Global Find and Replace

Corel WEB.SiteManager’s advanced Global Find and Replace feature allows you to search through any 
or all of your Web Pages to find or replace text.

To Find text…

On the Edit menu, click Global Find.

The search can be conducted on all files located on the Web site or on one or more selected files or 
folders. If the selected files option has been chosen then the search will be conducted on the file or folder 
that was last selected. 

Global Find also provides the option to search display text only. In this case, any HTML tags are ignored 
(text that is located between <> signs).

Next, type in the text you wish to locate and click the Find button. If the text is found, a dialog box appears
listing the files that contain the search text and along with the number of hits or occurrences of the text in 
each of the files.

To locate the text in a selected file, highlight the filename and click the View File button. 

The first occurrence of the text is now highlighted in Source View. To find the next instance of the text 
click the Find Next button. 

To Replace text…

On the Edit menu, click Global Replace.

The search can be conducted on all files located on the Web site or on one or more selected files or 
folders. If the selected files option has been chosen then the search will be conducted on the file or folder 
that was last selected. 

Global Replace also provides the option to search and replace display text only. In this case, the title and 
all HTML tags (text that is located between <> signs) are ignored.

Next, type in the text you wish to find along with the replacement text and click the Replace button. If the 
text is found, a dialog box appears listing the files that contain the search text and along with the number 
of hits or occurrences of the text in each of the files.

To go through a file and view the text before it is replaced, highlight the filename and click the Edit File 
button. The first instance of the text will be highlighted in Source View. You are then prompted to replace 
the highlighted text or all instances of the text in the current file. A message appears at the end informing 
you how many replacements were made. To save replacements made to the current file make sure the 
“save changes to this file before continuing” option has been selected. To continue replacing in the next 
file click the Yes button. To return to the dialog box listing of files click the No button.

To replace all instances of the text in all selected files, click the Replace All button. At this point it is 
possible to create backup copies of the files before the text is replaced. If this option is selected, the 
backup copies will be placed in a directory called “backup” which is located in the same directory as the 
Corel WEB.SiteManager executable file. The directory structure of the Web site will be maintained in the 
backup directory.



Other tools available for use with Source View:
    Find and Replace
    Keyboard Layout



Keyboard Layout

The following keys or combinations of keys can be used when working in Source View:

Cut           CTRL+F

Copy          CTRL+C

Paste          CTRL+V

Delete          DEL

Find          CTRL+F

Find Next          F3

Replace          CTRL+R

Properties        ALT+ENTER

Move to the start of a line          HOME

Move to the end of a line          END

Move to the start of the file          CTRL+HOME

Move to the end of a file    CTRL+END

Up one line          UP ARROW

Down one line          DOWN ARROW

Left one space          LEFT ARROW

Right one space          RIGHT ARROW

Left one word          CTRL+LEFT ARROW

Right one word          CTRL+RIGHT ARROW

Other tools available for use with Source View:
    Find and Replace
    Global Find and Replace



      List View - Overview
The List View allows you to see a list of files located on the current site. Information is given on the file 
Path, File name, Title, Author, Size, Last Modified date, and when it was Created. It is possible to sort 
the list in ascending or descending order based on one of these criteria by clicking the column header. 

Click the Size column header to arrange the files in descending or ascending size. This may be useful for 
finding out which files are taking up the most space.

Click the Last Modified column header to sort the view and see which files have not been modified 
recently and may be candidates to be deleted.

When a file is highlighted under path in List View, it automatically becomes highlighted on the left side of 
the screen in File View. Corel WEB.SiteManager also provides the option to synchronize List View with 
File View.

Tips
Double-click an item in List View to automatically switch to Page View.

To print a list of HTML pages, go to List View and do a multiple select of the files (holding down the 
SHIFT key) and copy the list onto the clipboard. Next, open your favorite text editor, copy the list of files 
into the document and print it.

Options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files

Other views offered by Corel WEB.SiteManager:
    File View
    Page View
    Source View
    Browser View



All Files and Links

To choose this option, select All Files and Links from the List View Menu.
In this report, Corel WEB.SiteManager gives the total picture of the Web site by displaying all of its files 
and showing which links go to and from the site.
Viewing all files and links can help you understand your site as a whole. For example, in List View you 
can sort (by clicking the column header) by the Last Modified column to see which files have not been 
modified recently. Click the Last Modified column header again to reverse the sort order and see which 
files have been modified recently.

Other options available with List View:
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



All Files

To choose this option, select All Files on the List View Menu
If your interested in seeing all the files on the current Web site but are not concerned with seeing the links
to and from the site, choose this report.

Other options available with List View:
    All Files and Links
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



HTML Pages

To choose this option, select HTML Pages on the List View Menu. All files with htm and html extensions 
will be displayed.
This report allows you to focus on the HTML pages in your site. 

Tip
You can sort the list by column headings such as the Author field. For example, if your documents have 
author tags in the meta data, the author's name will be displayed and you can sort by this value to see 
which documents belong to a particular author.

Other options available with List View:
    All Files and Links
    All Files
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Links to External Sites

To choose this option, select Links to External Files on the List View Menu.
A list of external sites that your Web pages point to is displayed.

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Image Files

To choose this option, select Image Files on the List View Menu. Files with extension jpg, gif, and xbm 
will be displayed.
This list allows you to focus on the images that are used on your site.    Often on large sites, you'll find two
or more copies of the same image.    This can happen when more than one HTML author posts 
information to the site. These duplicate images can waste space on your server's disk space.    With a list 
of Image Files, you can quickly identify duplicates by sorting by File name or Size.

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Mailto: Links

To choose this option, select Mailto: Links on the List View Menu.
A list that shows the links to e-mail addresses is shown under this option. 

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Pages Using Java

To choose this option, select Pages Using Java on the List View Menu.
It displays a list of files that use Java applets. 

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Pages Using Java Script

To choose this option, select Pages Using Java Script on the List View Menu.
A list of files that contain Java Script is displayed. 

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Pages Using ActiveX

To choose this option, select Pages Using ActiveX on the List View Menu.
This option allows you to focus on files using ActiveX objects.

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Pages Using VB Script

To choose this option, select Pages Using VB Script on the List View Menu.
A list of files using Visual Basic Script is shown. 

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Pages Using Frames

To choose this option, select Pages Using Frames on the List View Menu.
This option provides a listing of Web pages that contain frames.

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Forms
    Pages with Broken Links
    Broken Links
    Orphan Files



Pages Using Forms

To choose this option, select Pages Using Forms on the List View Menu.
This list allows you to focus on files that contain Forms. 

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages with Broken Links
    Broken Links
    Orphan Files



Pages with Broken Links

To choose this option, select Pages with Broken Links on the List View Menu.
A list of pages containing broken links helps identify problems which may exist on your Web site. Ideally, 
there should be no files listed. You can use Corel WEB.SiteManager’s advanced features to repair 
broken links.

Tip
To view a page that contains broken links in Page View double-click the item or right-click and select 
View Links.

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Broken Links
    Orphan Files



Broken Links

To choose this option, select Broken Links on the List View Menu.
This list shows the broken links that are located on the Web site. You can use Corel WEB.SiteManager’s
advanced features to repair broken links. 

Tip
To view a broken link in Page View double-click the item or right-click and select View Links.

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Orphan Files



Orphan Files

To choose this option, select Orphan Files on the List View Menu.
Orphans are files that have no other files pointing to them. Corel WEB.SiteManager reports that a page 
is an orphan when it detects that no other pages point to it. However, it is possible that other sites may 
have links to the page in question. 
Note
Before deleting an orphan, it is best to check with the author or person responsible for the file to ensure 
that it is in fact an orphan page.

Other options available with List View:
    All Files and Links
    All Files
    HTML Pages
    Links to External Sites
    Image Files
    Mailto: Links
    Pages Using Java
    Pages Using Java Script
    Pages Using ActiveX
    Pages Using VB Script
    Pages Using Frames
    Pages Using Forms
    Pages with Broken Links
    Broken Links



    Browser View -Overview
Browser View can be started by highlighting the file with a single-click and choosing Browser View on the
View menu, or by clicking the Browser View button on the toolbar.

Settings for Browser View
To change the settings for Browser View choose Preferences on the File Menu and select General Tab. 
Two options are available; Corel WEB.SiteManager’s integrated browser can be selected or one can use
the system’s default browser. 

If    the integrated browser is selected, it is still possible to use the system’s default browser by right-
clicking the file in File View and selecting Open with Browser.

By using Corel WEB.SiteManager’s integrated browser you can view Web Pages on the right side of the 
screen while File View is maintained on the left. This advanced feature allows you to view Web pages on 
the site either by selecting different files in File View and seeing how they look on the right or by 
navigating through the site in Browser View. Any link that is selected on the right will become highlighted 
on the left if the Web page is found within the site.

Other views offered by Corel WEB.SiteManager:
    File View
    Page View
    List View
    Source View



 Launch Editor - Overview
Editing HTML Web Pages

With Corel Web.SiteManager it’s easy to edit your HTML pages.
The desired editor is configured in the File Locations Tab under Preferences. By default, the Corel 
WEB.DESIGNER editor is used.

Editing Images

It is easy to edit your image files directly from Corel WEB.SiteManager.
The desired editor is configured in the File Locations Tab under Preferences. By default, the Corel 
WEB.PhotoPaint editor is used.

Launching the HTML editor or Image Editor

To launch the configured editor, either double-click the file in File View, single-click the Launch Editor 
button on the toolbar, or select Launch Editor in the View menu.

Note
After editing an HTML web page, you must reload the site in order for Corel WEB.SiteManager to 
recognize the changes. To reload a site, either choose Reload Current Site in the File menu or click the 
Reload Site button on the toolbar.



Filters - Overview

Filters can only be used when working in Page View. Their purpose is to reduce the clutter on the screen
and make it easier to see the relationships between files or documents. By default, no filters are applied. 
To apply a filter, either click the desired button on the toolbar or select it from the View menu.
Corel WEB.SiteManager provides the following filters:

    Show Duplicate Links
    Show External Links
    Show Links to Picture Files
    Show Unrecognized Files



    Duplicate Links
This filter allows you to see duplicate links and can only be used in Page View. By default, duplicate links 
are not shown. To apply or remove the filter, either click the Show Duplicate Links button on the toolbar or 
make your selection from the View menu.
Often, a page will contain two or more links to another page. For example, there may be a text link and a 
link through a picture. These duplicate links can clutter up the Page View.

Other Corel WEB.SiteManager filters:
    Show External Links
    Show Links to Picture Files
    Show Unrecognized Files



    External Links
This filter allows you to see links to files outside the currently selected site and can only be used in Page 
View. By default, external links are not shown. To apply or remove the filter, either click the Show External
Links button    on the toolbar or make your selection from the View menu.

Other Corel WEB.SiteManager filters:
    Show Duplicate Links
    Show Links to Picture Files
    Show Unrecognized Files



    Images
This filter allows you to see links to image files with extensions jpg, gif, and xbm and can only be used in 
Page View. By default, image files are not shown. To apply or remove the filter, either click the Show 
Links to Pictures button on the toolbar or make your selection from the View menu.

Other Corel WEB.SiteManager filters:
    Show Duplicate Links
    Show External Links
    Show Unrecognized Files



    Unrecognized Files
This filter allows you to see links to unrecognized files and can only be used in Page View. By default, 
links to unrecognized files are not shown. To apply or remove the filter, either click the Show 
Unrecognized Files button on the toolbar or make your selection from the View menu.

Other Corel WEB.SiteManager filters:
    Show Duplicate Links
    Show External Links
    Show Links to Picture Files



File Properties -Overview

To view file properties…

Click the file or folder whose properties you want to view. Next, either press ALT+ENTER, right-click the 
item and select Properties, or select Properties on the Edit menu. Properties of the selected file are found 
in two tabs:

General Tab properties which list the file name, size, the date it was created and the date it was modified.
File attributes are also listed.

HTML Tab properties containing information such as the author’s name, meta data, and the size of the 
document.

For properties relating to the application:
    Preferences



General Tab

The General Tab properties folder lists the files name and size, the date it was created and the date it 
was modified. File attributes are also given.

Other File Properties:
    HTML Tab



HTML Tab

The HTML Tab properties folder provides valuable meta information about published files.

Other File Properties:
    General Tab



    E-mail Integration Requirements
By default, Corel WEB.SiteManager is set up to use MAPI-compliant mail systems for sending e-mail. To
use a non-MAPI mail package , select Preferences on the File menu, then switch to the File Locations 
Tab and choose the “Launch this mail reader” option. Enter the name of the new compliant (or use 
Browse to make a selection) and click OK.
Click here        to see a list of Corel WEB.SiteManager’s templates.

Using Templates

With MAPI, the text for a selected template will automatically be copied into the e-mail message you are 
sending. If another mail system is being used, the text is copied onto the clipboard and must be pasted 
into the e-mail message you are sending.



Templates

Using Templates

With MAPI, the text for a selected template will automatically be copied into the e-mail. If another mail 
package is being used, the text is copied onto the clipboard and must be pasted into the e-mail message.

Click here        to see a list of Corel WEB.SiteManager’s e-mail templates.

Tip
To send a list of files with broken links go to List View and do a multiple select of the files (holding down 
the SHIFT key) and copy the list onto the clipboard. Click the e-mail button on the toolbar and choose the 
Broken Link Notification template. Next, copy the list of files with broken links into the e-mail message, 
select a recipient, and send.



Scanning for Viruses - Overview

To perform a virus scan, click the file or folder in File View. Next, on the File menu, click Scan for Viruses.
Corel WEB.SiteManager automatically detects the McAfee Virus Scan95 if it is present on your system. 
Other virus scanners must be configured in the File Locations Tab.
This feature is only available when the site is opened through File Level Access.



Preferences - Overview

On the File menu, click Preferences. Properties related to the application are divided into four tabs:

General Tab refers to properties relating to use of the Link Wizard and to the properties settings of the 
Browser View.

HTTP Options Tab: is where properties are set if a proxy server is being used.

File Locations Tab: allows you to specify your preferences regarding which HTML Editor, Image Editor 
and Virus Scanner you wish to use and what Mail Editor will be launched.

Link Agent     Tab  : preferences are set on scheduling Corel WEB.SiteManager’s Link Agent and choosing 
what sites to check for broken links.

Messages Tab: allows you to specify which warning messages you wish to receive.

For properties relating to a selected file:
    File Properties 



General Tab

General Tab properties are divided into two sections:

The first of these sections refers the General Tab properties regarding the use of the Link Wizard.
Check the Use Link Wizard option to be prompted whenever an operation is performed that modifies 
hyperlinks between files. Corel WEB.SiteManager provides four Link Wizards:
To have the welcome screen and tip of the day appear when you load SiteManager, make sure that the 
Show Welcome Screen box is checked.

    Moving
    Deleting
    Copying
    Renaming

The second section is where Browser View settings are selected. The options are to use Corel 
WEB.SiteManager’s integrated browser or the system’s default browser. Click here        for more 
information on Browser View.

Other Preferences:
    HTTP Options Tab
    File Locations Tab
    Link Agent Tab
    Messages Tab



HTTP Options Tab

The HTTP Options Tab contains the settings for listing information regarding the Proxy Server . 
This setting is used in certain environments to implement security. For more information on the use of a 
Proxy Server, contact your system administrator.      

Other Preferences:
    General Tab
    File Locations Tab
    Link Agent Tab
    Messages Tab



File Locations Tab

The File Locations Tab properties contains two sections:

File Locations: 
HTML Editor    - Type in the filename of the desired HTML editor or use Browse
Image Editor    - Type in the filename of the desired image editor or use Browse
Virus Scanner    - Type in the filename of the desired Virus Scanner or use Browse

E-mail:
By default, Corel WEB.SiteManager is set up to use a MAPI compliant mail system for sending e-mail. 
To use a non-MAPI mail package , select Preferences on the File menu, then switch to the File Locations 
Tab and choose the “Launch this mail reader” option. Enter the name of the mail system (or use Browse 
to make a selection) and click OK.

Using Templates
With MAPI-compliant mail system is being used, the text for a selected template will automatically be 
copied into the e-mail. If another mail system is being used, the text is copied onto the clipboard and must
be pasted into the e-mail message being sent.

Other Preferences:
    General Tab
    HTTP Options Tab
    Link Agent Tab
    Messages Tab



Link Agent Tab

The Link Agent Tab properties contains two sections:

Scheduling:
Click the Scheduling button to set the time(s) at which you want Corel WEB.SiteManager’s Link Agent to 
run.

Site to Check:
Preferences can be made to establish which site(s) to check for broken links. There is an option to 
choose the site which was last opened or a list of sites to be checked can be created. Entries in the list of 
sites to check must be made on separate lines.

Click here        for more detailed information on the Link Agent.

Other Preferences:
    General Tab
    HTTP Options Tab
    File Locations Tab
    Messages Tab



Messages Tab

By default, warning messages are provided for the following:

When the site level limit has been reached (if a level has been specified).
Before canceling a site read.
Before canceling external link checking.
When a external link checking is complete.

To cancel any of these warning messages, remove the check mark from the appropriate message. 
Warning messages may also be canceled by selecting the “Don’t display this message in future” option 
when the message appears.

Other Preferences:
    General Tab
    HTTP Options Tab
    File Locations Tab
    Link Agent Tab



Tips and Techniques

Corel WEB.SiteManager automatically fixes links while you move files.    All files and their respective links 
are maintained during this process.

Is your Web server getting full? Corel WEB.SiteManager's list of Orphan Documents will show all the files 
that have no links to them.

Remember the title of the document you are looking for but not the file name?    Use the List View to find 
the file you are looking for.

You can use Corel WEB.SiteManager's toolbar filter buttons to reduce the clutter and help you understand
the structure of your Web site.

You can drag and drop files from one directory to another and the links to those files will be    preserved.

Source View offers more power than a simple text editor and allows you to make on-the-fly updates to 
your HTML documents.

Corel WEB.SiteManager can check not only the links within your site but links to external Web sites too.

If you are not sure whether it is safe to delete a file or not, select the document and you will see all 
external and internal files pointing to it and all files and pages it points to.

The Link Wizard instantly recognizes when a file operation will affect links and can fix them automatically.

Corel WEB.SiteManager saves you time by providing e-mail templates that automatically create 
messages that you send frequently.

Check your content before going live. Corel WEB.SiteManager's list of Broken Links will show all the 
documents which need repair.

You can use the F5-F8 keys to quickly switch between the views offered by Corel WEB.SiteManager.

If a page contains broken links, the Source View will highlight them in red.

All of Corel WEB.SiteManager's views stay synchronized as you navigate through your Web site.

Use List View to get a count of the pages on your site.

In the List View, click on a column heading to sort the items by that column. Click again to reverse the sort
order.

Use the Link Agent to automatically check for problems on your Web Site.



 Stop Reading A Site
To stop Corel WEB.SiteManager while it is currently reading a site, press the Stop button on the 
Navigation Toolbar, or select Stop Reading Site from the file menu.

If you stop reading a site before Corel WEB.SiteManager is finished reading it, not all of the links will be 
processed, and SiteManager’s view of your site will be incomplete.



Exiting Site Manager
to exit before Corel WEB.SiteManager select Exit from the File menu,



Saving Source View Changes
After you have edited a web page in SiteManager’s Source View, you must save your changes if you want
to make them permanent.    To save the changes, click on the Save button on the toolbar.

 The Save button on the toolbar is represented by the icon on the right..



Showing Toolbars
If at anytime a toolbar is no longer visible, and you want to bring it back, select the appropriate Show 
Toolbar item from the View menu.    The will cause the corresponding toolbar to reappear.



Link Agent

Corel WEB.SiteManager can locate broken links on a particular Web site using its built-in Link Agent. 
The Link Agent will be started at the time you specify and will analyze the site(s) that you specify.    When 
its analysis is complete, if any problems were encountered, the Link Agent will list them in report format.

Windows 95
The Link Agent is scheduled through the System Agent. To schedule the Link Agent, select the Link Agent
Tab from Preferences on the File Menu or select Scheduling from the Link Agent Menu. Next, click the 
scheduling button and click Yes to display the System Agent.

Windows NT
Within Windows NT, the Link Agent can be scheduled to run using the Windows NT Schedule Service. To 
schedule the Link Agent, first make sure the Windows NT Schedule service is running. You can start the 
Schedule service using the following command: net start schedule. 

Next, select the Link Agent Tab from Preferences on the File Menu or select Scheduling from the Link 
Agent Menu. Use the command-line AT command to schedule the Link Agent to run.    For example, to 
schedule the Link Agent to run every night at 1:00AM, use the following command: AT 1:00AM 
/every:m,t,w,th,f,s,su \Program Files\Corel\SiteManager\LnkAgent.exe

For more information about scheduling applications using the AT command, see your Windows NT 
documentation or on-line help.

Site(s) to Check:
To enter a site to be checked by the Corel WEB.SiteManager Link Agent, select the Link Agent Tab from 
Preferences on the File Menu or select Link Agent Options from the Link Agent Menu.
Choose to examine the site which was last opened or create a list of sites to be checked. Entries in the 
list of sites to check must be made on separate lines.



Checking Links to External Sites - Overview

This feature allows you to ensure that all external links on the current site are valid. There are two options
for checking links to external sites. Corel WEB.SiteManager can either be defaulted to check links to 
external Web sites immediately after the site has been loaded or the links can be verified at a later time 
once the Web site’s pages have been analyzed.

To default Corel WEB.SiteManager to check external links after the site has been loaded, click the 
Check Links to External Pages After Site Load on the External Sites menu. 

If you want to save time in loading the site or only verify external links once modifications have been 
made to the Web pages, then external links can be checked at any time by selecting the Check Links to 
External Pages on the External Sites menu. To stop checking external links at any time select Stop 
Checking External Links on the External Sites menu

To check the status of only one external link, you can right-click on the external link in Page View and 
select Re-Check Link.

The following three symbols are used in Page View and represent how external links may appear:

Symbol Description

Not Validated

Validated and Unbroken

Validated and Broken



The Link Wizard

A dialog box that prompts you to repair broken hypertext links and leave messages when files have been 
moved, copied, renamed, or deleted. Depending on which operation has been performed, one or more of 
the following messages will appear:

Message Description

Automatically repair
affected links

Corel WEB.SiteManager will 
automatically update links to point to the
new location thereby maintaining the 
integrity of the site. This is the preferred 
option since it maintains the integrity of 
the site.

Move the item but 
do not repair any 
links 

This option may be useful if you want to 
fix the links later manually or if you’re 
using another tool to repair the broken 
links.

Leave a “This page 
has moved 
message” in its 
place

Useful if you have moved or deleted a 
page that other people have bookmarks
pointing to. Instead of getting an error, 
they will receive a message informing 
them that the page has moved.

Tip
Click the Details button to obtain information on what links will be affected by the operation.

Corel WEB.SiteManager provides four Link Wizards:

    Moving
    Deleting
    Copying
    Renaming



Synchronizing File View with Others Views

By selecting Keep Views Synchronized on the View Menu, the file that has the focus on the right side of 
the screen will stay synchronized with the file that is selected in File View. 
If the Keep Views Synchronized option has not been selected, it is also possible to synchronize the two 
views by right-clicking the file in File View and selecting Synchronize Views.



SiteBuilder Wizard

The SiteBuilder Wizard will help you quickly create attractive
corporate and personal web sites. This wizard speeds up the creative
process by prompting you to choose from several pre-created
graphics styles and templates. By using these styles you can give your
Web site a consistent, distinctive look. Once you launch the wizard,
you can just follow the wizard's instructions and choose the options
you want.

To launch the SiteBuilder Wizard Click File, SiteBuilder Wizard



FTP

Select the FTP option on the File Menu to transfer files between local and remote computers using the 
FTP protocol.
The file or directory that is selected in the File View will be the default selection when you FTP.



Publish to the Internet

To publish Web documents to the Internet, select the Publish to the Internet option on the File Menu.
The Publish to the Internet option activates a Wizard that will guide you through a process for publishing 
your Web site.    You have the option of choosing several different publishing plans.



Printing
The print option allows you to print either List View or Source View.
By selecting the Print Preview option, you can preview the output before it is printed. Use the Page Setup 
option to change page settings.



Moving Files and Folders 



Deleting Files and Folders



Copying Files and Folders



Renaming Files and Folders



Displays the names of files and folders located on the current Web site It is Located on the left side of 
your screen when either Page View, List View, or Source View is displayed on the right of the screen.



A graphical view of links going to and from the selected file.



Displays the contents (code) of the selected file.



Listing of the files located on the current Web site along with pertinent information about each file.



Displays the selected file as it would be seen by a Web Browser.



Corel WEB.SiteManager’s filters are used to reduce the clutter on the screen. They make it easier to see
the relationships between files or documents. To apply a filter, either click the desired button on the 
toolbar or select it from the View menu.



The file that is located in the center of the Page View screen. Links to and from this file are shown on 
either side



Corel WEB.SiteManager’s Recognized URL’s

Icon File Extensions Description Icon File 
Extensions

Description

.htm
.html

HTML files .xbm X Windows 
Bitmaps

All Files Files not yet 
Parsed

.zip
.gzip

Zipped Files

All Files Broken Links .map Map Files

.gif Compuserve 
Bitmaps

.txt Text Files

.jpg
.jpeg

JPEG Bitmaps Links to FTP

.wav        .av
.snd

Sound Files Links to Gopher

All Files Unknown File 
Types

.exe Binary Files

.pdf Adobe’s Portable 
Document Format

CGI Files

Mail To Links .htm
.html

Moved/Renamed/
Deleted Files



E-mail Templates

Template Description

Blank Message Creates a new e-mail message.

Broken Link Notification Informs the recipient that the selected document(s) have broken 
links.

Content does not 
conform 
to standards

Informs the recipient that the content of the selected documents 
does not conform to the defined standards and requests that the 
file be updated.

Content Has Been 
Approved for Posting

Informs the recipient that that their submitted content is available 
for posting

Content Has Been 
Received

Informs the recipient that that their submitted content has been 
received

Content is Out of Date Informs the recipient that the content of the selected documents is 
out of date and should be updated or removed.

Web site Will Be Down 
for Maintenance

Indicates that the site will be down for maintenance.

Web site will be 
re-organized

Informs the recipient that the Web site will be re-organized.

Web Page Properties

Icon Web Page Includes

                      Frames

                      Java

                      ActiveX

                      Forms




