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No doubt you’re anxious to find out all about Cosmo Worlds—a p
authoring tool for creating exciting interactive 3D content for the W
quick tour of Cosmo Worlds, which takes about two hours to comp
major features of Cosmo Worlds, as well as the typical workflow p
publishing a world for the Web. As you learn about the rich featu
will create a colorful, animated entry sign for your amusement pa

This quick tour is designed for a wide range of users and provide
started quickly. However, unless you are familiar with Cosmo Wo
3D authoring tools, you may want to proceed to the basic tutorial 
detailed explanations and procedures for using this powerful app

What you learn in this lesson
In this chapter, you learn how to:

• Start Cosmo Worlds, open a file, and set up your work area.

• Create, manipulate, and import objects in a scene.

• Create and edit complex objects—points, edges, and polygons

• Change the appearance of objects using materials and texture

• Create a simple animation.

• Add a light and a sound.

• Optimize your world.

• Set navigation information and a viewpoint.

• Publish your world for the World Wide Web.

Hello Worlds
This section describes how to start Cosmo Worlds and provides a 
interface and basic techniques of working in Cosmo Worlds. Model
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can be a challenge. Fortunately, Cosmo Worlds provides an intuitive user interface and 

 by double-clicking 

g installation, start 
 Cosmo Worlds > 

default path C:\
 your pathname for 

s that are organized 
 at this feature-rich 
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powerful tools that make this process much easier. 

Starting Cosmo Worlds

If Cosmo Worlds is not already running on your workstation, start it now
the Cosmo Worlds icon on the desktop. 

If you did not choose to create the Cosmo Worlds desktop shortcut durin
the program from the Task bar. The program file is in Start > Programs >
Cosmo Worlds. 

NOTE:   This tutorial assumes the Cosmo Worlds files are installed in the 
Program Files\CosmoWorlds. If you installed in another location, substitute
the default.

A glance at the user interface

Cosmo Worlds provides many powerful and versatile tools and function
in menus, toolbars, editors, and property sheets. Taking just a brief look
interface can help you work more effectively.
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ms have corresponding 
 dialog windows for user 
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lbar for a second or more. 
oolbars menu. A toolbar 
y default, all the toolbars 

r creating objects less 

t (orthographic)

Outline Editor

Property 
Inspector

(perspective) 
Room viewport
Take a brief look at the interface:

1. The menus contain items and roll-over menus. Some menu ite
buttons on toolbars and/or shortcut keys. Other items activate
input.

Menu items and 
toolbar buttons are 

enabled based on the mode in 
which you are working. This 
lets you know which 
functions are available.

2. Each toolbar contains buttons that activate related tools or fun
displayed when you leave the pointer over a button in the too
Each toolbar can be displayed or hidden through the View > T
can also be undocked and moved to suit your working style. B
are displayed and docked, except the Create Extras toolbar fo
frequently used. 

Menu bar

Status bar

Front viewpor

Toolbars

Top viewport (orthographic) Name of camera view Top viewport (orthographic)
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Perspective mode is 
essential to use while 
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roperty Inspector. 
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scene. The Property 
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bar displays the 
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is is oriented 
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 spacing and 
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creating 3D content. You may 
get surprising (and often 
unwanted) results using only 
2D views.

objects in the scene. The default configuration consists of one main v
Room perspective (3D) view, and two smaller viewports below it w
orthographic (2D) views. The active viewport is outlined in yellow. Y
three other viewport configurations, as well as a camera projection o
viewport and the same camera type in more than one viewport. 

4. The two window areas on the right contain the Outline Editor and P
The Outline Editor shows you a graphical view of the data in the fil
you add and modify objects to the scene, the changes appear in the 
Property Inspector window is blank until an object is selected in the 
Inspector contains pages for setting properties for the object. You ca
of the Outline Editor and Property Inspector through the Editors me

5. The status bar displays informational messages about menu items, t
actions performed in the scene. In the lower right corner, the status 
number of frames per second when rendering, the number of triangl
selected object, and the number of polygons currently displayed in 

Coordinate system and grid

Cosmo Worlds uses a right-handed coordinate system in which the X ax
horizontally, the Y axis vertically, and the Z axis toward you. When the g
X and Z axes are displayed. The Y axis is displayed only when you are ma
in the Y direction. 

To help you model and locate objects in 3D space, Cosmo Worlds provid
grid is displayed by default when you start Cosmo Worlds. You can inter
hide the grid and change some properties associated with it, such as the
orientation, but you cannot relocate the grid. 

+X

+Y

+Z
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the other). Only one 
napping guide, the axes 

 guide, the axes are white. 
hter white. The grid origin 
ult unit for distance. The 

ely useful, letting you 
ndo and Redo options are 
 for these actions—Ctrl+Z 
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ly saves your working file 
journaling facility that 
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oftware\CosmoWorlds\tmp.

ly
n a file and set your 
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Setting up your w

The grid is one of two snapping layout guides (the Snap Target is 
snapping guide can be active at once. When the grid is the active s
are displayed in blue. If the grid is displayed, but is not the active
The other grid lines are drawn in gray, with every tenth line in brig
is 0,0,0, and the default spacing is meters, which is the VRML defa
default grid spacing is 1 x 1 x 1.

Undo and redo options

The undo and redo options provided in Cosmo Worlds are extrem
freely experiment without fear of losing your original state. The U
in the Edit menu, but you will quickly learn to use the shortcut keys
to undo and Ctrl+Y to redo. You can undo and redo up to 100 comm
even across file saves.

NOTE:   Cosmo Worlds provides an auto-save utility that periodical
in your current working directory. Cosmo Worlds also includes a 
records the commands during your session. The journal, called def
temporary directory. By default, it writes to Program Files\CosmoS

Setting up your work area for scene assemb
The detailed lesson 
on setting up Cosmo 

Worlds and assembling a 
scene is in Chapter 1, 
“Assembling Objects in a 
Scene.”

This section describes how to set up your work area. You will ope
working view.

Opening a file

To get started, open the file that contains the grass area for the ani

Open a file:

1. Choose File > Open.
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By default, Cosmo 
Worlds installs on 

2. Navigate to the overview folder, select the file named sign1.wrl, and click the Open button.

e default directory. 
 Also, depending on 
xtension displayed. 
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low.

s

form. Because you 
 which will be your 
hanging the view is 
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iew Mode.

bjects for editing. 
ode to change the 

In this exercise, you 

l, you must closely 
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r screen. 

s
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the C drive. If you installed 
on another drive, substitute 
that drive letter in the path 
for the files in the tutorial.

NOTE:   The pathname for the tutorial files assumes you installed in th
If you installed in a non-default directory, substitute your pathname.
the file view options for your system, you may not see the filename e

The objects are shown in the three viewports, and the data are show
Editor in a graphical view with the current object highlighted in yel

3. Save the file with a different name by choosing File > Save As.

Switching temporarily between selection and view mode

Changing the view 
simply changes the 

camera position and does not 
move the location of the 
objects in the scene.

Now you are ready to start placing objects on the top surface of the plat
can see only part of the front edge of the platform in the Room viewport,
primary working view in the tutorial, you need to reposition the view. C
a fundamental action you perform when authoring 3D content, as is sele
editing. These actions are controlled by two modes—Select Mode and V

If you want to 
change your primary 

mode from Select to View, 
you can choose Camera > 
View Mode or click the hand 
icon in the Camera toolbar.

By default, Cosmo Worlds is in Select Mode. This mode lets you select o
Often while you are editing, you want to temporarily switch into View M
view of the scene to see how objects look from different vantage points. 
learn how to easily switch between modes.

NOTE:   To select objects and manipulate them as instructed in the tutoria
follow the instructions about when and how to change the view. The scre
in this tutorial show you what the view of scene should look like on you

View of object in the three viewport
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e view of platform:

rder to rotate the view:

e Spacebar. Notice that the 
s you are in the Rotate 
 perspective views.

tate the view.

r turns to a zoom icon.

acebar+Shift-drag. The 

 Hold down the Spacebar 
ys. Watch the pointer 

h of the viewports using 
s, use the online help as 

 the working camera view.

ns, and other tasks and 
elp.

m

Setting up your w

Temporarily switch between Select and View modes to reposition th

The pointer changes 
when you switch 

between Select Mode and 
View Mode. In Select Mode, 
the pointer is an arrow. In 
View mode, the pointer 
changes to show which view 
submode you are in while 
navigating.

1. To temporarily switch to View mode while in Select mode in o

• Place the pointer in the Room viewport, and hold down th
single arrow changes to a rotate arrow icon. This indicate
Camera submode, which is the default View submode for

• With the Spacebar still pressed, click-drag the mouse to ro

By default, objects 
are rendered on the 

screen in wireframe mode 
while the view is being 
changed or they are being 
moved. You can change this 
in View > Render Style.

2. To move in or out (zoom), use Spacebar+Ctrl-drag. The pointe

3. To slide right, left, up, or down without rotating (pan), use Sp
pointer turns to a pan icon.

NOTE:   These movements can be done in one continuous step:
and the left mouse button while toggling the Shift and Ctrl ke
change to provide visual feedback for the action.

You can use Ctrl+Z 
to undo and Ctrl+Y 

to redo your actions.

4. Before moving on, play around with changing the view in eac
the Spacebar and modifier keys. For descriptions of the option
described next.

NOTE:   If you are disoriented, you can press the Home key to restore

Using online help

To quickly learn more about the many camera tools, viewing optio
features while you are working in Cosmo Worlds, use the online h

Rotated view of platfor
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Get help on camera tools and viewing options:

Topics and select 

e Index or Find tab 

ement tools
e them in the scene. 
ely size an object 
ce it. Resizing the 
 a good time-saving 

ates a Shape node 
 information about 
tains information 
he size of the object 
 and the center is 
 have created the 

ariety of placement 
sizing, rotating, and 
t let you easily align 

t park and the light 

ructure. You create 
zing, which is a 
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1. To get information through the Contents page, choose Help > Help 
Viewing Objects and Scenes from the list in the window.

2. To get specific information, choose Help > Help Topics, then select th
and enter the word(s) for the search, such as “camera.”

3. To get context-sensitive help while using the tools, press F1.

Basic modeling using primitive shapes and plac
The detailed lesson 
on basic modeling 

using the placement tools is 
in Chapter 2, “Modeling with 
Primitives and Placement 
Tools.”

Cosmo Worlds provides tools to easily create primitive shapes and plac
You create new objects from the four basic primitives. You can interactiv
before you click to place it in the scene, or you can resize it after you pla
object to the desired dimensions before you click to place it in the scene is
technique to learn.

NOTE:   Whatever way you create and size a primitive, Cosmo Worlds cre
and a Transform node for the object in the file. The Shape node contains
the geometry of the object and the appearance. The Transform node con
about the object’s scale, rotation, and location in 3D space. On creation, t
in the Shape node is always the default VRML size for the object’s type;
located in the object’s local space. You can always edit the size after you
object.

To help you easily place objects in the scene, Cosmo Worlds provides a v
tools. These tools include object manipulators (DynaControl tools) for re
moving objects in the scene, as well as guides (Snap Target and grid) tha
objects with the grid or with other objects in the scene.

In this basic modeling section you will create the sign for the amusemen
structure for the spotlight that you will add later.

Creating a cone for the base of the sign

The first object you create is a cone, which will be the base of the sign st
the cone and resize it. First you try to create the cone using interactive si
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e. Creating objects using 
ant to spend the time now 
lace the object in the scene 
 try both ways so you can 

oom viewport without 

box and notice how the 
isual feedback on the grid 
e just yet, but drag it to an 
ee the intersecting lines 

ing motion up and to the 
drag, it becomes larger. 
le with a white handle on 

andle as you move. It is 
 yellow dots on the box, 

d

Basic modeling using primitive 

technique to resize an object before you click to place it in the scen
interactive sizing takes some practice. If you get stuck and don’t w
to practice, you can skip to the next procedure where you click to p
and then change its size, rotation, or orientation. It’s a good idea to
see the difference.

Create a cone and interactively size it:

1. Click the Create Cone button and move the pointer into the R
clicking the mouse button.

The default grid 
spacing is 1 x 1 x 1. 

The cone follows the pointer as you drag. Look at the orange 
object follows the pointer. Move the mouse around to see the v
and other object as the cone moves around. Don’t click to plac
intersection of two grid lines in front of the grass object. You s
turn yellow.

2. Now press and hold the left mouse button and make a sweep
right. The cone initially becomes very small and then, as you 
Don’t release the mouse button yet. Notice the box is now purp
the box. You do not have to place the mouse directly on this h
there to indicate that you can resize the object. Also notice the
that indicate midpoints and ends of the edges. 

Create Cone 

Cone on grid before being resized and place
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n two grid lines so 

g upward to stretch 
e guide is a vertical 
en aligned with the 
ewport to see when 
nits high, you can 
ll hear a creation 

ay between grid lines

DynaBox on cone after 
cone is placed
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The default size of a 
Cone shape is a 

radius of 1 unit and a height 
of 2 units, and is centered at 
its local axis at 0,0,0.

3. Continue to drag until the base of the cone is about half way betwee
that the base has about a 0.5 unit radius. Don’t release yet.

You can turn off the 
audio feedback by 

choosing View > Audio 
Feedback.

4. Without clicking the mouse button, hold down the Shift key and dra
the cone to 4 units high. Watch for the Y axis guide that appears. Th
line with purple dots at 1-unit increments. The dots turn yellow wh
bottom, middle, or top of an object. (You can also watch the Front vi
you have reached 4 units on the grid.) When you have resized to 4 u
release the Shift key and the mouse button to place the cone. You wi
sound when the cone is placed.

Cone gets very small on initial sweep

Cone base with center on grid line and edges halfw

Cone stretched in Y direction
before placed



13shapes and placement tools

ynaBox, is the basic object 
s lesson, you learn how to 
 the sides to move objects.

 the next exercise, “Create 
e procedure where you 

 delete it now by pressing 
 then press the Delete key 

 the Room viewport. Try 
wo grid lines, which will 
llow when the midpoints 
d lines turn yellow when 
tion of the grid. When you 
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When the cone is 
placed in the scene, 

the information that 
describes it is added to the 
Outline Editor. Notice that 
the cone is added as a 
Transform node that contains 
fields describing the location 
and size in 3D space, with a 
Shape node that describes the 
geometry and appearance.

Notice the box that is around the object. This box, called the D
manipulator and is on by default. As you proceed through thi
use the handles of the DynaBox to resize and rotate objects and

If you want to try another way of creating the same object, perform
a cone and size it after placing in scene:.” Otherwise, proceed to th
create the sphere for the sign on page 15.

Create a cone and size it after placing in scene:

1. If you have a cone in your scene already and it’s still selected,
the Delete key. If the cone is not selected, click it to select it and
to delete it.

2. Click the Create Cone button and move the cone to the grid in
to center the bottom surface of the cone at the intersection of t
make it easier to resize later. You will see one grid line turn ye
of the edges are aligned with a grid line. You will see both gri
the midpoint of the bottom surface is aligned with the intersec
see this, click to place the cone.

The DynaBox may 
appear slightly 

different on your screen. 

Notice the DynaBox now surrounds the cone.

Cone on grid before being placed

DynaBox on cone



14

Use the DynaBox to resize the cone:

lf its size by moving 

nge.

otice the purple 
x has lots of colorful 

e familiar with the 

d using the sides of 
w the outline turns 
ject. To move the 
front side of the 
ou can also watch 

t. To stretch the cone 
dle on the DynaBox 
efault). Notice the Y 
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1. Use the DynaBox to uniformly resize the object about its center to ha
the handle inward:

• Put the pointer over a white handle. Notice the handle turns ora

• Click-drag a white handle on a corner of the DynaBox inward. N
arrows that let you know which way you can move. The DynaBo
visual feedback to guide you as you resize objects. You will becom
color scheme as you work with objects.

To use the sides of 
the DynaBox to 

move an object: click-drag to 
move freely in a plane, 
Shift-drag to move parallel 
along a line, Ctrl-drag to 
move perpendicular to a 
plane. You may want to refer 
to the Cosmo Worlds Video 
Tour for a visual and audio 
demonstration of how these 
tools work

2. As a result of resizing, the cone is off the grid; move it back to the gri
the DynaBox. Put the pointer on the side of the DynaBox and see ho
orange. Again, visual feedback helps guide you as you move the ob
bottom surface of the cone to the grid, click-drag downward on the 
DynaBox until there is a yellow dot at the base of the Y-axis guide. Y
the Front viewport for alignment.

3. Now that the cone is back on the grid, you can easily resize the heigh
while keeping on the grid, put the pointer over an upper white han
and then Shift+Ctrl-drag upward to a height of 4 units (meters, by d

Click-drag on white handle of DynaBox 
to resize object uniformly about its center

Click-drag on side of DynaBox to move object 
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ervals, the same as the X 
u can also watch the Front 

-unit radius, which is the 

 move the pointer into the 
 grass object.

ve
Basic modeling using primitive 

axis guide line with dots on it. These markers are at 1-unit int
and Z grid lines. Release when the cone is 4 units tall. Again, yo
viewport for alignment.

Creating a Sphere for the top of the sign

You now create the sphere for the top of the sign. Create it with a 1
default, and then slightly flatten it to achieve the final shape.

Create a sphere:

• To create a sphere for the sign, click the Create Sphere button,
Room viewport, and click to place it on the grid in front of the

Ctrl+Shift-drag on white handle of DynaBox to mo
object along Y axis while anchoring opposite side

Create Sphere button

Default sphere on grid
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Using the DynaBox to resize and rotate the sphere

you will notice, the 
 handles and the 

lso use the green 

andle turns orange 
e than half way 
ng the X axis only. 
riginal size.

egrees. As you start 
ws an arc from the 
ees, which makes it 
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The DynaBox will now be used to both resize and rotate the sphere. As 
DynaBox is quite a versatile object manipulator. You have used the scale
sides of the DynaBox for moving and resizing. In this section you will a
rotate handles to rotate the sphere.

Use the DynaBox to flatten the sphere:

When you want 
exact measurements 

for objects, you can set the 
grid spacing or enter the 
dimensions in the Outline 
Editor.

• To flatten the sphere, put the pointer over a front white handle. The h
when the pointer is over it. Then, Shift-drag sideways to a little mor
between the two grid lines. The sphere is resized about its center alo
The final diameter of the sphere should be about two-thirds of the o

Use the green handles of the DynaBox to rotate the sphere:

The rotation guide is 
displayed only when 

the grid is the active 
snapping guide.

• To rotate the sphere, click-drag the front green handle to the left 90 d
to move, you see a purple rotation guide with a yellow line that dra
starting point of the rotation. The guide has tick marks every 15 degr
easy to move 90 degrees. 

Shift-drag white handle of DynaBox 
to resize sphere along the X axis

Click-drag green rotate handle of DynaBox 
and use rotation guide to rotate 90 degrees
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ou can move a selected 
 the Snap Target to move 

(or choose Placement > 
e tip of the cone. When 
e Snap Target. The Snap 
at the axes lines of the 

 of the cone. Make sure 
n the Placement toolbar 
e Snap Target on the tip 
Basic modeling using primitive sh

Using the Snap Target to align the cone and sphere

Another helpful placement tool is the Snap Target. With this guide y
object easily to the surface of another object. In this exercise, you use
the sphere to the tip of the cone you created earlier.

Use the Snap Target to align the sphere with the cone:

1. Click the Activate Snap Target button in the Placement toolbar 
Set Active Guide > Snap Target) and move the Snap Target to th
you see a yellow dot appear on the tip of the cone, click to place th
Target is now the active placement guide, not the grid. Notice th
grid turned from blue to white.

If you have trouble 
placing the Snap 

Target on the tip of the cone, 
put the Snap Target near the 
middle of the cone’s surface 
and then glide it up until you 
see the yellow dot appear on 
the tip of the cone.

2. Now you will align the bottom surface of the sphere with the tip
the sphere is still selected, and click the Move To Guide button i
(or choose Placement > Move To Guide). The sphere snaps to th
of the cone.

Activate Snap Target 

Snap Target placed on tip of cone

Move To Guide 
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oolbar for the Text 
 to edit the default 

and sign structure.

te Extras.

 and click to place it.

ras toolbar window.
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3. Choose File > Save to save the file.

Creating text for the sign

Now you will make the text for the sign. First, you need to display the t
creation tool. Then you create the text object, and use the Outline Editor
values of the text object to change the character string and the style. 

Choose your file:

• Continue with your file or open sign2.wrl, which contains the grass 

Create a text object for the sign text:

1. To display the Create Extras toolbar, choose View > Toolbars > Crea

2. Click the Create Text button, then drag the text object into the scene

3. Click the X on the right side of the title bar to dismiss the Create Ext

Bottom surface of sphere’s DynaBox
snapped to Snap Target on tip of cone

Create Text 

Text object placed in scene
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 you will change the text 
 style of the text. The 
 main Cosmo Worlds 

e text:

e highlighted text object 
 box, enter a name for the 
dio feedback to indicate a 

 the string field, click the 
 press Enter. The text 

 Then click the following 
Basic modeling using primitive 

Using the Outline Editor to edit the text

By default, the 
Outline Editor is 

docked in the upper right of 
the main window. This editor 
can be resized, undocked, or 
hidden to suit your working 
style.

The Text creator simply lets you add a text object to the scene. Now
by using the Outline Editor to change the character string and the
Outline Editor, which is the window in the upper right area of the
window, follows and highlights the selection in the scene.

Use the Outline Editor to change the character string and style of th

1. Make sure the text object is selected in the Outline Editor.

It’s good practice to 
name the nodes in 

your file. As you add nodes, 
you will appreciate being 
able to easily identify them. 
Also, the Outline Editor lets 
you perform searches by 
node type or by name, so it’s 
very helpful to have 
descriptive names.

2. Click the right mouse button on the bold Transform label of th
and select Edit Node Name from the popup menu. In the text
text object, such as “sign_text,” and press Enter. You’ll hear au
change was made.

3. Click the “+” next to the “T” icon to open the node. Then click
“Text” field and enter “COSMO WORLD” in the text box, and
changes in the scene.

See your favorite 
VRML reference for 

all the possible Text node 
field values.

4. Click the “+” next to the “A” icon to open the FontStyle node.
field names, fill in the specified value, and press enter:

Text object in the Outline Editor

Field Value

family SANS
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 structure:

e center of the text 

f cone:

ject’s DynaBox 

style BOLDITALIC
Hello Worlds—An Overview

Use the Snap Target and Move Center To Guide to snap the text to the sign

• The Snap Target is still on the tip of the cone. Use it again to move th
object to the tip by clicking the Move Center To Guide button.

Use DynaBox to uniformly resize text and to align sign with Snap Target on tip o

1. To uniformly resize the text, click-drag a white handle of the text ob
sideways to about 4-5 units in length.

justify MIDDLE

New text values in Outline
Editor displayed in scene

Move Center To Guide

Use Move Center To Guide to move
the center of the text to the tip of cone



21shapes and placement tools

ard on a side of the 
e DynaBox. This highlight 
Snap Target on the cone. 

p Target

rass. You will move the 
g them to the Snap Target.

r on the grass, click-drag 
r it and yellow when you 
e edge of the marker, but 

ck to place it.

n Shift-click the cone to 
 DynaBox is around the 
r master, selection. Also 
round the other two 

ecause it is the primary 

p Target
Basic modeling using primitive 

The Snap Target 
provides feedback 

when for aligning objects. 
When the edges or midplane 
of an object is aligned with 
the Snap Target, a yellow 
plane highlight appears.

2. Move the text into its final position by Shift-dragging downw
DynaBox until you see a yellow highlight on the top plane of th
appears when the surface of the DynaBox is aligned with the 

3. Use File > Save to save your file.

Selecting and moving multiple objects with the Sna

Use the Snap Target again to move the sign to the marker on the g
pieces simultaneously by first selecting them all and then snappin

Sometimes the Snap 
Target is obscured by 

an object after snapping. You 
can sometimes access it in 
another viewport, or you can 
click the Activate Snap Target 
button to turn it off and then 
click again to turn it on and 
drag it into the scene. Yet 
another way is to choose 
Placement > Set Active Guide 
> Snap Target twice.

1. To move the Snap Target from the tip of the cone to the marke
the gray hub. The handle turns orange when the pointer is ove
move. You will see a yellow dot when the Snap Target is on th
don’t worry about exact placement of the Snap Target, just cli

2. The text should still be selected. Shift-click the sphere, and the
select them all. The order of selection is important. Notice the
object you selected last. This object is known as the primary, o
notice the blue boxes, indicating multiple selections, that are a
objects. 

NOTE:   The order in which you select the objects is important b
selection on which the operation will act. 

Top edge of Text aligned with Sna

Three objects in sign selected
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3. Click the Move To Guide button to move the sign to the marker (or choose Placement > 
get. (If you selected 
igned with the Snap 
of on top.)

n structure because 

 guide for the scene. 
w explicitly set an 
 the grid or Snap 
 to set the active 

 structure

ark sign, use a box 
m another box, and 
one.

 grass and sign with 
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Move To Guide). The bottom surface of the cone snaps to the Snap Tar
one of the other objects last, the bottom of its DynaBox would have al
Target, resulting in the objects being embedded in the grass instead 

4. Click the Activate Snap Target to turn off the Snap Target. 

Notice in the Front viewport that the grid lines are in front of the sig
these objects are now behind the axis line.

NOTE:   When you turned off the Snap Target, you turned off the active
The grid is still displayed, but it is not the active guide. You must no
active guide using Placement > Set Active Guide. Or, you can toggle
Target off and on again using their buttons in the Placement toolbar
guide, which you will do later.

5. Choose File > Save to save the file.

Creating and cloning a box to make the posts for a light

To create the light structure to support the spotlight that shines on the p
for one of the two posts and then clone it. You create the middle piece fro
then you complete the light structure by creating a light fixture from a c

Choose your file:

• You can continue with your file or open sign3.wrl, which contains the
text.

Sign objects snapped to Snap Target
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> Set Active Guide > Grid. 

f the grass, and click-drag 

ointer on the front surface 
rns yellow when the edge 

 viewport by clicking the 
era > View Selection). 

n object changes the pivot 
you rotate the view the 
oo close.

t by choosing 
eractive placement here 
x so you can easily keep 
Basic modeling using primitive 

Set the grid as the activate guide:

If the grid is 
displayed, but is not 

currently the active guide, 
one way to make it the active 
guide is to click the Activate 
grid button to turn off the 
grid, and then click the 
button again to turn the grid 
back on.

• To activate the grid as the placement guide, choose Placement 

Create a box and use View Selection to center it in the viewports:

1. Click the Create Box button, move the box to the grid in front o
to uniformly size it to about 0.5 unit.

Depending on the 
size and location of 

the selected object, View 
Selection might place the 
object too close for you to 
work comfortably with the 
object. If this happens, use 
Spacebar+Ctrl to zoom out 
from the object.

2. Align the right side of the box with a grid line by placing the p
of the DynaBox and Shift-dragging to the right. The grid line tu
of the DynaBox is aligned with it.

3. To work on the box easily, bring the object to the center of each
View Selection button in the Camera toolbar (or choosing Cam

In addition to moving the object to the center, the View Selectio
point in the scene to the center of the selected object so when 
scene will rotate around this object. Zoom out if the object is t

Clone the first box and place the clone non-interactively:

1. The box should still be selected. If not, select it.

2. To clone the box, choose Edit > Clone. 

3. Before you paste the clone, turn off Interactive Paste Placemen
Edit > Interactive Paste Placement. You do not want to use int
because you want the clone to be put directly on top of the bo
them aligned when you move the clone.

Box uniformly resized to 0.5

View Selection 
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4. To paste the clone, choose Edit > Paste Clone. You will hear a creation sound and the 
ou do not see the 

nit to the right to 
id will highlight 
u now have the 

ture. The piece is 
 created.

ou see the edges 
s that the new 
of the new box is 
e new box when 

he post it’s 
ards the aligned 
er post (which 

ally aligned with 
 on the right 
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DynaBox changes because the clone becomes the selected object; but y
second box, because it’s placed directly on top of the first one.

When using the 
DynaBox to move an 

object, make sure you place 
the pointer away from the 
white and green handles; or 
you will end up resizing or 
rotating the object. 

5. Put the pointer on the front surface of the DynaBox, and Shift-drag 1 u
create a 1-unit gap between the inner surfaces of the two boxes. The gr
yellow when the left edge of the clone’s DynaBox is aligned with it. Yo
two posts for the light structure.

6. Save the file.

Creating and aligning the middle piece

The final piece of the light structure is a middle piece that holds the light fix
made from a box that is resized and placed between the two posts you just

Create a box between the posts and use DynaBox to resize it:

1. Click the Create Box button and drag the new box between the posts. Y
of the inner surface of the right post highlight in white, which indicate
object will align itself with this surface. You can also see that the center 
aligned with the inner surface of the one of the boxes. Click to place th
you see the yellow dot at the center of the post.

2. To keep the side of the middle piece aligned with the inner surface of t
attached to, Ctrl+Shift-drag the white handle on the opposite corner tow
side. Move this side until you see it align with the inner edge of the oth
should also align with the grid). For example, if the middle piece is initi
the inner surface of the left post, then Ctrl+Shift-drag the white handle
corner to the left.

Shift-drag the DynaBox of
the clone to move it
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es, turn off the grid as the 
e.

 and Shift-drag to make it 
te the view and Shift-drag 

 together. Grouping is a 
s in a scene.

o select it. Then Shift-click 
 You will see the DynaBox 

, rotate the view or zoom 

 Notice that one DynaBox 
Basic modeling using primitive 

3. Because you don’t want the middle piece to snap at the grid lin
active guide by choosing Placement > Set Active Guide > Non

4. To shrink the middle piece, place the pointer on a white handle
fit between the upper and lower edges of the posts. Then rota
a white handle sideways to resize the depth.

Grouping the objects and using DynaBox to rotate

To rotate and move the light structure easily, you group the pieces
common technique for organizing and easily manipulating object

Group the three objects of the light support structure:

1. The middle piece should still be selected. If not, click the piece t
to select one post, and Shift-click again to select the other post.
on the objects change as the pieces are selected.

NOTE:   If the DynaBox on the middle piece obstructs the posts
out until you can pick the posts.

2. Choose Edit > Group As Siblings to group the pieces together.
now surrounds the group.

Ctrl+Shift-drag DynaBox 
of middle piece to align it

Shift-drag 
DynaBox
vertically

Shift-drag 
DynaBox
horizontally
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ment > Set Active 

 then click-drag 
e as you move. 

ed group

 Target. The 
he DynaPlane next 
dy tool for moving 

 left front corner of 
 in the Placement 

o rotate 45 degrees

dle
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Use the DynaBox to rotate the structure 45 degrees in place:

1. Before you rotate the group turn the grid back on by choosing Place
Guide > Grid.

The rotation guide 
will not display 

unless the grid is the active 
guide.

2. Place the pointer over a green rotate handle on a side of the post and
clockwise to rotate the structure 45 degrees. Watch the rotation guid

Using the Snap Target and DynaPlane to move the rotat

To move the light structure group to the grass area quickly, use the Snap
placement of the Snap Target doesn’t need to be exact because you use t
to move the structure exactly where you want it. The DynaPlane is a han
an object perpendicular or parallel to other objects.

Use the Snap Target to move the light structure group to the grass:

1. Click the Activate Snap Target; and then drag the Snap Target to the
the grass, and click to place it. Now click the Move To Guide button
toolbar to snap the structure to the grass.

DynaBox around new group

Use rotation guide t

DynaBox rotate han

Move to guide
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get.

ace of the grass:

 the DynaPlane control to 
k the Toggle DynaPlane 
lick-drag to move the light 

he Top viewport to help 
the Top viewport first to 

y clicking the Toggle 

his fixture is used later as 
ht the sign.

 Grid.

t relative to a plane
Basic modeling using primitive 

2. Click the Activate Snap Target button to turn off the Snap Tar

Use the DynaPlane to move the rotated structure parallel to the surf

1. If you don’t like the location of the light structure, you can use
move the rotated object relative to the grass surface. First, clic
button and put the pointer over the surface of the grass. Then c
structure around to a position you like. 

As you move in the Room viewport, you may want to watch t
guide you. (You may need to zoom in using Spacebar+Ctrl in 
get the grass into the view.)

2. When you have positioned the structure, turn off DynaPlane b
DynaPlane Translation button.

3. Save the file.

Using a cone to create the light fixture

Now create the light fixture itself by interactively creating a cone. T
the geometry for the spotlight that you will add to this scene to lig

Use a cone to create the light fixture:

1. Activate the grid by choosing Placement > Set Active Guide >

DynaPlane

Use DynaPlane to move objec
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2. Click the Create Cone button and drag the cone onto the grid in the Room viewport. 
ntil the base is about 

o elongate the cone 
 corner of the Y axis 

h is too far.

g a white handle on 
Box downward to 
ngate the cone.

pport structure

port structure. The 

ucture:

 the DynaDot to the 
low dot, which 
ce, click to place the 

e pointer on the 
move the cone. The 
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Without clicking to place the cone, click-drag to sweep out the cone u
a 0.25-unit radius. Don’t click to place yet.

3. Press and hold the Shift key and then drag a white handle upward t
to a length of about 0.75 units. If you see a yellow dot in the upper left
guide line, you have dragged to the 1-unit mark on the Y axis, whic

To resize the cone after creation: click to place it on the grid, click-dra
the DynaBox to uniformly resize it, Shift-drag a surface of the Dyna
place it on the grid, and then Ctrl+Shift-drag an upper handle to elo

Using the DynaDot to place the tip of the cone on the su

Now use the DynaDot control to place the tip of the cone on the light sup
DynaDot lets you easily align a point on an object with another object.

Use the DynaDot to place the tip of the cone on the middle piece of the str

1. Click the Toggle DynaDot button in the Placement toolbar and drag
center of the top surface of the cone’s DynaBox. When you see a yel
indicates that the DynaDot is aligned with the midpoint of the surfa
DynaDot.

2. Rotate the view so you can see the top of the light structure. Place th
magenta handle of the DynaDot. It turns orange. Now click-drag to 

Elongated cone on grid

DynaDot



29shapes and placement tools

 DynaDot “flip” the cone, 
h another object. Drag the 
he tip of the cone on the 
 move the cone in front of 
se in placing the tool 
o play around with it.

toggle off the DynaDot.

e middle piece a little bit.

 have a couple more short 
, edges, and polygons 
Basic modeling using primitive 

handle turns yellow as you start to move, and you will see the
anticipating that the point of its attachment is to be aligned wit
DynaDot to the front edge of the structure, and click to place t
edge when you see the edge highlight yellow. You may need to
the middle piece and then bring it back up to the edge. The ea
depends on the angle of the view—you sometimes just have t

3. Click the Toggle DynaDot button in the Placement toolbar to 

4. Shift-drag on the top of the DynaBox to move the cone into th

5. Choose Camera > View All to see how your scene looks

6. Save the file.

You have now finished the basic modeling section of this tour. You
sections, importing a file and a brief introduction to editing points
(PEPs), and then you‘ll be about half finished.

DynaDot flips the object and
attaches it to the other object

Cone moved into middle piece 
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Importing and cloning an object
t you would like to 
n easily import the 
eated previously in 
, which means, you 
e object is 

)

) is an efficient way 
py, a clone inherits 
have to be repeated 
 the original object.

ere to place it in the 

nu bar and looking 
ck next to the item, 
ked, select the item 

wrl in the dialog 

ass area on the right 
ant.
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The detailed lesson 
on importing and 

cloning objects in Cosmo 
Worlds is in Chapter 1, 
“Assembling Objects in a 
Scene.”

In addition to creating new objects, you may have existing 3D objects tha
reuse. If the file is saved in a format that Cosmo Worlds supports, you ca
objects into your scene. In this section, you will import a tree that was cr
Cosmo Worlds. When you import the tree, you will place it interactively
will control the placement. (When you use non-interactive placement, th
automatically placed at the location in which it was originally modeled.

Cosmo Worlds 
imports several file 

formats: Cosmo Worlds 1.0, 
VRML 1.0 and 2.0, and 
Inventor. When you import a 
file, the contents are copied 
into the current file.

After the tree is placed, you will clone it. Cloning (also called instancing
to keep down your file size. A clone is different from a copy. Unlike a co
the geometry and appearance of the original, so the information doesn’t 
in the file. Like a copy, a clone can have a size and location different from

Using Interactive Import Placement to import a tree

When you use interactive placement to import an object, you control wh
scene, just as you did when you created primitives.

Use interactive placement to import the tree:

1. Make sure interactive placement is on by choosing File from the me
at the state of the Interactive Import Placement item. If there is a che
it is on; and you can simply click to dismiss the menu. If it is not chec
and release to dismiss the menu.

2. Import the file by choosing File > Import, selecting the file sign_tree.
window, and then clicking the Open button.

The default mode for 
importing a file is 

non- interactive placement. 
You can toggle this on and off 
by choosing File > Interactive 
Import Placement.

The tree appears in the scene under the pointer. Drag the tree to the gr
and front of the sign. Move the tree and click to place it where you w

Imported tree placed on platform
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nt to place it

ractive paste placement to 
rt, that is you control the 

oking at the state of 
an simply click to dismiss 
iss the window.

e tree to place it in front of 

er an upper white handle 
 while you shorten it; and 
the tree.
Imp

Cloning a tree and using Interactive Paste Placeme

To make the second tree easily, clone the first one and then use inte
place it. Interactive paste works the same way as interactive impo
placement of the object in the scene.

Clone the tree and interactively paste the clone:

The default paste 
mode is interactive 

placement. You can toggle 
this on and off by choosing 
Edit > Interactive Paste 
Placement.

1. To clone the tree, choose Edit > Clone.

2. Make sure interactive placement is on by choosing Edit and lo
Interactive Paste Placement. If it is checked, it is on and you c
the menu. If it is off (not checked), select it and release to dism

Once an object is 
cloned, there is no 

“original.” All instances are 
equal.

3. To paste the clone, choose Edit > Paste Clone and then drag th
and to the right of the first tree.

Use DynaBox to resize the second tree:

1. Use the DynaBox again to resize the clone. With the pointer ov
on the DynaBox, Ctrl+Shift-drag to anchor the tree to the grass
then release the Ctrl key and Shift-drag the handle to narrow 

2. Save your file.

Second tree resized
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Using basic PEP modeling to create capped posts
reate many 
nd somewhat 
 for you to easily 

ount to a minimum.

n its individual 
will split the top 
 light structure. 

y would look much 
ve polygons, you 
ated the posts from 

object using the tool 
 polygons. 

en you click on the 
 select objects in a 

you need to select 
 the parent, and the 
Select Child.
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The detailed lessons 
on working with 

PEPs are in Chapter 6, 
“Working with Points, Edges, 
and Polygons,” and 
Chapter 7, “PEP Precision 
Modeling with Placement 
Tools.”

So far you have been using basic shapes and imported objects. You can c
interesting objects using primitives, but this is often polygon-intensive a
limiting. Como Worlds provides a set of powerful tools that make it easy
manipulate objects into interesting shapes while keeping your polygon c

In this section you will see how you can take a box primitive and work o
points, edges, and polygons (PEPs) to easily manipulate the shape. You 
surface of a box and pull up the center point to make a capped post for a

Converting primitive shapes to PEP objects

The posts of the light structure are functional, but not very attractive. The
nicer with a simple cap finish. To create this effect without using excessi
convert the posts to their individual points, edges, and polygons. You cre
a simple box primitive that was cloned. Now you convert them to a PEP 
that transparently converts an object to its individual points, edges, and

Cosmo Worlds uses 
parent/child 

hierarchy to organize objects. 
You see a graphical 
representation of the 
hierarchy in the Outline 
Editor. 

The posts are part of the light structure group you created earlier, so wh
post, you will actually select the group. This exercise shows you how to
group.

Select the group and use View Selection to center it in the viewports:

1. Click one box to select it. Notice that you select the entire group, so 
down in the hierarchy to select just the box. The group is considered
box is a child of the parent group. To select the box, choose Select > 

Child box selected
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ne depends on the current 
election Policy highest, 
sform. You will learn later 

iewport by clicking the 
era > View Selection). 

n object changes the pivot 
you rotate the view the 

bject button in the PEP 
e any change in the object 

oints, edges, or polygons. 
led PEP Edit Mode. When 
object. The post is a clone, 
fore you enter PEP Edit 

t Child. Both instances are 
Using basic PEP mod

Depending on the 
size and location of 

the selected object, View 
Selection might place the 
object too close for you to 
work comfortably with the 
object. If this happens, use 
Spacebar+Ctrl to zoom out 
from the object.

What you select when you click on a grouped object in the sce
state of the Selection Policy. The default in Cosmo Worlds is S
which means you will select the object at its highest level Tran
how to change the state of the selection policy.

2. To work on the structure easily, bring it to the center of each v
View Selection button in the Camera toolbar (or choosing Cam

In addition to moving the object to the center, the View Selectio
point in the scene to the center of the selected object so when 
scene will rotate around this object.

Convert the post to a PEP object:

• To convert the post to a PEP object, click the Convert To PEP O
toolbar, which is on the left side of the viewports. You don’t se
in the scene.

Entering PEP Edit Mode

After an object is converted to a PEP object, you can edit any of its p
To do this, you must be in a special edit mode in Cosmo Worlds cal
you enter PEP Edit Mode, you will see an orange box around the 
so you must make sure you have all the instances of it selected be
Mode.

Select both clones and enter PEP Edit Mode:

1. To select the second instance of the clone, choose Select > Selec
now selected.

View Selection 

Convert To PEP Object Convert To PEP Object 
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2. In the PEP toolbar, click the PEP Edit Mode button. You should see an orange outline 
nger surrounds the 
 DynaPlane control 
Plane, which is a 
sses over them.

ore you can pull up 
the corners so when 
plit the surface into 
 is not the effect you 

 same changes are 
mation.

u are too close to an 
select a polygon, all 
Hello Worlds—An Overview

around one box to indicate you are in PEP mode. The DynaBox no lo
box because PEP Edit Mode automatically disabled it and enabled the
tool. When you pass the pointer over the surfaces, you see the Dyna
four-headed arrow, and you see the PEPs highlight as the pointer pa

When you are in PEP 
Edit mode, the 

pointer is the PEP Edit Mode 
icon; and the default 
DynaControl is the 
DynaPlane, which is used to 
move objects relative to 
planes.

.

Splitting a polygon with the Split to Both Corners tool

To create the capped post, you need to pull up the center of the post. Bef
this point, you must create it. To do this, you will split the top surface to 
you pull the point, the edges will align with the corners. If you simply s
four rectangles, the splits would be at the midpoints of the edges, which
want.

Because this object is a clone, when you convert and edit one object, the
applied to the other. Remember, clones share the same geometrical infor

Select and split the top surface of the post:

Cosmo Worlds uses a 
closed polygon 

connectivity model, in which 
all edges of the polygon must 
be connected.

1. If you can’t see the top of the post, rotate the view.

2. Click in the middle of the top surface to select the top polygon. If yo
individual edge or point, you will select only that edge or point. To 
edges around it must be highlighted. 

PEP Edit Mode button

Pep icon

DynaPlane

PEP edit box

x+y=z
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ation of what is currently 
ction is black with white 
lights if the pointer is not 
r a PEP, but it is not 

ol in the PEP toolbar. The 
a common point at the 
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The color scheme of the PEP edit mode selections are a combin
selected and where the pointer is placed. The current PEP sele
highlights if the pointer is over it, and black with yellow high
over it. Blue with white highlights indicates the pointer is ove
selected.

The selected PEPs 
are shown in black. 

When the pointer is over the 
PEPs, the highlight is white, 
when the pointer is over 
other PEPs, the highlight is 
yellow.

3. Split the top surface by clicking the “Split To Both Corners” to
selected polygon is now equally split into four triangles with 
center of the top of the post.

Selected polygon

Split To Both Corners

Polygon split to both corners
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Pulling up a point using the DynaPlane tool

s. To easily perform 
th the other 
ovements. You can 

ar to a plane. In this 
 sides of the post.

s), and put the 
arallel to the front 

point freely, but you 

he file.

this scene, and now 
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terials and textures 
rmats that are 
 that are best for the 
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The DynaPlane 
arrows provide color 

feedback and arrow heads for 
the directions you can move 
when you use the Shift or Ctrl 
modifier keys.

Common PEP editing tasks include moving PEPs relative to other surface
these moves, Cosmo Worlds provides the DynaPlane control tool. As wi
DynaControl tools, you can use the DynaPlane to perform a variety of m
use it to move a PEP freely in a plane, parallel to a plane, or perpendicul
exercise you will move the center point of the top surface parallel to the

Use DynaPlane to pull up the center point:

Another way to pull 
this point is to move 

it perpendicular to the top 
surface by selecting the point, 
putting the pointer on the top 
surface, and then using 
Ctrl-drag.

1. Click the center point to select it (which also deselects the other PEP
pointer over the front surface. Now Shift-drag to pull up the point p
surface about 0.5 unit. If you don’t use the Shift key, you can pull the 
can’t be sure it’s parallel to the sides.

2. To exit PEP edit mode, click outside the orange box, and then save t

Congratulations! You’ve finished creating and assembling the objects in 
you can enhance these objects by applying materials and textures to the

Changing the appearance of objects
The detailed lesson 
on using materials 

and textures is in Chapter 3, 
“Using Materials and 
Textures.”

You can create interesting and appealing objects quickly by applying ma
to the objects you have created. Cosmo Worlds supports many image fo
standard formats supported in VRML browsers. You should use formats
Web: PNG, GIF, JPEG.

Pull up the center point
parallel to the sides
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 apply materials from the 
d through the Material 
aterials from the material 

 edit a material to create a 

ns the sign, trees, and light 

n, then Shift-click the 

 which occupies the lower 
aterial Palette by default.

election

ction
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Applying materials

By default, the 
Property Inspector is 

docked in the lower right area 
of the main window. This 
editor can be hidden or 
undocked to suit your 
working style.

To enhance the appearance of objects in your scene quickly, you can
many palettes in Cosmo Worlds. The material palettes are accesse
Palette in the Property Inspector. You apply a variety of different m
palettes to the sign and light structure objects. You also apply and
custom effect. 

Choose your file:

• You can continue with your file or open sign5.wrl, which contai
structure and fixture.

Apply a material from the metal palette to the base and top of the sign:

1. In the Room viewport, click the cone that is the base of the sig
sphere to select it also. 

2. When you select an object in the scene, the Property Inspector,
right area of the main Cosmo Worlds window, displays the M

Blue line indicates secondary s

DynaBox indicates primary sele

Material Palette tab

A material palette
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3. In the Material Palette, select the “metal” palette by clicking the down arrow in the box 

rth row of the metal 

g the down arrow 
 of the sheen palette, 

aterial:

ou click the middle 
lection policy is set 
 middle piece is a 

he selection policy 
. The middle piece 

n arrow next to the 
ial, click the second 
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and selecting the name “metal.” 

If you don’t like the 
effect of the material, 

use Ctrl+Z to undo and select 
another material. You can 
also replace the current 
material by applying another 
one directly over it.

4. To apply the material to the objects, click the second sphere in the fou
palette. The material appears on the objects in the scene.

Apply a material to the text sign:

1. Click the COSMO WORLD sign to select it.

2. In the Material Palette, select the “sheen” material palette by clickin
next to the list box and selecting “sheen” from the list. In the fifth row
click the sixth sphere to apply the purple material to the text.

Select only the middle piece of the light structure group and apply a blue m

1. Click the middle piece of the light structure to select it. Notice when y
piece to select it, you actually select the group. This is because the se
to select the highest level in the hierarchy for the object. Because the
member of a group, the group is selected. 

2. To select only the middle piece of the light structure group, change t
from highest to lowest by choosing Select > Selection Policy Lowest
should now be the only one selected.

3. In the Material Palette, select the “santefe” palette by clicking the dow
list box and selecting “santefe” from the list. To apply the blue mater
sphere in the second row of the palette.

COSMO WORLD sign selected

Selection policy changed from highest
to lowest to select child in group
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aterial from the santefe 

 apply the material. The 
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 open the Material Editor, 

ir display on the screen. In 
aracteristics to see the 

k the second sphere in the 
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Apply a material to a clone:

1. To see the effect of applying a material to clones, apply a tan m
palette to the fence posts. Click one fence post to select it.

2. Click the first sphere in the fourth row of the santefe palette to
material is applied to both posts simultaneously. Remember, c
appearance information, so when you apply a material to one
instances of the clone.

Applying and editing a material

You can customize the materials in the material palettes to create j
editing their properties in the Material Editor. As you see when you
materials contain many characteristics besides color that affect the
this exercise, you change the color, and then play with the other ch
effect.

Apply and edit light fixture material:

1. Click the cone on the light structure to select it.

2. In the Material page, select the metal material palette and clic
fifth row.

3. To display the Material Editor, click the Material Editor tab, w
the left.

One clone selected at lowest selection p
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 middle of the color 
 as well as the cone 

her characteristics. 
ess field by 

e directly in the text 

lter the 

 use to make your 
tly and edit them to 
 a palette and then 
te to the posts and 
to adjust how it fits 
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If you don’t like the 
effect you created, 

use Ctrl+Z to undo.

4. To change the color to slightly more red, click-drag the square in the
wheel to the right. Watch the color change on the object in the editor
in the scene.

5. Use the sliders or type in values for the other fields to change the ot
For example, to change how shiny the object appears, edit the Shinin
click-dragging the slider next to the field name or by entering a valu
field. 

NOTE:   You will not see the effects of the ambient slider unless you a
ambientIntensity of a new light in the Outline Editor.

Applying textures

In addition to materials, Cosmo Worlds provides many textures you can
objects more interesting and life-like. You can apply these materials direc
change their appearance. You can also add your own custom textures to
apply it. You apply two textures in this section: one from a default palet
one custom texture to the sphere. Then you will edit the custom texture 
on the sphere.

Apply texture from a default texture palette to light support posts:

1. Click one post to select it.

Material Editor tab

Color wheel
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 row of the Gray Scale 1 
. Applying a grayscale 
han a plain grayscale 

 objects, such as this 

er, your standard image is 

orer) on your system, and 

e palette is full, a window 
dialog window may pop 
ow if you can’t see the 
Changin

2. Click the Texture Palette tab, and elect the last tile in the third
palette to apply the texture over the material of the fence post
texture over a material makes a much more interesting effect t
texture. This is an economical way to create special effects for
wood-grain appearance.

Editing a texture

You would like everyone to see your logo as they walk in. Howev
not the right size for the sphere, so you need to adjust it to fit.

Adding a texture to the palette:

1. To add a texture to the palette:

• Open the file browser window (such as Windows NT Expl
navigate to the overview folder.

• Click-drag the file logo.png to the texture palette. Because th
pops up and asks you if you want to create a palette. The 
up behind the file browser, so minimize the browser wind
dialog box.

One clone selected 

Texture applied

Texture Palette tab
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2. To create the palette, type in a name and click OK. The palette appears in the Texture 

The logo is applied, 
urface of the sphere.

 sphere. Click the 
re.
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palette page.

Editing a custom texture

1. Click the sphere to select it, and then click the logo tile in the palette. 
but you can see that it doesn’t fit very nicely—it “distorts” to fill the s

2. To fit the texture on the sphere, change its size and position it on the
Texture Editor tab to display the page that lets you modify the textu

Logo texture added to new palette

Texture fills surface of sphere
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d T boxes. You won’t see 
texture to the surface, so 

ter 0.25 in the 
e field. The image moves 
nt.

 and vertical directions. In 
enter the image. The final 
 size of your sphere. (You 

 the center!)
Changin

3. In the Repeat section, click the boxes to uncheck both the S an
any change in the texture in the scene, but this will clamp the 
the pattern won’t repeat to fill the object.

4. Reduce the size of the image by changing the scale values. En
S: Repeat/Scale field, and then enter 0.5 in the T: Repeat/Scal
on the sphere, and may not be visible in your view at this poi

5. Center the image on the sphere by moving it in the horizontal
the Translate S and T fields, move the slider bars to the left to c
values, which should be around -0.38 and -0.26, depend on the
can use the green rotate handle of the DynaBox as a guide for

6. Save the file.

Texture Editor tab

Fields for setting repeat or scale values
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Animating 3D objects
o Worlds provides 

bout the Keyframe 
 opposite directions, 

e file is loaded in a 

open the sign6.wrl, 

new animation, and 

r button (or choose 

 (or choose 
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The detailed lesson 
on animation is 

Chapter 4, “Animating 
Objects and Properties.”

Animation is a key factor in creating an interactive, life-like world. Cosm
a sophisticated animation tool called the Keyframe Animator. To learn a
Animator, you animate the text sign and sphere to rotate continuously in
and you set the trigger to be world entry so the animation starts when th
browser.

Choose your file:

You can continue with the sign file you’ve been working on, or you can 
which includes the content created to this point.

Setting up a new animation for the sign

To create a new animation sequence, open the Keyframe Animator, add a 
set up the parameters for the animation. 

Open the Keyframe Animator and set up a new animation:

1. To open the Keyframe Animator, click the Toggle Keyframe Animato
Editors > Keyframe Animator).

By default the 
Keyframe Animator 

window is docked below the 
viewports. You can undock 
the window by 
double-clicking the double 
line on the left edge of the 
Keyframe Animator window, 
and then locate the window 
that’s best for your working 
style.

2. In the Keyframe Animator toolbar, click the New Animation button
Animation > New). 

The Animator Properties window is displayed.

Toggle Keyframe Animator 

Animation New Animation 
menu
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r. The name is now 
e Animator. It’s really 

easily identify them.

the number of frames 
value is not related to the 

the animation continue to 

 scene is loaded, click the 
3. In the Animation page, fill in the following values:

Press Enter after 
typing characters, or 

change the pointer focus to 
update the fields in the 
Animator Properties pages.

• In the Name field, type in the name “sign” and press Ente
displayed above the Master Timeline label in the Keyfram
important to name your animations uniquely so you can 

• In the Length field, type in 80 and press Enter.

• In the Frames per second field, leave the value 10. This is 
displayed in the animation timeline for each second. The 
frame rate when the animation is viewed.

• Click the check box in the Loop Animation field. This lets 
play while the scene is in the browser.

4. To create a trigger that causes the animation to start when the
Trigger page tab, and then click the World Entry button.

World Entry trigger 
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5. Dismiss the Animator Properties window now by clicking the X in the right corner of the 

 Zoom To Fit button 
gnifying glass with 
mes to fit into your 

 the left of the Zoom 

e. The timeline 
nts of five.

h is next to the New 
e Animator. Notice 

ts and properties 

 Transform label, 
d entering 
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its title bar.

6. To display all 80 frames in the Keyframe Animator window, click the
in the Keyframe Animator toolbar. The Zoom To Fit button is the ma
a two-sided arrow. This button automatically sizes the animation fra
window. If the view is too small for you, use the Zoom Out button to
to Fit button.

NOTE:   Your window might display different numbers on the timelin
adjusts the display of numbers to the size of the window in increme

Adding the text object as an actor in the sign animation

Now that the animation is set up, add the text object as an actor. 

Add the text object as an actor:

1. In the Room viewport, click the COSMO WORLD text to select it.

It’s really important 
to name the objects in 

your scene, so you can easily 
identify them in the 
Keyframe Animator. 
Unnamed objects are simply 
added using the Transform 
label, so if you have many 
unnamed actors, you will 
have difficulty identifying 
the actors.

2. Choose Animation > Add Actor (or click the Add Actor button whic
Animation button). The actor and its timeline is added in the Keyfram
the unnamed Transform is added. When an actor is added, all objec
underneath it are eligible to be animated.

3. Edit the name of the Transform in the Outline Editor by clicking the
right-clicking the bring up the menu, selecting Edit Node Name, an
“sign_text” in the text field.

Zoom To Fit
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ce

rames. In VRML you can 
at the rotation happened 
te four keyframes at 
ion for each frame in 

 by alternating between 
sing the following steps:

ed frame.

 click-dragging its yellow 

rid.
Creating the keyframes for the text rotation sequen

The text sign animation you create is one complete rotation in 80 f
rotate only 90 degrees at a time for one keyframe and be certain th
in the right direction, so to create a complete rotation you will crea
20-frame intervals. The Keyframe Animator will calculate the mot
between the keyframes for you.

The general procedure for creating each keyframe is accomplished
the Keyframe Animator window and the object in the viewport u

• In the Keyframe animator, move the scrub bar to the desir

• In the scene, pose the actor. 

• In the Keyframe Animator, record the event.

Create the keyframes for the text sign rotation:

You can also move 
the scrub bar by 

clicking in the gray area in the 
Master Timeline above the 
frame number, or by entering 
the frame number in the 
Frame text field in the menu 
bar.

1. In the Keyframe Animator, move the scrub bar to frame 20 by
diamond-shaped handle.

2. Active the grid by choosing Placement > Set Active Guide > G

Actor

Scrub bar moved to frame 20
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3. In the scene, rotate the text sign 90 degrees by click-dragging the green rotate handle on 
 the actor line turns 

n because it is very 
cebar+Ctrl to zoom 

button in the 
d at frame 0 in 
sents the initial 
 keyframe, and the 

ing the sign another 

ing the sign another 

ntly selected (red)

t selected (blue)
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the DynaBox of the text to the left. Notice that the red button next to
red to indicate that an event occurred.

NOTE:   You may want to use the Top viewport to perform the rotatio
easy to see the rotation guide in this view. You may need to use Spa
out to see the guide in the viewport. Rotate clockwise.

A red marker 
indicates the 

currently selected 
keyframe(s). A blue marker 
indicates keyframes that are 
not currently selected.

4. In the Keyframe Animator, record the keyframe by clicking the red 
sign_text’s timeline. Notice when you do this, a keyframe is recorde
addition to the keyframe at frame 20. The keyframe at frame 0 repre
position of the object. The red marker indicates the currently selected
blue marker indicates a keyframe that is not selected.

5. Record the next keyframe by moving the scrub bar to frame 40, rotat
90 degrees in the same direction, and recording the keyframe.

6. Record the next keyframe by moving the scrub bar to frame 60, rotat
90 degrees in the same direction, and recording the keyframe.

Rotating the sign 90 degrees in the Top viewport

Keyframe recorded at frame 20 and curre

Keyframe automatically recorded at frame 0 and currently no
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tly where it started the 

e marker at frame 0 in the 

en choose Keyframe > 

nimator. You can play the 
e Animator. To test the 
t your scene will look like 

ied to frame 80
Copying a keyframe

To record the final position and make sure the object ends up exac
rotation, copy the keyframe at frame 0 to frame 80.

Copy the keyframe at frame 0 to frame 80:

1. To create a copy of the initial keyframe, click the blue keyfram
“sign_text” timeline; and then choose Keyframe > Copy.

2. To paste the keyframe, move the scrub bar to frame 80; and th
Paste.

Testing the animation

To see how the animation looks, first play it back in the Keyframe A
animation in the scene by pressing the Play button in the Keyfram
trigger, use the Cosmo Worlds Preview feature so you can see wha
on the Web. Preview uses the Cosmo Player browser by default. 

Keyframe at frame 0 cop
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Play back the animation to test it:

layback button (or 
 blue arrow) in the 

which is the square 

. 

ols. You will learn 
n it is loaded in the 

iew title bar.

ion

ding them as actors 
tion you just made, 
 as fast and in the 

 Window
Hello Worlds—An Overview

1. To start the animation at the beginning, click the left double arrow p
move the scrub bar to frame 0), and then click the Play button (right
Keyframe Animator toolbar. You should see the text sign rotating.

The animation will continue to play until you click the Stop button, 
button in the center of the playback controls.

2. Save the file.

Use Preview to test the trigger:

1. Choose View > Preview or click the Toggle Preview Window button

If Preview 
encounters a 

problem in the file, such as a 
missing file, a blinking 
yellow or red set of lights is 
displayed on the dashboard 
control. Click the light to 
display the warning or error 
messages.

2. The Cosmo Player window opens. The text sign should be rotating.

NOTE:   To navigate in the Preview window, use the dashboard contr
later how to set a viewpoint to position the view of your world whe
browser.

3. Dismiss the window by clicking the X in the right corner of the Prev

Adding the sphere as a second actor in the sign animat

You can include separate objects and animate them independently by ad
in an animation. In this exercise, you add the sign’s sphere to the anima
and then you create separate keyframes for the sphere so it rotates twice
opposite direction of the text.

Toggle Preview

Text sign spinning in Preview window

Dashboard controls
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gn animation by choosing 
 the Add Animation 

ng the Transform label, 
e, and entering 

tion at that frame in the 

reen handle on the 
e “sign_sphere” actor line 

cord the event. The event 
eyframe at frame 0.

, rotating the sign 90 

, rotating the sign 90 

ing the scrub bar to frame 
Add the sphere as a second actor:

1. In the scene, click the sphere to select it.

2. In the Keyframe Animator, add the sphere as an actor in the si
Animation > Add Actor (or click the Add Actor button next to
button). The unnamed Transform is added to the animation.

3. In the Outline Editor, edit the name of the Transform by clicki
right-clicking the bring up the menu, selecting Edit Node Nam
“sign_sphere” in the text field.

Record the keyframes for the sphere’s rotation:

1. To make the first keyframe:

• Move the scrub bar to frame 10. The text moves to its posi
animation.

• Rotate the sphere counter-clockwise by click-dragging a g
DynaBox to the right 90 degrees. The red button next to th
turns red to indicate an event occurred.

• Click the red button next to the sign_sphere actor line to re
keyframe is recorded at frame 10 and the initial position k

2. Create the next keyframe by moving the scrub bar to frame 20
degrees, and recording the keyframe.

3. Create the next keyframe by moving the scrub bar to frame 30
degrees, and recording the keyframe.

4. To complete the first rotation, create the next keyframe by mov
40, rotating the sign 90 degrees, and recording the keyframe.

Sphere 
added
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mes to create the 

he line for this actor:

elect it

eyframe > Copy.

 paste the four 

tor. You can trigger 
igger, you must use 
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Copying multiple keyframes

To finish the animation sequence for the sphere, copy the existing keyfra
remaining ones.

Copy keyframes to finish animation for the sphere:

1. To make the rest of the keyframes, copy the ones you just created in t

• In the “sign_sphere” actor line, click the marker at frame 10 to s

• Shift-click the markers at frames at 20, 30, and 40; and choose K

• Move the scrub bar to frame 50, and choose Keyframe > Paste to
keyframes that complete the animation.

Playing back the animation in the Keyframe Animator

See how the animation looks by playing it back in the Keyframe Anima
the animation in the scene only by pressing the Play button. To test the tr
the Preview feature.
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rrow playback button (or 
 (right blue arrow) in the 
the sphere rotating in 
e text.

utton, which is the square 

le. If you don’t, the current 
imation.

r left corner of the 
e Animator button in the 

iew window.

ight the COSMO WORLD 
nt park crowd. Lights and 
points and sensors. These 
o not appear as objects in 

objects. You will again use 

ill align the light with the 

7.wrl.
Test the animation:

1. To start the animation at the beginning, click the left double a
move the scrub bar to frame 0), and then click the Play button
Keyframe Animator toolbar. You should see the text sign and 
opposite directions, with the sphere rotating twice as fast as th

The animation will continue to play until you click the Stop b
button in the center of the playback controls.

2. Rewind to frame 0 before you close the window and save the fi
position of the scrub bar becomes the starting point for the an

3. Close the Keyframe Animator by clicking the “X” in the uppe
Keyframe Animator window, or by clicking the Toggle Keyfram
Editors toolbar.

4. Save the file.

5. Use Preview, if you want to preview the animation in the Prev

Adding lights and sounds
The detailed lesson 
on adding lights and 

sounds is in Chapter 5, 
“Adding Lights and Sounds.”

To create a realistic environment for your scene, add a spotlight to l
sign and an ambient sound that simulates the noise of an amuseme
sounds are parts of a group of “special objects” that includes view
items are represented in the scene in Cosmo Worlds by icons, but d
browsers. Visitors to your scene see only the effects of these special 
the sign file. 

Adding a spotlight for the sign

You now add a spot light to light the sign area of the scene. You w
conical light fixture and point it at the sign.

Open the sign file and create a spot light:

1. Either continue with the sign file you’ve created, or open sign
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2. In the Create toolbar, click the Create Spot Light button, drag the light icon into the scene 
light and hear a 
oint, but you should 

p Target on the end 
e Snap Target to the 
ve To Guide button 

.

reen rotate handle 
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near the light structure, and click to place it. You see an icon for the 
creation sound. The exact position of the light doesn’t matter at this p
rotate the view so you see the end of the cone.

3. To snap the light to the cone on the light structure, first place the Sna
of the cone by clicking the Activate Snap Target button, dragging th
cone, and clicking to place it on the end of the cone; then click the Mo
(or choose Placement > Move To Guide).

 

4. Turn off the Snap Target by clicking the Activate Snap Target button

5. Rotate the light to align it with the light fixture by click-dragging a g
of the DynaBox until the light icon is in a line with the cone.

Create Spot Light 

Spotlight on platform

Spotlight snapped to
Snap Target
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out the tip:

ate the objects together by 

y, you can either hide the 
ing box isn’t in the way.

e light. You will use the 
one as you did previously 

 the scene, and orient the 
oup about the tip of the 

ble orienting the 
b until it’s the right 
e tip of the cone, and then 

round, see its effect on 
s final position.

l.
Select the light and the light fixture and use DynaWheel to rotate ab

1. Select the light fixture along with the light icon so you can rot
Shift-clicking the light fixture. 

NOTE:   If you can’t select the cone because the light is in the wa
light temporarily or change your view until the light’s bound

The DynaWheel lets 
you rotate an object 

about an arbitrary point in 
the scene. By default, the 
DynaBox rotates an object 
around its center.

Now you can rotate the pieces together to properly position th
DynaWheel to rotate the light and fixture about the tip of the c
when you created the cone.

2. Click the Toggle DynaWheel button, drag the DynaWheel into
DynaWheel on the middle piece so you can rotate the light gr
cone. 

NOTE:   Aligning the DynaWheel can be tricky. If you have trou
DynaWheel, move it around by click-dragging the middle hu
orientation, then hold the Ctrl key, move the DynaWheel to th
click to place before releasing the Ctrl key.

3. Click-drag a green handle to rotate the light. As you move it a
objects in the scene. Orient the light toward the text sign for it

4. Click the Toggle DynaWheel button to turn off the DynaWhee

Spotlight in line with cone

Tip of cone rotated using DynaWheel 
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Turn off the light icon:

e light, but usually 
w > Show Special 

bient sound that is 
udio file, as well as 

tmusic.wav in the 

ppears in the scene 

The sound icon and 
e audible range 
re in audible range.

 minBack)

Back)
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Each time you create 
a light, all the light 

icons in the scene are 
displayed.

1. The icon for the light is handy to have when you are working with th
you want these icons hidden. To hide the light icon now, choose Vie
Objects > Show Lights.

2. Save the file.

Adding an ambient sound

To simulate the background noise of an amusement park, add a global am
triggered when the file is loaded in the browser. A sound consists of an a
information about the sound’s source, location, and direction. 

Add a sound:

Each time you create 
a sound, all the 

sound icons in the scene are 
displayed.

1. Click the Create Sound button, and double-click the filename ambien
“Choose a sound” window.

After you select the file, the window dismisses and the sound icon a
under the pointer.

2. Move the sound icon into the scene and click to place it on the grass. 
range indicator are rendered in the scene. (Zoom out to see the entir
indicator.) You won’t hear the sound until you preview the file and a

Create Sound

Full-intensity range sphere (minFront and

Audible range sphere (maxFront and max
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 and start at world entry:

pand it and then click the 
 clicking “spatialize” and 
es the sound to be 

dioClip icon to expand it, 
e the following fields:

UE by clicking the “loop” 
he field for editing. Enter 

ry), change the startTime 

button. 

the Preview window. You 

Preview Window
Use the Outline Editor to edit the Audio Clip node to loop the sound

1. In the Outline Editor, click the “+” next to the Sound icon to ex
Sound icon to show all the fields. Change the spatialize field by
then clicking “TRUE” and changing it to “FALSE.” This chang
non-directional, or ambient.

2. To edit the AudioClip information, click the “+” next to the Au
and then click the AudioClip icon display all the fields. Chang

• To play the sound continuously, change the loop field to TR
field name and then clicking the “FALSE” value to open t
“TRUE” in the text field.

• To have the sound start when the file is loaded (world ent
field to 0.

Use Preview to test the sound:

1. Choose View > Preview or click the Toggle Preview Window 

2. The sound should start playing as soon as the file is loaded in 
may not hear it until you move closer to the sign.

Set startTime to 0 to trigger sound on entry

Set loop to TRUE to play sound continuously

Set spatialize to FALSE for ambient sound

Toggle 
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Hide the sound icon:

 the sound, but 
se View > Show 

nsideration of the 
unt models, image 

 with your work in 
leting extraneous 

ct from a flat planar 
he two trees so they 

de is added to each 
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1. The icon for the sound is handy to have when you are working with
usually you want these icons hidden. To hide the sound icons, choo
Special Objects > Show Sounds.

2. Save the file.

Optimizing the scene
The detailed lesson 
on optimizing is in 

Chapter 8, “Optimizing Your 
World.”

Optimization is a reiterative process that starts with good design and co
requirements for producing content for the Web, such as low polygon-co
and sound formats, and so forth. However, there is a lot that you can do
progress. A few of these techniques are presented here: billboarding, de
polygons, level of detail modeling, and inlining.

Billboarding the trees

Billboarding is a technique you can use to create the illusion of a 3D obje
object through rotation about an axis. In this section, you will billboard t
rotate around the Y axis and give the illusion that they are “full” trees.

Choose your file:

• You can continue with your file or open sign8.wrl.

Billboard the trees:

Clones are identified 
in the Outline Editor 

by a number after their 
Transform label. The number 
displayed is the number of 
instances of the clone in the 
file.

1. Click one of the trees to select it, and then Shift-click the other.

2. Click the Insert Billboard button in the Create toolbar. A Billboard no
trees.

Insert Billboard
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. To see this, you can look 
 Billboard tab.

ate to face you all the time 

 reduce the polygons in 
t see the base of the sign, 
ce the polygon count 
 object must be converted 
 light fixture.

xis
3. By default, the billboard is created to rotate around the Y axis
at the Billboard page in the Property Inspector by clicking the

4. In the Room viewport, rotate the view to see how the trees rot
to give the illusion of a 3D object.

5. Save the file.

Deleting extraneous polygons

Another technique for improving performance of your world is to
your scene. The base of each cone contains 16 polygons. You don’
which is on the grass, so you can delete the polygons here to redu
without affecting the scene. Before the polygons can be deleted, the
to a PEP object. You can also delete the polygons on the end of the

Billboard tab

Y axis set as axis of rotation (default)

Billboarded trees rotated about Y a
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Convert the conical base of the sign to a PEP object and delete the polygons on the bottom:

ut the X axis so you 

ss is actually in the 
ass, choose View > 

n in the PEP toolbar. 

nge PEP edit box 

rag the paint brush 
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1. Click to select the cone base of the sign, and then rotate the scene abo
can see the bottom of the cone.

Cosmo Worlds uses 
backface culling, a 

process that eliminates 
drawing polygonal faces 
whose normals point away 
from the viewer. To change 
the backface culling property, 
select the object and use the 
Faceset Properties page in the 
Property Inspector.

2. Although you can see the bottom, you can’t select it because the gra
way. It’s not being drawn because of backface culling. To hide the gr
Hide Unselected objects. Then choose Camera > View Selection.

3. Convert the cone to a PEP object by clicking the Convert to PEP butto
You see no change in the scene.

4. Enter PEP Edit Mode by clicking the PEP Edit Mode button. The ora
appears around the cone.

5. To select the polygons easily, click the Paint Select button and click-d
icon over the end of the cone to select the all the polygons.

Bottom of cone

x+y=z

Convert To PEP Object 

PEP Edit Mode 

Paint Select 



61Optimizing the scene

 PEP toolbar (or press the 

 then show all the objects 

 to select it.

button in the Camera 
en rotate the scene so you 

st did for the sign cone: 
P button, enter PEP mode 
ton to select the polygons, 
d polygons. You see 
s on.
6. To delete the polygons, click the Delete Polygon button in the
Delete key). 

7. Click in empty space in the scene to get out of PEP mode, and
in the scene again by choosing View > Show All Objects.

Delete the polygons at the end of the light fixture cone:

1. Rotate the view so you can see the light fixture cone, and click

2. Choose Camera > View Selection (or click the View Selection 
toolbar) to bring the cone to the center of the viewports, and th
can see the end of the cone.

3. Select and delete the polygons on the end of the cone as you ju
Convert the cone to a PEP object by clicking the Convert to PE
by clicking the PEP Edit Mode button, use the Paint Select but
and then click the Delete Polygons button to delete the selecte
“through” the cone from this angle because backface culling i

4. Choose Camera > View All and then save the file.

Cones selected with Paint Select tool

Delete Polygons 

View SelectionView All
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Using level of detail (LOD) models

 create different 
etail (LOD) models 
are far away. You 
te, and then you 

 then group them 

 right-clicking the 
from the menu, and 

n in the Create 
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An effective way to optimize the rendering of objects in your world is to
levels of detail for the objects in your scenes. You can use high level-of-d
when visitors are close to the objects, and low-detail models when they 
create a low detail model using your high-detail sign model as a templa
create an LOD with two levels of detail. 

Create a high-detail group:

1. Select all the objects in the scene by choosing Select > Select All, and
together by choosing Edit > Group As Siblings.

2. In the Outline Editor, name this new group “CWSignHighDetail” by
Transform label of the selected group, selecting “Edit Node Name” 
entering the name in the text field.

Insert an LOD:

1. Insert an LOD grouping by clicking the Insert Level-Of-Detail butto
toolbar.

All objects selected 
and grouped

Insert Level-Of-Detail
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 node is added to the 
 Property Inspector, your 

ess Enter.

he group. After you insert 
plicate the current model. 
odel.

here you want to see the 
tically calculated from the 
isn’t right, you can change 

 in the scene, but the LOD 
l, and the copy is added to 

ange
The LOD page is displayed in the Property Inspector, and the LOD
Outline Editor. (If you have other property sheets or editors in the
window will have the tabs for them showing also.)

2. In the LOD name field, enter the name “CWSignLOD” and pr

When you insert the LOD, a Transform node is created above t
the LOD, the LOD editor provides a function that lets you du
You then edit the duplicated model to create the low-detail m

Adjust view for LOD range and duplicate the current level of LOD:

LODs switch only in 
perspective 

viewports.

1. In the Room viewport, zoom out until you are at a distance w
high-detail and low-detail models switch. The range is automa
view in the Room (or other perspective) viewport. If the range 
it later in the LOD editor.

2. Click the “Duplicate Current Level” button. You see no change
editor places a copy of the model directly on top of the origina

LOD name field

Zoom out to set view for LOD r
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the Outline Editor under the LOD Transform. Scroll down to see the second Transform 

nd instance of the 
ou might have to 
ighDetail.”

-detail version. A 
e, the high-detail 

ders 16, so this 

r by clicking the 
diting the model, 
the sign structure.

n the low-detail 
form labels of the 

eate the objects 
w-detail versions 

 sign, use the 

o CWSignLowDetailo CWSignLowDetail
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labeled “CWSignHighDetail.”

3. In the Outline Editor, rename the copy of the model by clicking the seco
“CWSignHighDetail” name and changing it to “CWSignLowDetail.” Y
scroll down in the Outline Editor to see the second copy of “CWSignH

To collapse the nodes 
in the Outline Editor, 

click the “-” next to the 
Transform icon.

Creating a low-detail version from the duplicated level 

The LOD is inserted and now you can edit the duplicated model into a low
good rule of thumb is to use at least a 10:1 ratio of polygons. In this exercis
sign model renders 643 triangles on the screen, and the low-detail one ren
model is optimized quite nicely.

Select the low-detail pavilion for editing:

When working with 
LODs, always start 

with the highest level and 
work out to the lowest level.

1. If the low-detail model is not still selected, select it in the Outline Edito
bold Transform label for “CWSignLowDetail.” Now you can work on e
which is first deleting objects and then creating a low-detail version of 

2. Use the Outline Editor to delete the pieces you don’t want to include i
version, which is everything except the grass. To do this, click the Trans
objects to select them, and press the Delete key.

Create the low detail version of the sign:

1. Zoom in so you can work easily with the cone and sphere. You will cr
using the high-detail version as a template and then you will add the lo
to the low-detail Transform group.

2. To create the triangle object for the low detail version of the base of the
Create Face tool to create a piece that represents the cone:

Second Instance of CWSignHighDetail renamed tSecond Instance of CWSignHighDetail renamed t
(figure shows nodes collapsed in Outline Editor)
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g the face into the scene in 
 straight, then hold down 
 yellow dot appears at the 
ce.

white handle of the 
ne. Then stretch the height 
t+Ctrl-dragging an upper 

center of the edge to create 
tail version. To enter PEP 

.

• Click the Create Face button in the Create toolbar and dra
front of the cone. If the face flips, move it around until it is
the Ctrl key and move it to the front of the cone. When the
middle of the bottom edge of the cone, click to place the fa

• Narrow the width of the face by Shift-dragging an upper 
DynaBox sideways until it is the width of the base of the co
of the face to the same height as the tip of the cone by Shif
white handle of the DynaBox.

Use PEP Edit Mode to make a triangular shaped face:

1. Use PEP edit mode to move the two upper corner points to the 
a tip for the new triangle that represents the cone in the low-de
Edit Mode, click the PEP Edit Mode button in the PEP toolbar

Create Face

Face placed in front of cone

Face stretched to height of cone
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en click-drag the 
ke sure the pointer 
p select.

to create a triangle.

 into the scene and 
to hold the Ctrl key 

ragging inward on 
+Ctrl-dragging 

PEP Edit Mode 
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2. Click the point on the left upper corner of the face to select it, and th
point inward to the tip of the cone, following the line of the cone. Ma
is over the face when you start to drag; if it’s not, you will do a swee

3. Select the point on the right upper corner, and move it to the center 

4. Click in the scene outside the orange box to exit PEP Edit Mode.

Create a face for the sphere:

1. Click the Create Face button in the Create toolbar and move the face
place it on top of the triangular face you just created. You may need 
again after orienting the face. The logo may show through partially.

2. Resize the face to align with the outer edges of the sphere by Shift-d
an upper white handle to the diameter of the sphere, and then Shift
downward on an upper handle.

Point on upper left corner
selected and moved to center

Corner points moved to center
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ar face to select them both.

the second sphere in the 
ent than the high-detail 
esn’t reflect the same.

tail” Transform. Then 
wDetail” group.

d “CWSignLOD” to select 
se Spacebar+Ctrl to zoom 
ail versions switch. By 
m the camera distance 

ou can zoom out and then 
Apply material to low detail sign objects:

1. With the rectangular face still selected, Shift-click the triangul

2. In the Material Palette page, select the metal palette and click 
fourth row to apply the material. The material will look differ
cone and sphere because these surfaces are flat so the light do

Group the two faces with the low-detail model:

3. In the Outline Editor, Shift-click to select the “CWSignLowDe
choose Edit > Add Sibling to add the faces to the “CWSignLo

Test the LOD:

1. To test the LOD switching, click the LOD Transform label name
the LOD, and zoom in and out to watch the models switch. U
in and out to see the range where the high-detail and low-det
default, the distance was automatically calculated for you fro
when you create the LOD.

2. If you want to add an empty level when you are far, far away, y
check the Add Empty Level button.

Face in front of sphere

LOD switch between high-detail
and low-detail models
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3. If you want to change the range, you can use the LOD editor. Uncheck the Auto-calculate 
, to verify the 
s.

r efficiency is to 
that you want to 
ost browsers 

n inline file can 
 together in one 

 in the Cosmo 
e for the 
 the park, which 

.wrl and click the 

e you will place 

re Interactive 
port Paste item. 

enu.
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level box, change the view, and click the Match Camera Distance. Then
switching, check Auto-calculate on and zoom in and out to see the LOD

4. Save the file.

Using inlines 

Inlines are useful for 
organizing your 

world into files and reducing 
file size of the main world 
file.

When you have a large world with many objects, one way to organize it fo
use inline files. An inline is a reference to an external file containing objects 
include in your world, but that don’t need to be displayed immediately. M
display the data in the file first, and then download the data in inline files. A
also be used to organize the objects in your world efficiently by keeping them
file and reducing the file size of the main file.

You can move, 
rotate, or resize the 

objects in an inline file within 
Cosmo Worlds, but you can’t 
edit the objects unless you 
fold the inline into the scene. 
After you edit, you can 
convert it back to an inline. 

This exercise shows you how to incorporate the sign with rest of the scenes
World amusement park. You import the sign as an inline file in the main fil
amusement park world. The main file also contains inlines for other scenes in
were created previously.

Open the file for the park world and import the sign as an inline:

1. To open the file for the world, choose File > Open, select Park_noCWsign
Open button.

2. Zoom out so you can see the blue marker on the platform. This is wher
the sign.

3. To control the placement of the inline file when you import it, make su
Import Placement is on by choosing File and looking at the Interactive Im
If it is not checked on, select it. If it is checked on, simply dismiss the m
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nline and selecting the 
u created, use sign9.wrl, 

ing you before you click 
line aligns itself with the 

he front edge of the blue 
e, click to place the inline 
e objects may switch 

ts
ong if they can’t get 
 add navigation 
ore your world. The park 
 this exercise, you create 
ors navigate around the 

 visitors in your world to 
an let visitors navigate in 
ploring your world, such 
Adding navigation

An inline file is 
referenced as a URL.

4. Import the sign file as an inline by choosing File > Import As I
name of your sign file (if you don’t want to use the sign file yo
which contains a completed sign model).

5. Move the sign to the blue marker and make sure its front is fac
to place it. As with other imported objects, the box around the in
edges of the other objects in the scene. Move the pointer over t
marker. When the yellow dot appears in the middle of the edg
in the correct orientation. Because the sign contains an LOD, th
between the two levels as you are moving it around.

 

6. Save the file.

Adding navigation information and viewpoin
The detailed lesson 
on navigation and 

viewpoints is in Chapter 9, 
“Adding Navigation 
Information and 
Viewpoints.”

Even the most visually exciting world won’t interest visitors very l
around in it. To help your visitors navigate in your world, you can
information and viewpoints to make it easy and fun for them to expl
file already has viewpoints set for the scenes except for the sign. In
one for the sign, and you add navigation information so your visit
park.

Creating and setting navigation style

Navigation information tells the VRML browser how you want the
navigate and what the physical dimensions of the avatar are. You c
any style, or you can limit them to certain styles appropriate for ex



70

as flying. The scenes in the park were created for visitors with human dimensions, so you will 

on Info button. 

ange in the scene, 
spector displays the 

. This name is for 
tifying the node, 

lows any type of 
ion in your scene, 

 only walk style in 
bably want visitors 

ation. If you allow 
at is initially set in 
t changes it.
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set the navigation information accordingly. 

Create navigation information:

1. In the middle section of the Create toolbar, click the Create Navigati

The NavigationInfo node is added to the scene. You don’t see any ch
but the node is highlighted in the Outline Editor, and the Property In
NavigationInfo pages.

Set the navigation style:

1. In the displayed page, enter a name for the NavigationInfo text field
your information only. It appears in your file and is helpful for iden
especially if there are multiple navigation nodes in your file.

2. In the Allowable Style field, click the “Any” box. The Any option al
navigation in the scene. When you want to limit the type of navigat
click one or more of the other boxes. It might be appropriate to allow
the Cosmo World park, but because it is an amusement park, you pro
to be able to do almost anything!

3. In the First Choice field, leave WALK as the preferred style of navig
other navigation styles in this scene, the preferred style is the one th
the VRML browser and remains the style until the viewer or a scrip

Create Navigation Info
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 provides the default light 
ur own lights, especially 

ht using NavigationInfo.

sical dimensions of your 
, so you should set the 
se dimension to “human” 
vatar dimensions to the 
rld as if they were mice, or 

 Avatar tab in Navigation 
Adding navigatio

4. Leave the Headlight on. The headlight is a directional light that
for the scene and for the VRML browser. When you specify yo
to create a special effect, you may want to turn off the headlig

Setting avatar dimensions

You can adjust the physical characteristics of the avatar to the phy
scene. The avatar is the representative of your viewer in the scene
dimensions accordingly. Most of the time, you will probably set the
factors, but if want to create special effect views, you can set the a
appropriate size. You could have your visitors experience your wo
giants, or any size creature you can imagine.

Use the Avatar page to set avatar dimensions:

1. To display the page for setting the avatar dimensions, click the
Info page.

2. Set the following values:

Collision 0.1 Shoulder width of avatar, which determines 
what it can pass through

Height 1.75 Height of avatar, which sets the eye site level

Step 1.0 Height the avatar can step up 
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Creating Viewpoints

sement park sign. 
e Room viewpoint. 

f its view because it 

o set as a viewpoint. 
you were looking 

f the Create toolbar. 
all other viewpoint 
 viewpoint you just 

ra icon. If you zoom 
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In this exercise, you set a viewpoint for a view of the Cosmo World amu
You can set viewpoints only in perspective views, so you set the view in th
When you set a viewpoint, be sure to give it a name that is descriptive o
will appear in the list of viewpoints in the VRML browsers. 

NOTE:   The file already has viewpoints in it for other scenes.

Create a viewpoint: 

1. In the Room viewport, position the view of the scene that you want t
For example, you might want an aerial view of the entire park, as if 
down on it from an airplane. 

2. Click the “Create Viewpoint” button, which is in the middle section o
A yellow camera icon is placed in the scene for this viewpoint, and 
camera icons are displayed in the scene. You won’t see the icon for the
created because the view of the scene is the from the front of the came
out you will see a camera icon that is surrounded by a DynaBox. 

Create Viewpoint
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ndow.

press Enter or move the 

this is for your own 
nnot select the viewpoint 

how up in the viewpoint 

e name that you want to 
ld not be too long—the 
on’t put in a name, the 
ist.

en click the Go To button 
 just set.

avigate to a new position 

ood and location for your 
island, or a whatever you 
d in the scene is displayed 
The position of the 
viewpoints in your 

file matters to the VRML 
browser. The browser opens 
at the first viewpoint, and the 
list of viewpoints is derived 
from the sequence. If you 
want to change the order of 
your viewpoints, you can 
move them around in the 
Outline Editor by 
click-dragging the Viewpoint 
icon.

The Viewpoint page is displayed in the Property Inspector wi

3. In the Viewpoint page, fill in the fields, type in the name and 
mouse focus to another field:

Try to use unique 
names for transforms 

and objects in your file. If a 
viewpoint has the same name 
as a transform, and the 
transform appears before the 
viewpoint in the file, the 
browser may not see the 
viewpoint.

• In the Viewpoint text field enter the name the viewpoint (
identification in the file). If you don’t put in a name, you ca
as a link in Cosmo Worlds, because the viewpoint won’t s
list.

• In the Description in browser field, enter a name (this is th
display in the list of viewpoints in the browser, so it shou
name can be different than the Viewpoint name). If you d
browser will not display the viewpoint in its Viewpoint L

4. To check the viewpoint, change your view in the scene and th
in the Viewpoint page. You should jump to the viewpoint you

5. If you want to change the position of the viewpoint you set, n
and click the Update button on the Viewpoint page.

Adding a background
Backgrounds help provide realism to your scene. You can set the m
scene with the right colors and shading—a moonscape, a tropical 
desire. If you create more than one background, the first backgroun
unless you explicitly bind them.
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In this exercise, you create a background using the default provided in the Create 
Background tool. The Create Background button is on the Create Extras toolbar, which is the 

xtras.

ckgrounds are 

ode. 

ML browser. 
p other browsers 
ks and behaves 
 window 

 errors when you 
le, if you specify 
ill get a warning 

d errors by 
ead the messages 
 the world in the 
external file, and 
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only toolbar not displayed by default.

Create a background:

1. To display the Create Extras toolbar, choose View > Toolbars > Create E

2. Click the Create Background button to add the default background. Ba
displayed in perspective viewports only. 

NOTE:   You can use the Outline Editor to edit the fields in the Background n

Previewing
The Preview window lets you check how your file appears in a typical VR
Cosmo Worlds uses Cosmo Player as the default browser, but you can set u
to use. The Preview utility is an excellent way to verify how your scene loo
before you publish your file for the World Wide Web. You used the Preview
previously in the exercises for animation, light, and sound.

NOTE:   Often during the authoring process, you may experience warnings or
preview your files because you have incomplete or missing files. For examp
a sound file that has been moved from the location specified in the file, you w
message that says the file doesn’t exist. The browser indicates warnings an
displaying yellow or red flashing lights on the dashboard control. You can r
for the warnings and errors by clicking the lights. Usually you can still see
browser, but you may not be able to hear a sound, see a material, link to an 
so forth.

Preview your scene:

1. Choose View > Preview, or click the Toggle Preview Window button. 

Create Background
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e sure the information in 

ures are loaded and 

osite directions as soon as 

 and the audio clip should 
 Preview window.

he LOD is working.

ft to right while watching 

oint you set from the list 
n using the dashboard 

Preview Window
2. The Preview window opens with the scene in it.

3. Check the following items that you created previously to mak
the file is correct:

• Materials and textures—Make sure the materials and text
displayed correctly for the sign and the light structure.

• Animation—The text and sphere should be rotating in opp
the file is loaded in the Preview window.

• Light and sound—The light should be shining on the sign
be continuously playing as soon as the file is loaded in the

• LOD range—Zoom in and out of the scene to make sure t

• CylinderSensor—drag the mouse across the knob from le
the clown head rotate

• Navigation information and viewpoints—select the viewp
and see how it looks. Also, try different styles of navigatio
navigation controls.

Toggle 

Low-detail model switches to

high-detail as view gets closer
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The detailed lesson 
on navigation and 

Publishing the scene
rk, you can prepare 
 utility for you to 

or the world, checks 
lean copy of the 

 The Publisher 
u want to publish, 
ns on the files, such 
int precision 

 C:\Program Files\
ry, your publishing 
y change the 

ou publish until the 
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viewpoints is in “Chapter 10, 
Publishing Your World.”

Now that you have verified the sign for the entrance to the amusement pa
the scene for the Web. Cosmo Worlds provides an easy-to-use packaging
publish your content for the Web.

What publishing does 

The Publishing Wizard consists of a series of steps that finds all the files f
all the references to other files, resolves naming conflicts, and makes a c
relevant files in the location you specify. 

How to publish your world

You can publish your world easily using the Cosmo Publishing Wizard.
contains windows that prompt you for information about which files yo
the location and structure of the package directory, and optional operatio
as compression, optimization of textures by instancing them, floating po
settings.

NOTE:   The screen shots in this section show the tutorial files installed on
CosmoSoftware\CosmoWorlds. If you did not install in the default directo
session may fail to find files referenced in inlined files. You can manuall
pathnames of these files by editing their URLs in the Outline Editor.

Start the Publishing Wizard:

1. If you haven’t saved your file, save it now. The Publisher won’t let y
file is saved.
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o be located. For example, 
Park is created on your C: 
se the Browser button to 

el document(s).

 of the top-level 
orld. In this exercise, there 
t to list. The name of the 

hing here.

 exclude from publishing. 
 to re-publish them, enter 
les, so click Next to go to 
ation.

sher the options you want 

 Publisher to compress the 
2. Choose File > Publish to start the Publishing Wizard.

3. Enter the name of the directory where you want the package t
if you enter “C:\CWPark” in the text box, a folder named CW
drive and your published files will be copied into it. You can u
select a directory from a file browse window.

4. Click Next to go to the screen where you specify your top-lev

Specify top-level documents:

1. In the “Specify top-level documents” window, enter the name
documents. These documents are the entry points into your w
is only one entry point, so there is only one top-level documen
current file appears in the list, so you don’t need to enter anyt

2. Click Next to go to the screen where you specify which files to
If you know you have files on a server already and don’t need
the filenames in the text box. You don’t want to exclude any fi
the screen where you specify your preferences for file optimiz

Specify VRML preferences:

1. In the “Specify VRML Preferences” window, you tell the Publi
to use for your VRML files:

• Leave the “Gzip VRML files” box checked if you want the
VRML files using gzip compression format. 
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• Leave the “Optimize textures” box checked if you want the Publisher to create 
 of making copies 

cimal numbers in 

 because you can’t 
 the next screen, 

t to go to the 
your package.

 for the 
your source files.

files is included in 
directories, map 

he files in the 
:

lect the entry that 

ory, and click OK.
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instances of textures that are used for more than one object instead
for each object.

• Leave the “Floating point precision” at Default if you want the de
you files to remain unchanged.

Before you go on, make sure everything is set up the way you want it,
come back to this step. If you want to change anything after you go to
you’ll have to start the publishing process over.

2. When you are sure everything is set up the way you want it, click Nex
window where you specify the directory structure and mappings for 

Specify the package directory structure and mappings:

1. In the “Specifying directory structure” window, click the radio button
HIERARCHICAL option. This retains the same directory structure as 

If you don’t specify any mappings, the entire pathname of the tutorial 
the final directory structure. To remove these extraneous levels of sub
them to another location.

2. In the Mappings section, remove the extra subdirectory locations for t
\overview subdirectory. Click the Add button, and enter the following

• In the “from:” field, use the drop-down list box to scroll down to se
has “overview\” at the end.

• In the “to:” field, enter “.\” to map the files to the top-level direct
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y locations for the files in 
e following:

own to select 
e list

\textures subdirectory. 

en:

ucture.

w to see if all the files and 

o the previous screen and 
 the list and clicking the 

at you want, because you 
3. Again, in the Mappings section, remove the extra subdirector
the \grayscale subdirectory. Click the Add button, and enter th

• In the “from:” field, use the drop-down list box to scroll d
C:\Program Files\CosmoSoftware\Shared\textures\ from th

• In the “to:” field, enter “textures\” to map the files to the 
Click OK.

The mappings screen should look similar to the following scre

4. Click the Next button to review the new package directory str

Review the directory structure:

1. Look at the structure in the “Review directory structure” windo
directories are listed as you specified. 

2. If the files are not correct, you can click the Back button to go t
edit or remove the mapping by selecting the mapping item in
appropriate button for the task you want to perform.

3. Before you click the Next button, make sure the structure is wh
can’t back up from here. 

4. Click Next.

Mappings



If a package 
directory with the 

The Publisher saves the published versions of your files in the package directory you 
automatically 
d. If there are any 
ations are that you 
e already exists.

 directory, click the 
ew Using” button 

 is displayed that 

w

same name exists as the one 
currently being published, 
the Publisher asks you to 
confirm moving the existing 
one to the Recycle Bin

specified. During the stage of the publishing process, the Publisher 
changes all filename references to match any mappings you specifie
problems or errors, a dialog window is displayed. Two possible situ
don’t have enough disk space, or that a package with the same nam

Preview the world if desired:

You can create a list 
of preferred 

browsers by clicking 
“Preview Using” and setting 
up other browsers. The list of 
browsers is saved with your 
Cosmo Worlds preferences.

1. If you want to preview the world before writing it to the destination
Preview button to use your default Web browser, or click the “Previ
and specify the Web browser you want to use. 

2. Click the “X” in the browser’s title bar to dismiss the browser.

Finish the publishing session:

1. After you dismiss the browser, click Finish. A results dialog window
shows you what files have been published and to which location.

Packaged world in browser windo



81Where to go from here

ound at the location you 

 a Web server for viewing.

, or whatever medium you 

Cosmo Worlds, and now 
te exciting, interactive 3D 
ur own; or you may want 

ng any or all of the lessons 
2. Click OK to end the publishing session. The files can now be f
specified at the beginning of this process.

3. When the package is complete, copy the directory contents to

Presenting your world

Now you can present your world on the World Wide Web, on a CD
choose. 

Where to go from here
Congratulations! You’ve just completed the overview tutorial for 
you’re ready to use the skills and techniques you’ve learned to crea
content for the Web. You may want to explore Cosmo Worlds on yo
to learn more details about the features Cosmo Worlds by performi
in the Basic Tutorial—chapters 1-10. 
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