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Word Commands Not Available in Internet Assistant

Menu Command
Edit menu Links

Object
View menu Master Document

Header and Footer
Footnotes
Annotations

Insert menu Breaks
Page Numbers
Annotations
Footnote
Caption
Cross Reference
Index and Tables
Frame
Object

Format 
menu

Font
Paragraph
Tabs
Borders and Shading
Columns
Drop Cap
AutoFormat
Style Gallery
Frame
Drawing Object

Tools menu Hyphenation
Mail Merge
Envelopes and Labels
Protect Document
Revisions

Table menu all commands

HTML Tags and Equivalent Word Commands

The following table lists HTML elements with the equivalent Word style or command. You don't need to 
worry about special characters like <, >, &, and ". Internet Assistant will tag them with the proper HTML 
entity syntax. 

HTML Tag Style or Command Style Type
<A> n/a
<A HREF=...> Insert menu, HyperLink to URL

Insert menu, HyperLink to Local Document
see also Hyperlink Command Overview

n/a

<A HREF="#...> Insert menu, Hyperlink to Bookmark n/a
<A NAME=...> n/a
<ADDRESS> Address Paragraph
<B> n/a
<BLOCKQUOTE> Blockquote Paragraph
<BODY> automatically inserted by converter n/a
<CITE> Cite Character



<CODE> Code Character
<DFN> Definition Character
<DIR> Directory List Paragraph
<DL> Definition List Paragraph
<DL COMPACT> Definition Compact Paragraph
<DT>...<DD> Definition Term Character
<EM> Emphasis Character
<FORM> Insert menu, Form Fields

see Creating a Form
n/a

<H1> through <H6> Heading 1 through Heading 6 Paragraph
<HEAD> automatically inserted by converter n/a
<HR> Paragraph
<HTML> automatically inserted by converter n/a
<I> n/a
<IMG> n/a
<KBD> Keyboard Character
<MENU> Menu Paragraph
<META> Insert menu, HTML Markup n/a
<OL> Paragraph
<P> Normal Paragraph
<PRE> Preformatted Paragraph
<PRE WIDTH=...> Preformatted - Wide Paragraph
<SAMP> Sample Character
<STRIKE> Strikethrough Character
<STRONG> Strong Character
<TITLE> n/a
<TT> Typewriter Character
<U> n/a
<UL> Paragraph
<VAR> Variable Character

What Is Lost When Word Documents Are Converted to HTML

If you create an HTML document using Internet Assistant commands and toolbar, your document will not
lose anything when it is saved as HTML and brought back into Word. However, when a Word document 
is not created with Internet Assistant, it may contain some elements that will not be brought back into 
Word after it is saved as HTML. These include:

annotations
borders
character formatting (e.g. subscript, dropped caps)
drawing layer elements

graphics embedded via the Clipboard

footnotes and endnotes

headers and footers

indented paragraphs



index entries

OLE objects

revision marks

shading

tabs

TOC entries



Creating a New HTML Document

You can create an HTML document without knowing HTML markup. You just use Word styles as you 
normally would. Refer to the Style box for a list of styles available in this template. Internet Assistant will 
automatically convert these styles to their equivalent HTML tags when you save the document.
To create a new HTML document
1. From the File menu, choose New.
2. For Template, choose Html, and then choose OK.
3. Create your HTML document.
4. From the File menu, choose Save.
5. In the Save File As Type box, select HyperText Markup Language (HTML).
6. Type the name of your file, and then choose OK.
For more information on how Word styles compare to HTML tags, see HTML Tags and Equivalent Word 
Commands



Converting an Existing Document to HTML

You can convert any document that can be opened in Word into HTML. Internet Assistant maps common
Word styles to their HTML equivalents. 
To convert an existing document to HTML
1. From the File menu, choose Open.
2. Specify the path to the document you want to open, select the file, and then choose OK.

For best results when converting an existing document that was not formatted using styles, run 
AutoFormat from the Format menu before saving as HTML.

3. From the File menu, choose Save.
4. In the Save File As Type box, select HyperText Markup Language (HTML).
5. Type the name of your file, and then choose OK.

Note    Not all Word elements are preserved when a document is converted to HTML. For more 
information, see What Is Lost When Word Documents Are Converted to HTML.



Creating a Hyperlink

When you create a hyperlink to connect one document to another, you choose from one of three types 
of links.

Hyperlink to URL
Establishes a hyperlink to the URL, or address, of a file that exists on an Internet server. Choose the 
To URL tab in the HyperLink command dialog box, or choose the Copy HyperLink command from 
the Edit menu while you are browsing the document.
Example: <A HREF="http://machine_name/directory/file_to_jump_to">

Relative link
Creates a hyperlink between the document you are working on and another document on your local 
drive. You use these links when you are authoring a set of documents that will be published on a 
Web server. Save all the documents on the same drive before creating hyperlinks. Choose the To 
Local Document tab in the HyperLink command dialog box.
When you copy the documents to a Web server, preserve the subdirectory structure by using the 
MS-DOS XCOPY command.
Examples:
<A HREF="fellow_file_in_same_directory">
<A HREF="part_one/intro.doc">
<A HREF="part_one/chapter_one/chapter.doc">

Link in a "local web"
Used when you are authoring a "local web," a set of documents that will be shared among users on 
a local network. You create hyperlinks in a local web the same way you create relative hyperlinks for 
publishing on the Web, except you do not have to save all the documents on the same drive before 
establishing links. Internet Assistant creates an HREF using the UNC pathname of the file on the 
network. As long as other users have a connection to the same server/share, they will be able to 
follow the links in your document.
Example: <A HREF="LOCAL://server/share/directory/file_to_jump_to">

Note    Links for local webs will not work if you create a hyperlink in a document on a network that 
jumps to a file on your local hard drive. 



Using Find and Replace to Modify Hyperlinks

You can quickly modify hyperlinks by using the Find and Replace commands.
To find and replace hyperlinks

Display hyperlinks by choosing Html Hidden 

 from the toolbar.
The Find and Replace commands will function with hyperlinks as they do with regular Word text.



Viewing Markup of an HTML Document

1. With the document displayed in Web Browse view, choose Save As from the File menu. Make sure 
that HyperText Markup Language (HTML) is selected in the Save File As Type box.

2. In the File Name box, type a name for the file, and then choose OK.
3. From the File menu, choose Close.
4. From the File menu, choose Open.
5. Select the Confirm Conversions check box.
6. In the Convert File dialog box, choose Text Only, and then choose OK.

Note    To view the HTML markup of a local document you have created with Internet Assistant, open the
fie and perform steps 3 through 6 only.



Opening an Existing HTML Document

1. From the File menu, choose Open.
2. Specify the path to the HTML document, select the file, and then choose OK.

If you want to view the markup of this HTML document, select the Confirm Conversions check box. 
In the Convert File dialog box, choose Text Only and then choose OK.

_________
See also
Creating a New HTML Document



Internet Assistant Menu Commands

The commands listed below are added to Word's menus by Internet Assistant. All existing Word 
commands are still available for you to use, except Word Commands Not Available in Internet Assistant.

Menu Commands in Web Browse View
Menu Commands in HTML Edit View



Menu Commands in Web Browse View

File menu
Open URL
Reload
Close All Web Documents
HTML Document Info

Edit menu
Copy HyperLink

View menu
HTML Edit
Load Images [on]/[off]

Tools menu
Open Favorite Places Doc
Add to Favorite Places Doc

Window menu
History List
Go Back
Go Forward
Home



Menu Commands in HTML Edit View

File menu
Open URL
Close All Web Documents
HTML Document Info

Edit menu
Go Back

View menu
Web Browse

Insert menu
Form Field
HyperLink
Horizontal Rule
HTML Markup

Format menu
Bullet
Numbering
Multilevel Numbering
Increase Indent
Decrease Indent



Open URL command

Displays the Open URL dialog box, which lets you type the URL of the file you want to open.



Reload command

Reloads the current document into memory.



Close All Web Documents command

Closes all HTML documents that are open, and returns you to any active non-HTML document. If no 
other documents are open, you are returned to the normal default state you've defined for Word.



Copy HyperLink command

Copies the URL of the current document to the Clipboard. You can then paste the URL into any other 
Word document.

Note    If the current document is on the Internet, a hyperlink created with this command will always be a 
full URL. If the current document is on your local drive, this command will create an invalid hyperlink. For
more information, see Creating a Hyperlink.



Go Back command

Moves the insertion point back to the last HTML document you selected. This command has the same 
effect as choosing  from the toolbar.



Go Forward command

Moves the insertion point forward to the next HTML document you selected. This command is only 
available if you have previously used the Go Back command. It has the same effect as choosing  
from the toolbar.



Home command

Reloads DEFAULT.DOC, the Internet Assistant home page. This command has the same effect as 
choosing the Home button on the toolbar.



Web Browse command

Switches you to Web Browse view. This command has the same effect as choosing .



HTML Edit command

Switches you to HTML Edit view. This command has the same effect as choosing .



Load Images [on]/[off] command

Enables and disables the display of inline graphics.



Horizontal Rule command

Inserts a horizontal rule into your document at the insertion point. The HTML equivalent is the <HR> tag.



History List command

Opens the History List dialog box, which displays a cumulative list of the last 50 URLs you have opened 
during your Web browsing sessions. This command has the same effect as choosing the History button 
on the toolbar.
If you want to delete an item from the history list, see Deleting an Entry from the History List.



Deleting an Entry from the History List

You can remove an item from the History list by modifying HTMLHIST.INI.
To delete an entry from the History list
1. From the File menu, choose Open.
2. In the Directories box, select your Windows directory.
3. In the File Name box, type htmlhist.ini
4. In the [History] section, delete the entries you want to remove from the History list.
5. In the [URL] section, delete the lines that correspond to the entries you deleted in step 4.
6. From the File menu, choose Save.
7. Exit Word.
When you start Word again, the changes you have made will take effect.



Open Favorite Places Doc command

Opens FAVORITE.DOC, the list of URLs that you can customize to include your own favorite 
destinations. This command has the same effect as choosing the Open Favorite button.



Add to Favorite Places Doc command

Adds the URL of the current document to FAVORITE.DOC, the list of URLs that you can customize to 
include your own favorite destinations. This command has the same effect as choosing the Add Favorite 
button.



Bullet command

Inserts a bulleted paragraph at the insertion point, or formats selected paragraphs as items in a bulleted 
list. This command has the same effect as choosing the Bullets button on the toolbar.



Numbering command

Inserts a numbered list item at the insertion point, or formats selected paragraphs as items in a 
numbered list. This command has the same effect as choosing the Numbering button on the toolbar.



Multilevel Numbering command

Opens the Bullets And Numbering dialog box so you can define multiple levels of ordered lists.



Increase Indent command

Creates a nested list when used on paragraphs formatted with the List Number <OL> or List Bullet <UL>
style. If you use Increase Indent on paragraphs that are not formatted with either list style, this command
will have no effect when your document is converted to HTML.

For example, NEED A GRAPHIC HERE!



Decrease Indent command

Acts as an "undo" command on nested lists you created by using the Increase Indent command on 
paragraphs formatted with the List Number <OL> or List Bullet <UL>. This command returns the 
paragraphs to the next higher level of list. If you use Decrease Indent on paragraphs that are not 
formatted with either list style, this command will have no effect when your document is converted to 
HTML.



Frequently Asked Questions

TBD, so please keep those questions coming.



Technical Support

Note to beta users:    This Help file is not final nor fully implemented, but we're interested in any 
feedback you might have. Please feel free to comment on the level of detail, quality of information, 
organization... Send feedback to the wordhtml alias. Thanks in advance for your feedback!



HTML Document Head Information command (File menu)

Inserts information about your document into the head of the document. Like Word's Summary Info, the 
head element contains information about your document that isn't displayed within it. You do not need to 
enter the <HEAD> tag into your HTML document; Internet Assistant automatically adds both <HEAD> 
and <BODY> tags for you when you save the document as HTML.

Dialog Box Options
Title
Type a title for your document. You should choose a title that is as descriptive of the document contents 
as possible. You might find it helpful to think of how the title will be used; for example, a search routine 
looking for specific content may choose or discard your document based on what it finds in the title.
The recommended limit for a title is 64 characters, since most browsers can display a title of that length. 
Titles cannot contain anchor tags, paragraph marks, or character formatting.

Advanced
Opens the Advanced HTML Document Head Information dialog so you can add additional summary 
information to your document. For more information, see Advanced HTML Document Head Information 
dialog box.



Advanced HTML Document Head Information dialog box
HTML Document Head Information command (File menu)

Inserts additional summary information into the head of your document.

Dialog Box Options
Base (URL)
The Base element allows the URL of the document itself to be recorded in situations in which the 
document may be read out of context. URLs within the document may be in a 'partial' form relative to 
this base address.

NextID
NextID is a parameter used by editors to generate unique identifiers.

IsIndex
The IsIndex element informs the browser that the document is an index document, which can be 
searched by keywords.

Links
The Links command opens the Create Link dialog box. For more information, see Create Link dialog 
box.

Meta
The Meta command opens the Insert HTML dialog box so you can define the META element directly in 
your document. For more information, see Insert HTML Markup command



Create Link dialog box
Advanced HTML Document Head Information command

Allows you to add additional information into the head of your document. Far too arcane to explain; 
please see http://info.cern.ch/hypertext/WWW/MarkUp/Tags.html.



HyperLink Command Overview

The HyperLink command allows you to define a hypertext link, or hyperlink, in your document. This 
command is equivalent to inserting an HTML anchor element.

About Hyperlinks in HTML
You create a hyperlink to define either the starting point or destination of a jump between your document
and an external location. The starting point of a jump is formatted in a way that identifies it as being a 
"hot spot"--usually colored blue and underlined. You can specify links to graphics, sound files, 
animations, video clips, Microsoft Excel spreadsheets, and so on. As long as your reader can configure 
his or her browser to view these various file formats, your document can be read in its entirety.
Hyperlinks are very similar to the jumps in this Help file: you click a hot spot and you jump to the 
destination indicated by the text of the hot spot. A hyperlink in HTML is identified by an anchor <A> tag. 
The attribute you define for the anchor tag specifies whether the tag marks a destination or a starting 
point.

Note    The HTML markup shown in the following examples would not be displayed by a Web browser. It 
is shown for purposes of illustration only.

The HREF Attribute
Consider the following example:

For more information, see <A HREF="http://www.microsoft.com/bicycles">The Evolution of the 
Bicycle</A>.

The value of the HREF attribute, "http://www.microsoft.com/bicycles", specifies a path to a document. 
When you click the text "The Evolution of the Bicycle" you jump to the document specified in the HREF 
attribute.

The NAME Attribute
The value of the NAME attribute marks a destination that other hyperlinks can jump to. Consider the 
following example:

The development of the <A NAME="bicycle">bicycle</A> influenced other modes of transportation.
This markup allows the word "bicycle" to serve as the destination for hyperlinks that originate in other 
places. The word is not formatted differently from surrounding text.

About Hyperlinks in Internet Assistant for Word
You do need a general understanding of hyperlinks in order to take full advantage of the power of the 
Web. Luckily, you don't need to memorize HTML syntax or type hyperlink markup when you use Internet 
Assistant for Word. You can create links either by choosing the HyperLink command from the Insert 
menu or by using the Internet Assistant toolbar.

You can define three kinds of hyperlinks through the HyperLink dialog box:

To a document on your local hard drive or local area network. For more information, see 
HyperLink to Local Document.

To any URL. See HyperLink to URL.

To an internal location in your document. See HyperLink to Bookmark.



HyperLink to Local Document
HyperLink command (Insert menu)

Inserts a hyperlink to a file located on your hard drive or on a local area network.

Text to Display
Type the text you want to display as the "hot spot" for the hyperlink you are creating. The HTML 
equivalent is the text between the start and end of an anchor tag.

Image
Allows you to choose a graphic to display as the "hot spot" for the hyperlink you are creating. This 
command opens the Picture dialog box. The HTML equivalent is an IMG tag included within an anchor. 
For information on how to select the graphic, see Inserting a Picture.

File Name
Select or type the name of the document you want to open. This box lists documents with the filename 
extension selected in the List Files Of Type box.

List Files of Type
Select the type of file you want to see in the File Name list.

All Files (*.*)
Lists all files in the current directory.

HTML Documents (*.HTM)
Lists all files in the current directory that were saved with the .HTM extension.

Word Documents (*.DOC)
Lists all files in the current directory that were saved with the .DOC extension.

Text Files (*.TXT)
Lists all files in the current directory that were saved with the .TXT extension.

Drives
Select the drive that contains the file you want to open.

Directories
Select the directory that contains the file you want to open.

Advanced
Opens the Advanced HyperLink Options dialog box so that you can define more options for this 
hyperlink. For more information, see Advanced HyperLink Options.

Find File
Opens the Find File dialog box so that you can search for documents. For more information, choose the 
Help button in the Find File dialog box.

Network
Opens the Connect Network Drive dialog box so that you can make a connection to a network drive. For
more information, choose the Help button in the Connect Network Drive dialog box.

___________

See Also
Hyperlink Command Overview
Picture Command Overview



HyperLink to URL
HyperLink command (Insert menu)

Inserts a hyperlink to a document located on a Web server. The full path name of a document on the 
Web is known as a URL.

Text to Display
Type the text you want to display as the "hot spot" for the hyperlink you are creating. The HTML 
equivalent is the text between the start and end of an anchor tag.

Image
Allows you to choose a graphic to display as the "hot spot" for the hyperlink you are creating. This 
command opens the Picture dialog box. The HTML equivalent is an IMG tag included within an anchor. 
For information on how to select the graphic, see Inserting a Picture.

Type a URL or select a previously used one from the list
Type the full path name of the file to which you want to establish a link. If the path name appears in the 
history list, you can select it from the list.
If the path name does not appear in the history list, you can select a similar path name from the list and 
modify it. Select the path name, position the cursor in the text box, and use the cursor keys or 
BACKSPACE key to modify the path name.

Advanced
Opens the Advanced HyperLink Options dialog box so that you can define more options for this 
hypertext link. For more information, see Advanced HyperLink Options.

___________

See Also
Hyperlink Command Overview
Picture Command Overview



HyperLink to Bookmark
HyperLink command (Insert menu)

Inserts a hyperlink to a bookmark within your document.

Text to Display
Type the text you want to display as the "hot spot" for the hyperlink you are creating. The HTML 
equivalent is the text between the start and end of an anchor tag.

Image
Allows you to choose a graphic to display as the "hot spot" for the hyperlink you are creating. This 
command opens the Picture dialog box. The HTML equivalent is an IMG tag included within an anchor. 
For information on how to select the graphic, see Inserting a Picture.

Advanced
Opens the Advanced HyperLink Options dialog box so that you can define more options for this 
hypertext link. For more information, see Advanced HyperLink Options.

___________

See Also
Hyperlink Command Overview
Picture Command Overview



Advanced HyperLink Options
Advanced HyperLink Options command (Insert menu)

Allows you to define additional, optional information about the hyperlink in your document. Except for 
HREF, the attributes listed below are all optional.

HREF
The default value of the HREF for your hypertext link is displayed here. You may override this value by 
modifying the text in this box.

The following definitions are quoted from the HTML specification, a work in progress:

REL
An attribute REF may give the relationship(s) described by the hypertext link. The value is a comma-
separated list of relationship values. Values and their semantics will be registered by the HTML 
registration authority. The default relationship if none other is given is void. REL should not be present 
unless HREF is present.

REV
The REV attribute is the same as REL, but the semantics of the link type are in the reverse direction. A 
link from A to B with REL=X expresses the same relationship as a link from B to A with REV=X. An 
anchor may have both REV and REL attributes.

URN
Specifies a uniform resource number (URN) for the document. URNs allow a document to be recognized
if duplicate copies are found. This prevents a client implementation from picking up a copy of something 
it already has. The format of URNs is under discussion (1993) by various working groups of the Internet 
Engineering Task Force.

TITLE
The TITLE attribute should provide the title of the document whose address is given by the HREF 
attribute.

METHODS
The METHODS attribute provides information about the functions which the user may perform on an 
object.

___________

See Also
HyperLink to Local Document
HyperLink to URL
HyperLink to Bookmark



Cannot Create Valid HREF

The hyperlink you have created contains drive information that will be meaningless when you post this 
document on the Web. The only valid links for a Web document are full URLs or relative links.
You can create hyperlinks in documents you will publish on a "local web" if the documents all exist on 
the same drive when you create the links. For more information on creating hyperlinks for a local web, 
see Creating a Hyperlink.

To continue creating this link, exit Help and choose Continue.

To create a link that will be valid in a Web document, exit Help, choose Cancel, and choose the 
To URL or To Local Document tab from the HyperLink dialog.

___________

See Also
HyperLink Command Overview



Picture command (Insert menu)

Inserts an inline graphic into your document. This command is equivalent to the HTML <IMG> element. 
For guidelines on when to use this command, see Picture Command Overview. For information on how 
to use this command, see Inserting a Picture.

Dialog box options
File Name
Type or select the name of the picture you want to insert. This box lists files with the filename extension 
selected in the List Files Of Type box.

List Files Of Type
Select the type of file you want to see in the File Name list. The file formats listed in this box are the two 
graphic file formats that are widely supported by Web browsers.

CompuServe GIF (*.gif)
Lists all files in the current directory that were saved with the .GIF extension.

JPEG (*.jpg)
Lists all files in the current directory that were saved with the .JPG extension.

Alternative Text To Use If Image Cannot Be Displayed
Type text that can be displayed in place of the graphic, in case your reader's browser is unable to 
display graphics. It's a good idea to keep this text under 64 characters; do not embed other tags or 
character formatting.

Advanced
Lets you define additional attributes for the graphic. See Advanced Picture Options dialog box



Advanced Picture Options dialog box
Picture command (Insert menu)

Lets you define additional attributes of the graphic.

Dialog box options
Sensitive Map (ISMAP)
Identifies the graphic to browsers as a sensitive map--a graphic that contains hyperlinks. You set the 
ISMAP attribute with Internet Assistant, but you need to work with your Web administrator to generate 
the graphic itself.

Text Alignment (ALIGN)
Select the relative placement of the graphic and any text that might be displayed in the same line. The 
default is "Bottom," which aligns the baseline of any text in the line with the bottom of the graphic. 
"Center" aligns text with the center of the graphic, and "Top" aligns it with the top of the graphic.

Note    Other browsers display text and inline graphics in the relative position you define with the ALIGN 
attribute. Internet Assistant, however, will always display text aligned with the bottom of the graphic



Picture Command Overview

Using the Picture command, you can insert a decorative graphic into your HTML document or you can 
choose a graphic to display as the "hot spot" for a hyperlink you create. You should use these types of 
graphics judiciously, for two reasons:

1. Some browsers may be unable to display inline graphics inserted with the Picture command, so the 
graphics should not be essential to the meaning of your document. It is important to include 
alternative text for such browsers to display.

2. Including many inline graphics, or very large inline graphics, decreases the speed at which your file 
can be downloaded and slows your reader's ability to browse quickly through your document. This is 
not good Web publishing practice.

If you want to include a large graphic in your document without slowing down how quickly your 
document can be downloaded, use the HyperLink command on the Insert menu. For more information, 
see HyperLink Command Overview. For instructions on inserting graphics, see Inserting a Picture.



Inserting a Picture

You can insert an inline graphic into your HTML document either for illustrative purposes or as the 
starting point for a hyperlink.
To insert a graphic as an illustration
1. From the Insert menu, choose Picture.
2. Specify the path to the graphic you want to insert, and then select the file. If you want to insert a 

graphic from a Web server, see Inserting a Picture from a Web Server.
The graphic must be either *.GIF or *.JPG format to be displayed by Web browsers.

3. Type text describing the graphic in the "Alternative text to use if image cannot be displayed" box, and
then choose OK.

To insert a graphic as the starting point for a hyperlink
1. From the Insert menu, choose HyperLink.
2. Select the tab that describes the type of hyperlink you want to create, and then choose the Image 

button. 
3. Specify the path to the graphic you want to insert, and then select the file. If you want to insert a 

graphic from a Web server, see Inserting a Picture from a Web Server.
The graphic must be either *.GIF or *.JPG format to be displayed by Web browsers.

4. Type text describing the graphic in the "Alternative text to use if image cannot be displayed" box, and
then choose OK.
If you want the "hot spot" for this hyperlink to consist of text as well as the graphic you just selected, 
type the text in the "Text to display" box.

5. Finish defining your hyperlink by selecting a local document, typing a URL, or selecting a bookmark.

Note    You must use the Insert Picture or Insert HyperLink commands to insert a picture with Internet 
Assistant. If you embed a picture by copying and pasting from the Clipboard, it will be lost when you 
save the document as HTML.

_________
See also
Picture command (Insert menu)
Picture Command Overview
HyperLink Command Overview



Inserting a Picture from a Web Server

You can insert an inline graphic from a Web server. This is equivalent to giving a URL for the SRC 
attribute of an HTML <IMG> tag.
To insert a graphic from a Web server
1. From the Insert menu, choose Picture. 
2. In the File Name box, choose any *.gif or *.jpg graphic, and then choose OK.

3. Choose Html Hidden  from the toolbar.
4. Delete the file name of the graphic (PRIVATE SRC= in the field code), and replace it with the URL
of the graphic you want to insert.
5. From the File menu, choose Save As, and then choose OK.

The next time you open your document, the <IMG> tag will call the inline graphic from the URL you have
given it.



Insert HTML Markup command (Insert menu)

Allows you to insert HTML markup directly into your document. You must use this command to insert 
HTML directly; otherwise, when you type the opening angle bracket (<) of an HTML tag, Internet 
Assistant will convert it to a character entity (&lt;) when you save the file as HTML.

The text you type in this dialog should consist of all the text for the tag you want to enter, including 
opening and closing brackets. The markup will be displayed in your document as <<HTML Markup>> 
while you are creating the document in HTML Edit view.

When you open a document in Web Browse view that has unsupported HTML markup in it, the markup 
is not displayed. Any text occurring between opening and closing markup tags is displayed as Normal.

When you open a document in HTML Edit view that has unsupported HTML markup in it, the markup is 
labelled as <<Unknown HTML Tag>>. You can double-click on <<Unknown HTML Tag>> to display the 
Insert HTML Markup dialog box, where you can see the text of the markup.



Creating a Form

With the Internet Assistant Forms toolbar, you can create simple forms to submit information and to 
perform Web searches.
To create a form
1. From the Insert menu, choose Form Field.
2. When the message reminding you that you are creating a new form appears, choose Continue.

Top Of Form and Bottom Of Form boundaries appear in your document, the Forms toolbar is 
displayed, and the Form Field dialog box is opened.

If you want a form field to be the first item in your form, select the Form Field Type and then 
choose OK.

If you do not want a form field to be the first element of your form, choose Cancel.
3. Create your form, using the Forms toolbar to insert form fields. Next to the form fields, type the text 

that you want to appear in the form. You may have to use cursor keys to position text where you 
want it relative to the form fields.
For information on setting options for each form field type, see Setting Options for a Form Field.

4. From the Forms toolbar, choose the Submit button.
5. In the Form Submit Button dialog box, type submission information for the form.

You can also use this dialog box to customize the appearance of the Submit button. For more 
information, see Form Submit Button command.
To insert text to the left of the Submit button, use the cursor keys to move the insertion point.
It's important to include a Reset button so that after your form is filled out and submitted, a user can 
restore all form-field values back to their defaults. From the Forms toolbar, choose the Reset button.

6. When you have finished creating your form, choose Protect Form from the Forms toolbar.

_________
See also
Form Overview
HTML Forms and Equivalent Word Commands



HTML Forms and Equivalent Word Commands

Internet Assistant uses some of Word's form capabilities to create HTML forms, 
Element Attribute Word or IA Equivalent
input type="checkbox" Displayed as a checkbox form field

name="name" Stored in Add Help Text, Status Bar tab, as name
value="value" Stored in Add Help Text, Help Key (F1) tab, as 

value="value"
input type="radio" Displayed as a checkbox form field.

Identified as a RADIO input element by a bookmark labeled 
TYPE_RDn, where n is a counter beginning with 0 that 
distinguishes the bookmark from the other RADIO input 
elements. If there is a NAME attribute for the RADIO input 
element, the bookmark is labeled name_RDn, where name 
is the NAME attribute. 

name="name" Stored in Add Help Text, Status Bar tab, as name 
value="value" Stored in Add Help Text, Help Key (F1) tab, as 

value="value" 
input type="hidden" Displayed as a text box form field when Html Hidden has 

been turned on.
Identified as a HIDDEN input element by the string 
type="hidden" in Add Help Text command, Status Bar tab.

name="name" N/A
value="value" N/A

input type="image" Equivalent to selecting the Text Button Type in the Form 
Submit Button dialog box

value="value" Stored in the text box next to the Text Button Type in the 
Form Submit Button dialog box.

name="name" Stored in the Private field for this form field.
src="filename" Turns type to SUBMIT and ignores all other attributes.
align="alignment" Ignored.

input type="submit" Equivalent to selecting the Submit button on the Forms 
toolbar.

value="value" Stored in the text box next to the Text Button Type in the 
Form Submit Button dialog box.

name="name" Stored in the Private field for this form field.
input type="reset" Equivalent to choosing the Reset button on the Forms 

toolbar.
input type="text" Displayed as a text box form field.

Identified as a TEXT input element by the string 
type="text" in Add Help Text, Status Bar tab.

name="name" Required attribute. (???) Stored in Add Help Text, Status 
Bar tab.

value="value" Stored as Default Text in the Text Box Form Field Options 
dialog box.

maxlength="x" Stored as Maximum Length in the Text Box Form Field 
Options dialog box. If maxlength is not specified, the value 
defaults to Unlimited.

size="x" N/A
textarea name="name" Stored in Add Help Text, Status Bar tab

rows=x Stored in Add Help Text, Help Key (F1) tab



cols=x Stored in Add Help Text, Help Key (F1) tab. The product of 
rows and cols is stored in Maximum Length. 

text between start 
and end tags

Stored as Default Text in the Text Box Form Field Options 
dialog box.

select name="name" Displayed as a Drop-Down form field. Name is stored in the 
Add Help Text, Status Bar tab as name

option Stored as Items in Drop-Down List in the Drop-Down Form 
Field Options dialog box

selected Written out in HTML when form is saved
value N/A
disabled N/A

select multiple Displayed as Checkbox form fields
name="name" Stored in the Add Help Text, Status Bar tab as name. 

Identified as a MULTIPLE select element by a bookmark 
labeled name_MSn, where name is the NAME attribute.

option Displayed as Checkbox form fields. The label for each 
option is stored in Add Help Text, Help Text (F1) tab as 
VALUE="label"

selected Written out in HTML when form is saved
value N/A.



Setting Options for a Form Field

After you insert form fields using the Forms toolbar, you can use Word to set options for the fields by 
using the Form Field Options button  on the Forms toolbar. You can 

To set options for a form field using Word's Form capabilities

Select the form field and then choose Form Field Options from the Forms toolbar.

Note    Some of the options you can set for a form field in Word are not available in Internet Assistant, 
because there are no HTML elements equivalent to those options. For a description of the options in 
Word's Form Field Options dialog boxes that you can use, see one of the following:
Internet Assistant options available in Text Form Field Options dialog box
Internet Assistant options available in Check Box Form Field Options dialog box
Internet Assistant options available in Drop-Down Form Field Options dialog box



Internet Assistant options available in Text Form Field Options dialog box

Internet Assistant converts the following commands from the Text Form Field Options dialog box into 
HTML markup. Any commands that are not listed are not converted because there is no HTML 
equivalent.

Maximum Length
Unlimited or greater than 80
Defines the text form field as a textarea element, which can accommodate multiple lines of text. This 
setting is equivalent to the markup

<TEXTAREA    NAME="bookmark_name">Default text</TEXTAREA>

80 or less
When you type a value of 80 or less in the Maximum Length box, the text form field becomes an input 
element with its TYPE attribute set to TEXT. For example, if Maximum Length is set to 80, this setting is 
equivalent to the markup

<INPUT    TYPE=TEXT    NAME="bookmark_name"    MAXLENGTH="80"    VALUE="Default text">

Default Text
Specify text you want displayed by default in the form field, if any.

Field Settings
Bookmark
Specifies the NAME attribute of the textarea element (if Maximum Length is Unlimited or greater than 
80), or the NAME attribute of the input element (if Maximum Length is less than or equal to 80). You can 
modify the name of the bookmark given to the form field, or you can accept the default bookmark names
that Word assigns.

Fill-in Enabled
Ensures that the form field can be modified by users of the form.



Internet Assistant options available in Check Box Form Field Options dialog box

Internet Assistant converts the following commands from the Check Box Form Field Options dialog box 
into HTML markup. Some commands in the dialog box are not listed because there is no HTML 
equivalent. You use this dialog box to set options for input elements with the TYPE attribute of 
CHECKBOX or RADIO.

Default Value
Not Checked
Sets the default value of the CHECKBOX or RADIO input element to "not checked."

Checked
Sets the default value of the CHECKBOX or RADIO input element to "checked."

Field Settings
Bookmark
Word automatically assigns bookmarks to each form field.

If the TYPE attribute is CHECKBOX, the bookmark takes the form LEGALnnn.

If the TYPE attribute is RADIO, the bookmark takes the form name_RDn, where name    is the 
NAME attribute of the input element.

Check Box Enabled
Ensures that the form field can be checked by users of the form. This setting should always be selected.

Add Help Text
Status Bar
Stores the text string corresponding to the NAME attribute of the CHECKBOX or RADIO input element.

Help Key (F1)
Stores the text string corresponding to VALUE="value", where value is the VALUE attribute of the 
CHECKBOX or RADIO input element.



Internet Assistant options available in Drop-Down Form Field Options dialog box

Internet Assistant converts the following commands from the Drop-Down Form Field Options dialog box 
into HTML markup. Any commands that are not listed are not converted because there is no HTML 
equivalent.

Drop-Down Item
Type the text you want to add to the drop-down list. Choose Add.

Items in Drop-Down List
The text you typed in the Drop-Down Item box appears in this list. To change the order of drop-down list 
items, select an item and use the Move keys to change its position. To remove an item from the drop-
down list, select it and then choose Remove.
These settings are equivalent to the markup

<SELECT    NAME="bookmark_name">
<OPTION    SELECTED>First item in drop-down list
<OPTION>Second item in drop-down list
etc.
</SELECT>

Field Settings
Bookmark
The bookmark specifies the NAME attribute of the select element. You can modify the name of the 
bookmark given to the form field, or you can accept the default bookmark names that Word assigns.

Drop-Down Enabled
Ensures that the form field can be selected from by users of the form.



Form Submit Button command

Lets you specify how your form is to be submitted, and also lets you customize the look of the button 
that users will press to "submit" their responses to the server.

Dialog box options
Button Type
Select either Text or Custom Button.

Text
Displays the Submit button as a standard command button. The default text for this button is "Submit." 
To change the default text, type new text for the button in the text box.

Custom Button
Lets you select an inline graphic to display as the Submit button in your form. To select the graphic, 
choose the Select Picture button. The Insert Picture dialog box shows you the available graphics.

Submission Information

ACTION
Specifies the URL of the server to which you want to submit the contents of the form.

METHOD
The METHOD attribute of a form specifies the way data is submitted. METHOD is POST when ACTION 
is an HTTP URL. The default METHOD is GET.

ENCTYPE
This attribute is only present when METHOD is POST. It is a MIME type that specifies the format of the 
form's data. The default value of ENCTYPE is application/x-www-form-urlencoded.



No Picture Selected

Context ID # 15. This dialog doesnt have a Help button, which is just fine. This topic is left in place just in
case Arye puts a Help button in here someday.



Form Overview

Internet Assistant uses most of Word's Form command capabilities to create HTML forms, but there are 
some areas of these two types of forms that do not overlap. To create simple HTML forms, see Creating 
a Form. If you want to create more complex forms, you'll need to understand how Internet Assistant 
handles certain form elements and attributes--see HTML Forms and Equivalent Word Commands.

Note    To fully implement your forms on a Web server, you must work with your system administrator. 
For an overview of implementing forms on the Web, see

http://www.ncsa.uiuc.edu/SDG/Software/Mosaic/Docs/fill-out-forms/overview.html



Glossary

anchor
bookmark
ftp
GIF
gopher
head
HREF
HTML
HTTP
hyperlink
image
ISMAP
JPEG
MIME
tag
URL
World Wide Web



URL
uniform resource locator

Identifies the full path of a document, graphic, or other file to locate it on the Internet. In a Web 
document, the destination of a hyperlink is often a URL. Correct URL syntax is described in

http://info.cern.ch/hypertext/WWW/Addressing/Addressing.html



HTML
Hypertext Markup Language

A system of marking up, or tagging, a document so it can be published on the World Wide Web. The 
author of the document incorporates HTML markup in order to define the function (as distinct from the 
appearance) of different text elements. The appearance of these text elements is not defined at the 
authoring stage; formatting is applied when a browser decides the appearance of marked-up text 
elements.
For example, an emphasized word is marked up as <EM>word</EM> in an HTML file. Some browsers 
will display that word in boldface, while others might use italics. All the author needs to do is indicate that
the word should be emphasized; formatting is left to the browser. This differentiation between the 
function and appearance of text is typical of implementations of SGML (Standard Generalized Markup 
Language), of which HTML is one.
To view the HTML markup of a document on the Web, see Viewing Markup of an HTML Document.
The HTML level 2.0 specification is a work in progress. Its URL is http://www.hal.com/%7Econnolly/html-
spec/



anchor

The HTML element that defines hypertext links, or hyperlinks. The anchor is a section of text that forms 
the starting point or destination of a hyperlink. <A> and </A> are the anchor's start and end tags, 
respectively. An anchor must contain either the attribute of NAME (if it is the destination of a link) or 
HREF (if it is the starting point of a link to another location) in order to be meaningful:

<A HREF="..." NAME="..."> text to display for link </A>



HREF
hypertext reference

Attribute of the HTML anchor element that defines the anchor as a "hot spot" which, if selected, will 
launch the reader to another location. HREFs give the network address of the location to which the 
hyperlink leads. This address can be a URL or a relative link. For more information, see Hyperlink 
Command Overview.

 <A HREF="http://far.off.destination"> Click here to go to a far-off 
destination </A>



image 
IMG

An HTML element that allows you to embed an inline graphic into your document. The SRC attribute, 
which gives the URL of the graphic, is mandatory. The ALT attribute, which defines text for a non-
graphical browser to display in place of the graphic, is so strongly suggested that it might as well be 
mandatory. The ALIGN attribute specifies the relative position between the graphic and any text 
displayed in the same line. 

Note    Other browsers display text and inline graphics in the relative position you define with the ALIGN 
attribute. Internet Assistant, however, will always display text aligned with the bottom of the graphic.

There is no end tag for <IMG>.

<IMG SRC="..." ALT="..." ALIGN="...">



head

The head element is a collection of information about a document that is used by programs outside of 
the document. Of this information, the <TITLE> tag is the most important and is present in every well-
made HTML document. If you do not provide a title, Internet Assistant will automatically generate one 
using the first line of your document.

Proper markup of an HTML document follows this pattern:

<!doctype HTML public "-//W30//DTD W3 HTML 2.0//EN">
<HTML>
<HEAD>

<TITLE> ... </TITLE>
other head elements if needed

</HEAD>
<BODY>

body elements
</BODY>
</HTML>

Note that you do not need to add <HEAD> tags directly; Internet Assistant automatically adds them to 
any document you save as HTML. 



BASE (URL)

Quoted from HTML specification 2.0, a work in progress:

The BASE element allows the URL of the document itself to be recorded in situations in which the 
document may be read out of context. URLs within the document may be in a 'partial' form relative to 
this base address.

Where the base address is not specified, the browser uses the URL it used to access the document to 
resolve any relative URLs.

The one attribute for BASE is HREF, which identifies the URL.



NextID

Quoted from HTML specification2.0, a work in progress:

The NEXTID is a parameter used by editors to generate unique identifiers. This tag takes a single 
attribute which is the number of the next document-wide numeric identifier to be allocated of the form 
z123.

When modifying a document, old anchor IDs should not be reused, as there may be references stored 
elsewhere which point to them. This is read and generated by hypertext editors. Human writers of HTML
usually use mnemonic alphabetical identifiers. Browser software may ignore this tag.

"Example:
<NEXTID N=Z27>

NOTE: Support for NEXTID does not impact browsers in any way.



ISINDEX

Quoted from HTML specification2.0, a work in progress:

The ISINDEX element informs the browser that the document is an index document. An index document
can be queried with a keyword search by adding a question mark to the end of the document address, 
followed by a list of keywords separated by plus signs. See the network address format for more 
information.



ISMAP

Attribute of the image element that informs the browser that the image is a sensitive map--that is, a 
graphic that contains hyperlinks. You set the ISMAP attribute with Internet Assistant, but you need to 
work with your Web administrator to generate the graphic itself.



bookmark

A location or selection of text that you name for reference purposes. Word marks the location with a 
name you specify. In Internet Assistant, you use a bookmark to identify a place in your document that will
be the destination of a hyperlink. The HTML equivalent of a bookmark is the NAME attribute of an 
anchor. See also Hyperlink Command Overview.



tag

Characters enclosed in angle brackets that represent the markup of an HTML element and its attributes. 
When an element requires both start and end tags, the end tag is indicated with a forward slash. For 
example, <EM> and </EM> are start and end tags, respectively, for the emphasis element. Tags are not 
case-sensitive.
For more information, see the HTML level 2.0 specification, a work in progress.



MIME
Multipurpose Internet Mail Extensions

A standard that allows binary data to be published and read on the Internet. The header of a file with 
binary data contains the MIME type of the data; this informs client programs (Web browsers and mail 
packages, for instance) that they will need to handle the data some way other than they handle straight 
text. For example, the header of a Web document containing a JPEG graphic contains the MIME type 
specific to the JPEG file format. This allows a browser to display the file with its JPEG viewer, if one is 
present.



FTP
file transfer protocol

Internet standard for transferring data. Internet Assistant is an ftp client--that is, you can copy files from 
FTP servers. You cannot post files to FTP servers using Internet Assistant.
URLs of files on FTP servers begin with the string ftp:// or file://



gopher

An interface that allows access to resources on the Internet. Gopher servers contain menus that list 
categories of information that the reader chooses. Gopher menus have the same function as hyperlinks 
in Web documents. You can access gopher servers using Internet Assistant.
URLs of files on gopher servers begin with the string gopher://



GIF
Graphics Interchange Format

A graphics file format that many Web browsers can display as inline graphics. GIF was developed 
specifically for transmitting images. GIF files are compressed bitmaps. See also JPEG.



JPEG
Joint Photographic Experts Group

A graphics file format supported by many Web browsers, although most can't display JPEG files as 
inline graphics. JPEG was developed for compressing and storing photographic images. JPEG files, 
which have a *.JPG extension in Windows, are compressed bitmaps. See also GIF.



HTTP
hypertext transfer protocol

World Wide Web standard for transferring data between Web servers and clients. URLs of files on Web 
servers begin with the string http://



hyperlink

Hyperlinks--or hypertext links--are the "hot spots" that connect Web documents to other files on the 
Internet. When you activate a hyperlink you are launched to the location it specifies, which could be 
within the same document or it could be on a different server in a different country. You create hyperlinks
by using the HTML anchor element. For more information, see Hyperlink Command Overview.



World Wide Web

A group of Internet servers that share a set of protocols, such as HTTP, and conventions, such as 
HTML. Using Web browsing software, you can open documents on Web servers that contain many 
types of information--not just text, but sound, animations, video, etc. For further information, see 
http://info.cern.ch/hypertext/WWW/TheProject.html.




