


About Macro Dialog Editor

Purpose
Use the Macro Dialog Editor to quickly and easily create, design, set properties for, and 
edit the dialogs you use in your macros.    Using the Macro Dialog Editor takes the place of 
the DIALOGDEFINE sections in your macros.

Macro Dialog Editor lets you add, edit, position, size, move, and assign values to controls, 
lines, and other elements of a dialog.    You can also use it to give each control a control 
name, variable name, values, and other properties, as well as define the control order, set 
the initial focus, set tab stops, and group controls. The file WPDE20US.DLL contains the 
Macro Dialog Editor functionality, and it goes in your Shared Code directory.

See Also
Open Macro Dialog Editor



Open the Macro Dialog Editor

Purpose
Use the Macro Dialog Editor to create and edit the dialogs you use in WordPerfect 6.1 for 
Windows-level macros.    You can open the Macro Dialog Editor from the WordPerfect Macro
Facility or from within WordPerfect 6.1 for Windows.

Steps
To open the Macro Dialog Editor from within WordPerfect,
1 Choose Macro from the Tools menu, then choose Edit.

2 Specify a macro filename, then choose Edit to display the Macro feature bar.

3 Click Dialog Editor on the macro feature bar.

4 Choose Create, type a name for the dialog, then choose OK.
or
Select the dialog you want, then choose Edit.

To open the Macro Dialog Editor from the Macro Facility,
1 Open the Macro Facility.

2 Choose Dialog from the Macros menu.

3 Specify a macro filename, then choose OK.

4 Choose Create, type a name for the dialog, then choose OK.
or
Select the dialog you want, then choose Edit.

See Also
About Macro Dialog Editor



Link Dialogs to Macros

Purpose
Use the DialogShow and DialogDismiss commands to use a dialog created in the Macro 
Dialog Editor within a macro.    These commands can be found in the WordPerfect 
Command Inserter under the type WPMacroFacility.

The DialogShow command uses three parameters:    the dialog name, the parent window 
for the dialog, and a label that identifies a callback function. The first and second 
parameters are required, the third is optional.    The DialogDismiss command requires two 
parameters:    the name of the dialog and the name of the control used to dismiss the 
dialog.    See the Example cited in the See Also list for syntax and further information.

Variables associated with controls work the same way as with the DialogDefine method.    
If a variable exists, its value is set into the controls when the dialog displays, and the 
value in the controls is set into the variables when the dialog is dismissed.

Steps
To display a dialog within your macro,
1 In your macro editor, type or insert the DialogShow command where you want the 

dialog to appear in your macro.

2 Specify the name of the dialog and the named region for its parent window.

3 Specify a callback parameter if you want the macro to execute while the dialog displays.

To dismiss a dialog if you are using a callback,
1 In your macro editor, type or insert the DialogDismiss command after a DialogShow 

command that uses callback.

2 Specify the name of the dialog and the name of the control used to dismiss the dialog.

If you use the cancel button, a control other than a push button, or a non-existent 
control to dismiss the dialog, your changes will not take effect.    If you use a push 
button other than a cancel button, the variable values are set and your changes take 
effect when you dismiss the dialog.

See Also
Example of DialogShow and DialogDismiss
Choosing Properties for Controls



Select Macros

Purpose
Use Select Macro to specify which macro file (*.wcm) you want to create or edit dialogs 
for.    The Macro Dialog Editor only works with macros in WordPerfect 6.0 for Windows 
format.    The Macro Dialog Editor does not allow you to edit the macros themselves, only 
to define dialogs for them.

Steps

1 Choose Macro from the WordPerfect 6.0 Tools menu, then choose Edit.
or
Open the Macro Facility, then choose Dialog from the Macros menu.

2 Specify a macro filename, then choose OK.

See Also
Open Macro Dialog Editor
Select Dialogs



Select Dialogs

Purpose
Use Macro Dialogs to select the dialog you want to edit.

Steps

1 In Macro Dialogs, select the name of the dialog you want to edit, then choose Edit.

See Also
Copy Dialogs
Create Dialogs
Open Macro Dialog Editor
Link Dialogs to Macros
Rename Dialogs
Select Macros



Create Dialogs

Purpose
Use Create to build new dialogs to use in your macros.    Be sure to use the same names 
you used in your macros, with the same case, since dialog and control names are case-
sensitive.

Steps

1 In Macro Dialogs, choose Create.

2 Type a name for the dialog, then choose OK.

3 Add controls, choose a font, and set the properties for the dialog.

4 Choose Save from the File menu to save the new dialog, then choose Close twice.

See Also
Open Macro Dialog Editor
Add Controls
Choose Fonts for Dialogs
Choose Properties for Dialogs
Copy Dialogs
Open Macro Dialog Editor



Edit Dialogs

Purpose
Use Edit to revise the dialogs in your macros.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.

2 Add, edit, or delete controls, change the font, and alter the properties for the dialog.

3 Choose Save from the File menu to save the new dialog, then choose Close twice.

See Also
Add Controls
Choose Fonts for Dialogs
Choose Properties for Dialogs
Delete Controls
Edit Controls
Open Macro Dialog Editor



Copy Dialogs

Purpose
Use Copy to save an exact copy of a dialog in another macro file or in the current macro 
file with a new name.

Steps

1 In Macro Dialogs, select the dialog you want to copy, then choose Copy.

2 Specify the macro file you want to copy the dialog to.

3 Type a new name for the dialog.

4 Choose OK.

See Also
Create Dialogs
Select Macros



Delete Dialogs

Purpose
Use Delete to remove a dialog from a macro file.    Be sure to delete all references to a 
deleted dialog from the macro.

Steps

1 In Macro Dialogs, select the dialog you want to delete, then choose Delete.

2 Choose OK.

See Also
Create Dialogs
Rename Dialogs
Open Macro Dialog Editor



Rename Dialogs

Purpose
Use Rename to give a dialog a new name while leaving it in the current macro file.    
Renaming the dialog does not change the name displayed on the caption bar.

Steps

1 In Macro Dialogs, select the dialog you want to rename, then choose Rename.

2 Type a new name for the dialog.

3 Choose OK.

See Also
Copy Dialogs
Create Dialogs
Open Macro Dialog Editor



Save Dialogs

Purpose
Use Save to store a new or revised dialog in the current macro file.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Add, edit, or delete controls, choose the font, and set the properties for the dialog.

3 Choose Save from the File Menu to save the new dialog, then choose Close twice.

See Also
Create Dialogs
Edit Dialogs
Open Macro Dialog Editor
Test Dialogs



Test Dialogs

Purpose
Use Test to check your dialogs before closing the Macro Dialog Editor.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Add, edit, or delete controls, choose the font, and set the properties for the dialog.

3 Right-click on the dialog, choose Test from the QuickMenu, then test your dialog.

4 When you are finished testing, choose OK, Close, or double-click the Control-menu.

See Also
Edit Dialogs
Open Macro Dialog Editor
Save Dialogs



Choose Properties for Dialogs

Purpose
Use Dialog Properties to specify the location and size of the dialog, its caption, class, 
dialog type, frame type, and attributes.

Steps
To set dialog properties,
1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Right-click on the dialog, then choose Properties from the QuickMenu.

3 Specify settings for the following properties:
Location and Size
Caption
Class
Help File and Help Key
Attributes
Dialog Type
Frame Type

4 Choose OK.

See Also
Create Dialogs
Edit Dialogs
Open Macro Dialog Editor
Save Dialogs



Choose Fonts for Dialogs

Purpose
Use Font to choose a typeface and point size for all text on your dialog.    The caption font 
remains constant for all dialogs.    Changes in font size and style do affect the size of the 
dialog.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Right-click on the dialog, then choose Font from the QuickMenu.

3 Select a font and point size.

4 Choose OK.

See Also
Choose Properties for Controls
Choose Properties for Dialogs
Open Macro Dialog Editor



Control Palette

Purpose
Use the Control Palette to choose controls and actions in the Macro Dialog Editor.    You can
drag the title bar to position the palette on the screen.

Steps

1 Move the pointer to the palette graphic below until the pointer is on the desired icon 
and becomes a hand .

2 Click for information about that tool.

See Also
Add Controls
Edit Controls
Open Macro Dialog Editor
Save Dialogs
Test Dialogs



Add Controls

Purpose
Use the icons on the Controls palette and on the Control menu to add controls to your 
dialogs.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Click a control from the Controls palette.

3 Position the "x" above the control symbol where you want the top left corner of the 
control to appear, then click.

4 Double-click the control, set its properties, then choose OK.

5 Repeat steps 2-4 for the rest of the controls you want to add.

6 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Align and Space Controls
Choose Properties for Controls
Delete Controls
Open Macro Dialog Editor
Position Controls



Delete Controls

Purpose
Use Delete to remove controls from a dialog.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Right-click on a control, then choose Delete from the QuickMenu.
or
Press Delete.

3 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Add Controls
Open Macro Dialog Editor



Edit Controls

Purpose
Double-click any control to edit its properties, or click once and drag to size and position it 
where you want it.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Double-click a control, make the changes you want to its properties, then choose OK.

3 Click and drag each control to position and size it.

4 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Add Controls
Align and Space Controls
Delete Controls
Open Macro Dialog Editor
Position Controls with a Grid



Position Controls

Purpose
Use the Location and Size options to position and size controls precisely using dialog units,
or click and drag to size and position controls manually.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

To position a single control,
1 Double-click a control, specify a left and top value to position it on the dialog, specify a 

width and height value to change its size, then choose OK.
or
Click and drag each control to position and size it.

To position multiple controls,
1 Click the top-left corner of the top control in the group you want to select.

2 Drag the selection area down and right to select all the controls you want in the group.

3 Drag the grouped controls to position them.

2 Choose Save from the File menu to save the dialog when you are finished positioning 
the controls, then choose Close twice.

See Also
Add Controls
Align and Space Controls
Edit Controls
Position Controls with a Grid
Open Macro Dialog Editor



Add and Edit List Items

Purpose
Use Create/Edit List to enter and change options for controls that use lists, such as pop-up 
lists, drop-down lists, list boxes, and so on.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Double-click a control that uses a list of options.

3 Choose Create/Edit List.

4 Type a name, then choose Add for each option in the list.

5 Select an item in the list, type a new name, then choose Replace to replace an item, or 
Delete to remove an item.

6 Select an item in the list, then choose Move Up or Move Down to reposition an item.

7 Select an item in the list, then choose Set Initial to have that item selected when the 
dialog opens.

8 Select an item on the list, edit it, then choose Add to modify list items.

9 Select Sort List to sort the list items.

10 Choose OK twice.

11 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Add Controls
Choose Properties for Controls
Edit Controls
Open Macro Dialog Editor



Choose Properties for Controls

Purpose
Use the Properties dialogs associated with each control to set the location, size, named 
regions, variables, and other properties for each control.

For more information about each property option, choose the Search button above and 
type the name of the dialog, for instance, "List Box Properties."    Then click the option you 
want information about.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Double-click a control, make the changes you want to its properties, then choose OK.

3 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Add Controls
Align and Space Controls
Edit Controls
Open Macro Dialog Editor
Position Controls



Set Up Dialogs

Purpose
Use the options on the Dialog menu to group dialog controls, to specify the default focus 
and buttons, and to define tab stops.    You must set the control order before grouping the 
controls; defining a group box around a set of controls does not automatically group them.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Right-click on the dialog.

3 Choose Control Order, click the controls in the order you want to tab through them, then
choose OK.

4 Choose Control Groups, click each control to select its group, then choose OK.

5 Choose Default Button, click a control, click the button you want to be activated when 
the user presses Enter on the control, then choose OK.

6 Choose Default Focus, click the control you want to have the focus when the dialog 
displays, then choose OK.

7 Choose Tab Stops, click to highlight the controls you want to tab to, then choose OK.

8 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Add Controls
Choose Properties for Dialogs



 Bitmap
Allows you to display a bitmap as a control icon.    See Bitmap Properties.



 Check Box
Check boxes represent compatible options.    Clicking an empty check box selects the option;
clicking a marked check box deselects the option.    You can also define check boxes as 
"Three State" to give a third value.    See Check Box Properties.



 Color Wheel
Color wheels allow users to select colors based on values of hue, lightness, and saturation.    
See Color Wheel Properties.



 Combo Box
Combo boxes display an edit box and a list box.    Enter text in the edit box, or double-click a 
list item to insert it.    See Combo Box Properties.



 Counter
Counters allow users to enter numeric data in an edit box by typing or by clicking an 
incrementor/decrementor.    Clicking inserts a number in the edit box that is within a 
specified range.    See Counter Properties.



Position Controls with a Grid

Purpose
Use the options on the View menu to align controls with precision.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Choose Show Grid from the View menu.

3 Choose Snap to Grid from the View menu to force controls to align with grid points.

4 Choose Grid Options from the View menu, choose the amount of space you want 
between grid points on each axis, then choose OK.

5 Add controls to the dialog using the grid as a guide.

6 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Add Controls
Align and Space Controls
Edit Controls
Open Macro Dialog Editor
Position Controls



 Date
Date controls display an edit box and a calendar icon.    Users can enter dates by typing or 
by clicking the calendar icon to open a calendar and selecting a date to display in the edit 
box.    See Date Properties.



 Edit Box
Edit boxes allow users to type text or allow the macro to type text for them.    They can have 
one line or multiple lines.    See Edit Box Properties.



 Filename Box
Filename boxes display an edit box and a folder icon list button.    Users can enter filenames 
or directories by typing them in or by clicking the list button to display a Select File or Select 
Directory dialog.    See Filename Box Properties.



 Frame
Frames can group items in a dialog, or act as design elements.    See Frame Properties.



 Group Box
Group boxes visually group controls in a dialog with a titled frame.    Group boxes do not 
automatically group the controls, however.    Use Control Groups and Control Order to group 
controls.    See Group Box Properties and Set Up Dialogs.



 Horizontal Line
Horizontal lines visually separate items in a dialog.    See Line Properties.



 Horizontal Scroll Bar
Horizontal scroll bars allow users to scroll from left to right.    See Scroll Bar Properties.



 List Box
List boxes display lists of options to choose from.    See List Box Properties.



 Popdown Button
Popdown buttons display a list of options when clicked.    The button itself shows the feature 
name.    See Popdown Button Properties.



 Popup Button
Popup buttons display a list of options when clicked.    The button itself shows the selected 
option.    See Popup Button Properties.



 Progress Indicator
Displays the progress of a process as it runs.    See Progress Indicator Properties.



 Push Button
A push button activates a specific action when clicked, such as OK, Cancel, Help, and so on.   
See Push Button Properties.



 Radio Button
Radio buttons represent mutually-exclusive options.    Selecting one radio button deselects 
another.    See Radio Button Properties.



 Static Text
You can use static text on a dialog to give instructions or information to users.    Static text 
can consist of one line or many lines, and is read-only.    See Static Text Properties.



 Vertical Line
Vertical lines visually separate items in a dialog.    See Line Properties.



 Vertical Scroll Bar
Vertical scroll bars allow users to scroll from top to bottom.    See Scroll Bar Properties.



 Viewer
Viewers display read-only, scrollable text files.    See Viewer Properties.



Example of DialogShow and DialogDismiss

The following is an example of the DialogShow command:

DialogShow("DialogName";"WordPerfect";CallBack@)

The first parameter is the name you gave to the dialog when you created it in the Macro 
Dialog Editor (in this case, DialogName).

The second parameter is a named region specifying the parent window for the macro 
dialog (in this case, the WordPerfect window will be the parent window for the dialog).    
Named regions are defined by the application.    The region consists of the application 
name, followed by a period (.), followed by additional words that narrow the named region
to the appropriate window.    For example, the named region of the document window in 
WordPerfect is WordPerfect.Document.    For more information on using named regions, 
see the "Mouse String" topic in Macros Online Help.

The third parameter is a label that identifies a callback function.    If you do not specify a 
callback parameter in the DialogShow command, the macro does not execute until you 
dismiss the dialog.    If you use a callback, the macro executes while the dialog is up.    It is 
up to the callback to prevent the macro from terminating prematurely, and to shut down 
the macro dialog using the DialogDismiss command.

The following is an example of the DialogDismiss command:

DialogDismiss("DialogName";"OKBttn")

The first parameter is the dialog name.

The second parameter is the named region of the control used to dismiss the dialog.

For more information on the DialogShow and DialogDismiss commands, see Macros Online
Help.

See Also
Link Dialogs to Macros



Bitmap Properties

Purpose
Use Bitmap Properties to set and change the characteristics and position of bitmap 
controls.

These are the Bitmap Properties options:
Location and Size
Named Region
Variable
Filename
Attributes

See Also
Add Controls
Edit Controls



Text
Use this control to specify the titles for group boxes.



Check Box Properties

Purpose
Use Check Box Properties to set and change the characteristics and position of the check 
boxes.

These are the Check Box Properties options:
Location and Size
Named Region
Variable
Text
Text Placement
Initial State
Type

See Also
Add Controls
Edit Controls



Color Wheel Properties

Purpose
Use Color Wheel Properties to set and change the characteristics and position of color 
wheels.

These are the Color Wheel Properties options:
Location and Size
Named Region
Variable
Initial Values

See Also
Add Controls
Edit Controls



Combo Box Properties

Purpose
Use Combo Box Properties to set and change the characteristics and position of combo 
boxes.

These are the Combo Box Properties options:
Location and Size
Named Region
Variable
Style
Current Item List
Type
Attributes

See Also
Add and Edit List Items
Add Controls
Edit Controls



Counter Properties

Purpose
Use Counter Properties to set and change the characteristics and position of counters.

These are the Counter Properties options:
Location and Size
Named Region
Variable
Values
Attributes

See Also
Add Controls
Edit Controls



Align and Space Controls

Purpose
Use the options on the Align menu to position and space controls inside the dialog and in 
relation to each other. The first control you click is the "anchor control," which appears 
with black squares around it.

Steps

1 In Macro Dialogs, select the dialog you want to edit, then choose Edit.
or
Choose Create, type a name for the new dialog, then choose OK.

2 Press Shift while clicking the control(s) you want to align, then choose Left, Right, Top, 
or Bottom from the Align menu to move the control to that side of the anchor control.

3 Press Shift while clicking the control(s) you want to align, choose Center, then choose 
Vertical or Horizontal to center a control in relation to the anchor control.

4 Press Shift while clicking the control(s) you want to make the same size as the anchor 
control, choose Make Same Size, then choose Vertical, Horizontal, or Both.

5 Press Shift while clicking the controls you want to space in relation to each other, 
choose Space Evenly from the Align menu, then choose Vertical or Horizontal.

6 Choose Save from the File menu to save the dialog, then choose Close twice.

See Also
Add Controls
Edit Controls
Open Macro Dialog Editor
Position Controls
Position Controls with a Grid



Date Properties

Purpose
Use Date Properties to set and change the characteristics and position of date controls.

These are the Date Properties options:
Location and Size
Named Region
Variable
Initial Date
Attributes

See Also
Add Controls
Edit Controls



Contents

How Do I    Step-by-step instructions for common tasks

Search    Index of help topics and features



Edit Box Properties

Purpose
Use Edit Box Properties to set and change the characteristics and position of edit boxes.

These are the Edit Box Properties options:
Location and Size
Named Region
Variable
Style
Text
Type
Automatic Scroll
Scroll Bar
Attributes
Justification
Capitalization

See Also
Add Controls
Edit Controls



Filename Box Properties

Purpose
Use Filename Box Properties to set and change the characteristics and position of filename
boxes.

These are the Filename Box Properties options:
Location and Size
Named Region
Variable
Directory and Template
Type
Show Files
Hide Buttons/Select File Dialog

See Also
Add Controls
Edit Controls



Justification
Use these controls to specify the justification for group box titles.



Frame Properties

Purpose
Use Frame Properties to set and change the characteristics and position of frames.

These are the Frame Properties options:
Location and Size
Named Region
Type
Color

See Also
Add Controls
Edit Controls



Group Box Properties

Purpose
Use Group Box Properties to set and change the characteristics and position of group 
boxes.

These are the Group Box Properties options:
Location and Size
Named Region
Text
Justification

See Also
Add Controls
Edit Controls



Line Properties

Purpose
Use Horizontal and Vertical Line Properties to set and change the characteristics and 
position of horizontal and vertical lines.

These are the Horizontal and Vertical Line Properties options:
Location and Size
Named Region

See Also
Add Controls
Edit Controls



List Box Properties

Purpose
Use List Box Properties to set and change the characteristics and position of list boxes.

These are the List Box Properties options:
Location and Size
Named Region
Variable
Style
Current Item List
Attributes

See Also
Add and Edit List Items
Add Controls
Edit Controls



Popdown Button Properties

Purpose
Use Popdown Button Properties to set and change the characteristics and position of 
popdown buttons.

These are the Popdown Button Properties options:
Location and Size
Named Region
Text
Current Item List

See Also
Add and Edit List Items
Add Controls
Edit Controls



Popup Button Properties

Purpose
Use Popup Button Properties to set and change the characteristics and position of popup 
buttons.

These are the Popup Button Properties options:
Location and Size
Named Region
Variable
Current Item List

See Also
Add and Edit List Items
Add Controls
Edit Controls



Progress Indicator Properties

Purpose
Use Progress Indicator Properties to set and change the characteristics and position of 
progress indicators.

These are the Progress Indicator Properties options:
Location and Size
Named Region

See Also
Add Controls
Edit Controls



Push Button Properties

Purpose
Use Push Button Properties to set and change the characteristics and position of push 
buttons.

These are the Push Button Properties options:
Location and Size
Named Region
Text
Type

See Also
Add Controls
Edit Controls



Radio Button Properties

Purpose
Use Radio Button Properties to set and change the characteristics and position of radio 
buttons.

These are the Radio Button Properties options:
Location and Size
Named Region
Variable
Text
Text Alignment
Type
Initial State

See Also
Add Controls
Edit Controls



Text
Use this control to specify the text associated with the edit box.



Scroll Bar Properties

Purpose
Use Vertical and Horizontal Scroll Bar Properties to set and change the characteristics and 
position of horizontal and vertical scroll bars.

These are the Horizontal and Vertical Scroll Bar Properties options:
Location and Size
Named Region
Variable
Values
Alignment and Sizing

See Also
Add Controls
Edit Controls



Static Text Properties

Purpose
Use Static Text Properties to set and change the characteristics and position of static text.

These are the Static Text Properties options:
Location and Size
Named Region
Variable
Style
Text
Justification
Type

See Also
Add Controls
Edit Controls



Viewer Properties

Purpose
Use Viewer Properties to set and change the characteristics and position of viewers.

These are the Viewer Properties options:
Location and Size
Named Region
Variable
Filename

See Also
Add Controls
Edit Controls



Attributes
Use these controls to choose which elements you want to incorporate in the dialog.

Caption:    Puts a title bar and caption on the dialog.
System Menu:    Puts a system menu on the dialog.



Automatic Scroll
Use these controls to choose the types of scrolling the edit box allows beyond its edges.    
Vertical scrolling allows text to scroll up and down, Horizontal scrolling allows text to scroll 
left and right.



Attributes
Use these controls to set the size of the bitmap in relation to the control on which it appears.

Size Control to Bitmap:    Makes the control as large or small as the bitmap.
Size Bitmap to Control:    Makes the bitmap as large or small as the control.
No Auto Sizing:    Does not size either the control or the bitmap.    If the bitmap is larger 
than the control, the edges are cropped.



Radio Button Initial State
Use these controls to select the state of the radio button when the dialog opens.

Clear: Unmarked and unactivated.
Checked: Marked with a dark circle and activated.



Text
Use this control to specify the text appearing on a push or popdown button, or beside a radio
button.



Capitalization
Use these controls to select how text appears in the edit box (upper, lower, or mixed case).



Caption
Use this control to specify the text that appears in the title bar of the dialog.    If you type a 
title longer than the title bar, it is cut off at the right edge.



Text
Use this control to specify the text that will appear next to the check box.



Type
Use these controls to select the type of check box you want.    Auto Check Boxes are the 
most commonly used type.

Check Box:    Gives two possible states (on or off).    When users click on the check box, it 
does not automatically reflect the change.    You must send a message to the dialog within 
the macro to change the state of the check box.
Auto Check Box:    Gives two possible states, and clicking the box automatically changes 
the state.    No additional message is necessary in the macro.
Three-State:    Gives three possible states (on, off, or indeterminate).    When users click on 
the check box, it does not automatically reflect the change.    You must send a message to 
the dialog within the macro to change the state of the check box.
Auto Three-State:    Gives three possible states, and clicking the box automatically 
changes the state.    No additional message is necessary in the macro.



Class
Use this control to specify the dialog class.



Attributes
Use these controls to choose characteristics for the combo box.

Auto Horizontal Scroll:    Allows users to enter text longer than the actual text box without 
cutting it off.
OEM Convert:    Converts text typed in the edit control from the Windows character set to 
the OEM character set, then back to the Windows character set again.    This ensures proper 
character conversion.



Type
Use these controls to select the type of combo box you want to use.

Simple:    Gives a small, permanently open list with a thin black border.
Drop Down:    Gives a small list with a thin black border when the user clicks the icon next 
to the edit control.    A scroll bar appears if the number of items in the list exceeds the length
of the list box.
Drop Down List:    Gives a static text field displaying the current selection instead of an edit
control.    Clicking the control displays the list.    A scroll bar appears if the number of items in
the list exceeds the length of the list box.



Control Buttons
Use these controls to accept or cancel the changes you made.    The Help functionality is not 
implemented in the Beta release.



Attributes
Use these controls to choose characteristics for counters.

Auto Horizontal Scroll:    Allows users to enter numbers longer than the actual text box 
without cutting them off.
Auto Validate:    Automatically checks entered numbers to ensure they fall within the 
acceptable range, and changes unacceptable numbers to the nearest acceptable value upon
leaving the control.
No Scroll:    Removes the incrementor/decrementor buttons.



Values
Use these controls to set the possible range of values and format for numbers in counters.

Minimum:    Specifies the minimum value possible.
Maximum:    Specifies the maximum value possible.
Step:    Specifies the increment used for the incrementor/decrementor buttons.    For 
example, typing 5 causes each click on the up arrow to increase the value in the text box by 
5:    5, 10, 15, 20, and so on.
Initial:    Specifies the value displayed when the dialog opens.
Format:    Specifies the unit measured (i.e., centimeters, inches, points, and so on).



Current Item List
Use these controls to specify the list of possible choices.    Choose Create/Edit List to add, 
replace, delete, and position items on the list, and to set the option selected when the dialog
opens.



Attributes
Automatically checks entered dates to ensure they fall within the acceptable range, and 
keeps the focus on the control until you enter an admissible date and format.



Dialog Type
Use these controls to select the type of dialog.

Modal:    When the dialog is open you must dismiss it to access the parent window.    You can
switch to another window using Alt+Tab.
Modeless:    When the dialog is open you can still access features in the parent window.
System Modal:    When the dialog is open you must dismiss it before you can access any 
other functions.



Attributes
Use these controls to choose characteristics for edit boxes.

Allow Carriage Return:    Allows users to press Return inside the edit box to enter multiple 
lines.
Password (*****):    Displays characters as asterisks as the user types a password.
Read Only (No Typing):    Displays text the user cannot edit.
Word Wrap:    Allows text to wrap to the next line when it reaches the right edge of the edit 
box.



Scroll Bar
Use these controls to specify on which sides of the edit box scroll bars appear.    Use scroll 
bars with edit boxes to let the user see all the text entered.



Type
Use these controls to specify how much text users can enter into the edit box.

Single Line:    Limits text entry to a single line.    Pressing Return moves the user to the next 
control.
Multiple Line:    Allows users to enter multiple lines of text.
Limit Text Entry:    Limits text entry to the number of characters you specify.    The system 
limit is 1 K.



Filename
Use this control to specify the location, path, and filename of the bitmap image you want to 
use.    Use the folder icon to select directories and filenames.



Type
Use these controls to choose characteristics of the dialog that appears when users click the 
folder icon next to filename boxes.

Path Only:    Displays only directory and subdirectory names; all filenames are grayed.
Path/Filename:    Displays directories, subdirectories, and filenames.
Does Not Have to Exist:    Users can enter invalid filenames without generating an error 
message.
Pathname No Validate:    Useful with Path Only.    Allows users to enter invalid paths and to 
create the directory or subdirectory.



Directory and Template
Use these controls to specify the default directory and template for filename boxes.    Click 
the folder icon to select directories.



Color
Use these controls to choose a white, black, or gray fill for frames.



Type
Use these controls to select the type of frame you want on the dialog.

None:    Removes the frame from around the dialog.
Thin Border:    Puts a thin black line around the dialog.
Dialog:    Puts a Windows-standard dialog border around the dialog.
Thick/Sizeable:    Puts a thick border around the dialog with sizing areas on the corners and 
edges.



Type
Use these controls to select the type of frame you want.    Using frames does not 
automatically group controls.    To group controls, use the Control Order and Control Groups 
option from Layout on the Dialog menu.

Filled:    Fills the area inside the frame with a solid color.
Frame:    Outlines the area with thin line.



Help File and Help Key
Use these controls to specify the Help file and Help key this dialog connects to.    For 
example, you can tell this dialog to look for "MYHELP.HLP," and assign it a key included in 
the map and alias files for that help system.



Hide Buttons/Select File Dialog
Use these controls to choose the buttons displayed on the dialog    that appears when users 
click the folder icon.    You must have these applications and options available in order for 
them to operate.

QuickFinder:    Displays a button that opens WordPerfect's QuickFinder application.
Setup:    Displays a button that opens a dialog allowing users to change the appearance of 
the dialog.
Viewer:    Displays a button that allows users to view files.
Options:    Displays a button that allows users to copy, rename, delete, and otherwise 
manipulate files.



Initial Values
Use these controls to specify the values for the color highlighted when the dialog opens.    
You can also click the color wheel and color bar to select colors.

Hue:    Adjusts the color (0=red, 240=blue, 360=green).
Lightness:    Adjusts the amount of white and gray in a color.
Saturation:    Adjusts the amount of color.



Initial Date
Use this control to specify the date displayed when then dialog opens.    Click the calendar 
icon to select the date or specify today's date.



Initial State
Use these controls to select the state of the check box when the dialog opens.

Clear:    Unmarked and unactivated.
Checked:    Marked with an X and activated.
Grayed:    Filled with gray.    You must select Three-State or Auto Three-State from the Type 
group box to activate this option.



Justification
Use these controls to specify the justification (left, center, or right) for text inside edit boxes 
and static text.



Attributes
Use these controls to choose characteristics for list boxes.

Check Boxes:    Displays check boxes next to each item on the list.
Extended Selection:    Allows users to select several separated items by pressing Ctrl while
clicking.
Multiple Selection:    Allows users to select contiguous items by dragging.



Location and Size
Use these controls to precisely position a control in relation to the left, top corner of the 
dialog.    The values you can use depend on the size of the dialog, and are measured in 
dialog units.    You can also select and drag controls to position them.

Left:    Distance from the left edge of the dialog.
Top:    Distance from the top edge of the dialog.
Width:    The width of the control.
Height:    The height of the control.



Location and Size
Use these controls to position the dialog in relation to its parent window.

Absolute:    Allows you to position the dialog in dialog units from the top left corner of the 
parent window.    Dialog units are based on the currently selected font for the dialog and your
screen resolution.
Relative:    Allows you to position the dialog based on available screen space.    For example,
if you choose 50% for Left and 50% for Top, 50% of the available screen space will be on the 
left and 50% will be at the top of the dialog.
Left:    Percent or number of dialog units the dialog is removed from the left edge of the 
window.
Top:    Percent or number or dialog units the dialog is removed from the top edge of the 
window.
Width:    The width of the dialog in dialog units.
Height:    The height of the dialog in dialog units.



Named Region
Use this control to specify the name of each control on a dialog.    This is the name you use in
the macro when referring to this control, so each control on the same dialog should have a 
unique name. Named Regions are case-sensitive.



Named Region
This control shows the name of the dialog.    This is the name you use inside the macro when 
calling and dismissing this dialog. Named Regions are case-sensitive.



Type
Use these controls to select the type of push button you want.

OK:    Makes the button an OK button.    Clicking this accepts the dialog settings and 
activates them.    Selecting OK automatically fills in the Text box.
Cancel:    Makes the button a Cancel button.    Clicking this closes the dialog without 
implementing the changes.    Selecting Cancel automatically fills in the Text box.
Help:    Makes the button a Help button.    Clicking this button calls the Help file associated 
with this dialog.    Selecting Help automatically fills in the Text box.
Other:    Allows you to specify any name for the button.



Type
Use these controls to select the type of radio button you want.

Radio:    Gives two possible states (on or off).    When users click the button, it does not 
automatically reflect the change.    You must send a message to the dialog within the macro 
to change the state of the button.
Auto Radio:    Gives two possible states, and clicking the button automatically changes the 
state.    No additional message is necessary in the macro.



Alignment and Sizing
Use these controls to determine the location and size of scroll bars.

None-Size to Control:    The scroll bar extends the length or width of the control 
automatically.
Left:    The scroll bar appears at the left of the scroll bar control.
Right:    The scroll bar appears at the right of the scroll bar control.
Top:    The scroll bar appears at the top of the scroll bar control.
Bottom:    The scroll bar appears at the bottom of the scroll bar control.



Values
Use these controls to set the values and increments for scroll bars.

Minimum:    The smallest allowable value.
Maximum:    The largest allowable value.
Step:    How much each click will change position.
Initial:    The initial position of the scroll bar.



Show Files
Use these controls to choose which types of files the Select File dialog displays in the List 
Files of Type combo box.    This allows you to limit the types of files that users can choose to 
list.

DOC:    Displays document files.
SS:    Displays spreadsheet files.
DB:    Displays database files.
GR:    Displays graphics files.
All Files (*.*):    Displays all files.



Text
Use this control to enter the text you want to appear as static text on the dialog.    Text 
longer than the display area is cut off at the right edge.



Style
Use these controls to select the style of control you want to use (WordPerfect or Windows).



Text Alignment
Use these controls to select the side of the radio button on which the text appears.



Justification
Use these controls to choose left, right, or center justification for static text.    The text is 
justified in relation to the text area.



Text Placement
Use these controls to select the side of the check box on which the text will appear.



Type
Use these controls to select appearance options for static text.

Regular:    Text appears printed on the dialog without a border.
Recessed:    Text appears as white text on a darker gray, recessed background.
Shadow:    Text appears as black text on a raised, shadowed box.
Squash Path:    Text appears with ellipses (...) replacing the middle of overlylong 
pathnames.



Variable
Use this control to specify the name of the variable associated with the dialog control.    Use 
this name in the macro when specifying the values for the variable.



Filename
Use this control to specify the path and filename of the file the viewer displays.    Click the 
folder icon to select directories and files.
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