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About DiskIt

Welcome to the first release of DiskIt, the diskette catalog 
manager.  First of all, thank you for evaluating and, of course, 
registering DiskIt 1.0.  As you've no doubt heard, you (the upstanding 
computer user) provide the necessary funds for shareware by 
registering this software.  Really, people, the shareware marketing 
concept provides an alternative to money gouging software 
monopolies (no names, of course).  Without all the legalese, please 
register this software if you use it.  There you have it:  That's the 
completion of our integrity pep talk today.

Moving on to DiskIt.  DiskIt is intended to be a simple solution for
managing information about files stored on diskettes.  DiskIt includes 
features such as:

- Automatic file information retrieval:  No manual entry.
- User definable descriptions for each file.
- Multiple viewing options.
- Multiple sorting options.

DiskIt was created using The Whitewater Group's Actor 
development system for Microsoft Windows.  Why Actor?  We think it 
will better enable us to enhance DiskIt and produce other software 
products in the future.  Although Actor has its drawbacks, it enables us 
to more quickly create and update software.  The quicker turnover 
should provide the user with a quality product in less time.   

Using DiskIt

DiskIt is a disk cataloging program written for Microsoft Windows.
DiskIt is designed to provide all the general capabilities needed by a 
disk cataloging program while remaining very easy to use.

This section is meant to help you get up and running with DiskIt 
(if for some reason you don't feel like reading the whole manual).  

Once you get DiskIt started, there are only a few things you need
to know to take advantage of DiskIt's functionality. To read in catalogs 
off a disk, simply choose Add from the Catalog menu.  Once you 
choose the drive, DiskIt will read in the disk.  If  the disk does not have 
a volume name, DiskIt allows you to enter one; DiskIt will write this 
volume name to disk in addition to using it to track the files you've just
read into DiskIt.  You can continue reading in disks in this fashion.
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    Once you've read files into DiskIt, the first thing you should do is 
save the entire data file.  To do this, just choose Save As from the File 
menu.  DiskIt's default file extension is .DAT, but you can use any file 
name you want (within DOS's limits) for the data file.  

The next thing to try is manipulating the display.  There are two 
displays you can toggle between by using the View menu.  Drop down 
the View menu and choose File.  DiskIt will display all files 
alphabetically, without any volume information.  Now drop down the 
View menu again, and choose Disk.  The display now sorts files by the 
disk they are on, in addition to displaying information about that disk 
like volume name, space free, and disk size. 

The second way to change the display is by using the Display! 
menu.  This brings up a dialog box containing the various file 
information you can toggle on and off:  Attributes, path, volume label, 
date, file size, and description.  Checking the box next to one of these 
boxes turns the display of that attribute on.

The third and final way to change the display is through the Sort 
By menu.  You can sort by file name, extension, date, size, or 
description.  To choose a sort, just drop down the Sort By menu, and 
pick the sort you want (a check mark denotes the current sort).

There you have it.  We hope you enjoy using DiskIt!  If you like 
this program, or use it regularly, please register it.  We would also 
appreciate your comments, suggestions, questions, and ideas.  We 
especially enjoy receiving new product ideas; also keep your eye out 
for new products from us.  
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Files You Should Have

If you are using an unregistered (i.e. evaluation) version of DiskIt,
you should have a file called DISKIT.ZIP.  That file will contain the 
following files:

DISKIT.EXE DiskIt executable file
DISKIT.IMA DiskIt image file
DISKIT.WRI DiskIt documentation in Windows Write format
DISKIT.DAT Sample catalog file
ORDER.TXT A text file containing an order form

If you have a registered version of DiskIt (and you should!), the 
disk you get will contain the following files:

DISKIT.EXE DiskIt executable file
DISKIT.IMA DiskIt image file
DISKIT.DAT Sample catalog file

Registered versions of DiskIt also include complete printed 
documentation (with screen shots) and an About Box with your name.  
In the registered version, the About Box does not appear when the 
program is started.

ACKNOWLEDGEMENTS, ETC.

Welcome to the first release of DiskIt.  Thanks for supporting us!  
Really, people, the Shareware marketing concept provides a great 
alternative to money gouging software monopolies (no names, please).
Please support us by registering the software.  The more money you 
send us, the more products we produce - and we have some really 
good ones slated for release in the next 6 to 8 months!  

DiskIt was created using Whitewater Group's Actor development 
system.  

Thanks to Jeff Autor and Mike Maley for beta testing and helping 
distribute our product.  

Windows is a registered trademark of Microsoft Corporation.  
Actor is a registered trademark of The Whitewater Group.  All products 
mentioned in this manual are registered trademarks of their respective
corporations.  

Our software adheres to all standards of the Association of
Shareware Professionals.
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Ordering DiskIt

Ordering DiskIt is easy.  Simply print this page, fill it out, and mail it 
along with a check or money order for $35.00 to:

Stephen Drone
P.O. Box 8041
Wilmette, IL  60091

Your name:  
______________________________________________________________________
Address:      
______________________________________________________________________
Address:      
______________________________________________________________________
City:            ___________________________________  St:_______  Zip:  
______________

Disk size: _____ 5.25" (High Density) _____ 3.5" (Low 
Density) 

Where did you hear about or download DiskIt?

What features, if any, would you like to see added in future versions of 
DiskIt?

How can we imporove distribution and support to help the end user?

Would you be interested in a customized version of DiskIt?
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Warranty and License Information

Limited Warranty

This software and manual are sold "as is" and without warranties as to 
performance or merchantability or any other warranties, whether 
expressed or implied.  Because of the various hardware and software 
environments in which this program may be used, no warranty of 
fitness for a particular purpose is offered.

License

DiskIt is a SHAREWARE program; it is NOT public domain software, nor 
is it free software.  DiskIt requires the user to register the program if he
or she intends to use it except for the purpose of limited evaluation 
described below.  Registration grants the user a license to use DiskIt on
a single computer at any one time.

Non registered users are granted a limited license to use DiskIt on a 
trial basis for the purpose of evaluation.  

All users of DiskIt are granted a limited license to copy the product only
for the trial use by others, provided that DiskIt is copied in its full and 
unmodified form.  The copy must include all files necessary to permit 
full operation of the program.  It must also include this license 
agreement, registration form, warranty, and documentation.  

Use of non registered copies of DiskIt by any person in connection with 
a business, corporation, educational institution, or government agency 
is forbidden.  Such users must register the product and/or purchase a 
site license.  

Association of Shareware Professionals

DiskIt 1.0 is a Shareware program conforming to standards as 
established by the Association of Shareware Professionals.

Trademarks

Microsoft(R) and Windows(TM) are registered trademarks of Microsoft 
Corporation.
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PKZIP(R) and PKUNZIP(R) are registered trademarks of PKWARE, Inc.
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Distribution License

Anyone wishing to charge people a fee for giving them a copy of DiskIt 
must have the written authorization of the authors, without which the 
distributor is guilty of copyright violation.  To receive such 
authorization, send this completed application along with a copy of 
your software library's order form to:  Stephen Drone, P.O. Box 8041, 
Wilmette, IL, 60091.

Your name:  
______________________________________________________________________
Company:    
______________________________________________________________________
Address:      
______________________________________________________________________
Address:      
______________________________________________________________________
City:            ___________________________________  St:_______  Zip:  
______________

Include $10 to cover the costs of processing the application and 
sending you the latest version of DiskIt.  For distributors already 
recognized by the Association of Shareware Professionals, this 
application is not necessary.  

Terms of Distribution of DiskIt:

1.  The fee charged may not exceed $8, including postage, mailer, 
and any other charges.
2. Your library's catalog or listing must state that DiskIt is not free, 
but is copyrighted software that is provided to allow the 
user to evaluate it before buying it.
3. The offering and sale of DiskIt will be stopped at any time upon 
request of the authors.
4. Copies must be made from the copy of DiskIt sent to you with 
this agreement.
5. Problems and complaints will be reported to the authors for 
resolution.

In return for the right to charge a fee for the distribution of the DiskIt 
software, I agree to comply with the above terms of distribution.
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Signed,

_________________________________ _______________
your signature date

________________________________ _______________
Richard Thompson date

_________________________________ _______________
Stephen Drone date
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Working With Catalogs

The disk catalogs you use Diskit to track will be kept in data files 
with the default extension .DAT.  Each file may contain as many disk 
catalogs as you wish.  You can simply track all your disks in one data 
file, or you can split up your disks into several different catalog files.     

Starting a New File

To start a new data file (catalog) simply pull down the File Menu 
(or <ALT>-<F>) and choose New.  DiskIt will then present you with a 
blank display:
This display will not show any files until you add disk catalogs to it; this
procedure is described in the Working With Catalogs section.

Using an Existing File

To open an existing data file, choose Open... from the File menu.  
DiskIt will present the File Open dialog box:
DiskIt lists the current directory at the top of the dialog box.  If you see 
the file you want to open in the box at the lower left, simply double 
click on the file name to open that data file.  If you do not see the file 
want, you can use the Directories box to look for the file you want.  
Double click on a drive letter to pick a disk drive, then use the mouse 
to choose the directory you want to look in.  Once you find the file you 
want, just double click on the file name to open that file.

If you have saved the data file with some extension other 
than .DAT, you should type *.* in the Files box, instead of *.DAT.   

If you want to cancel the operation, simply click the Cancel 
button.

Working With Catalogs

After you've started a new catalog by choosing New from the File
menu, you can start adding disks to your catalog data file.

Adding a Disk to the Catalog

To add the files from a floppy disk to your current catalog, pull 
down the Catalog menu with the mouse (or <ALT>-<C>) and choose 
Add... to bring up the Select Diskette Drive dialog box.  

Choose the floppy drive that the diskette is in from the selection 
box (if more than one drive is available, click the down arrow next to 
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the selection box to get a list of drives) and click the OK button.  To 
cancel the operation, click the Cancel button.

If you chose the wrong drive, Windows will return an error 
message.  Simply keep clicking Cancel buttons until you are back at 
the DiskIt screen. After choosing the correct drive, DiskIt will present 
the Add This Disk to Catalog?? dialog:

Notice two things:  All files and their associated paths are listed.  Also, 
if the disk has no volume name, you are prompted to enter a volume 
name for DiskIt to use.  Please do so.  While you're at it, label the disk 
with the appropriate volume name.  You'll thank us for it.  To continue, 
click the OK button.  To cancel the operation, click the Cancel button.

The list of files form this disk is now added to your current 
catalog.

Saving Catalogs

We highly recommend saving your work quite often.  To save the 
catalog you're currently working on, just choose Save from the File 
menu.  If your data file does not have a name, DiskIt will save it as 
UNTITLED.DAT.  

If you are working on a new file (one that you haven't previously 
saved) you should choose Save As... from the File menu.  This will bring
up the File Save As dialog box:

Simply type in the name you want to use for your file (it must be 8 
characters or less); the default DiskIt extension for the file is .DAT.  The
current directory is shown at the top of the dialog box.  You can use the
Directories box to choose the drive and directory you want to save the 
catalog in.  Once you've chosen a file name, drive, and directory, hit 
the <ENTER> key or click on OK to save the file.  To cancel the 
operation, click the Cancel button.

Describing Files

There are two ways to add descriptions to files.  For the first 
method, simply choose Describe Files... from the Catalog menu to bring
up the Add Description to File dialog box:

The Files scroll box contains a list of all the files in the current 
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catalog.  Click the down arrow, then use the scroll bar to find the file 
you want to add a description to; click the mouse on that file name to 
highlight it.  You can also use the right and left arrow keys to highlight 
the file you want to describe.

Once you've highlighted the file you want to describe, just type 
the description you want to add to that file into the description box.  
This description can be up to 200 characters long.  To save the 
description, hit the <ENTER> key or use the mouse to click the OK 
button.  If you hit the <ENTER> key, you can enter multiple 
descriptions by choosing the next file you want to describe.

To cancel this operation, click the Cancel button.
For the second method, simply double click on a file name from 

the main DiskIt screen.  The will bring up the Add a Description to a File
dialog box; the file you double clicked on will already be highlighted.  
All you have to do is type in the description and hit the OK button.  

Deleting Catalogs

Deleting a catalog of a disk is easy.  Just choose Delete from the 
Catalog menu to bring up the Delete Diskette Information from DiskIt 
dialog box:
Use the Volume Name: drop down box to pick out the volume you want
to delete.  After you pick a volume, DiskIt will display the files in that 
volume in the Files Listed for Diskette box.  Be sure this is the volume 
you want to delete!  To delete this volume, click the OK button.  To 
cancel this operation, click the Cancel button.

NOTE:  You cannot delete an individual file from a DiskIt catalog.  
To delete a file, you must delete the entire volume the file is in.  
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Updating Catalogs

The Update Catalogs choice in the Catalog menu allows you to 
update the information in the current disk catalog.  

For example, suppose you had a disk with the volume label 
WORK.  You had read it's catalog into DiskIt several months ago 
(undoubtedly with a beta copy of DiskIt).  But now you've added a file 
to that disk, or perhaps deleted a couple of files.  What you need to do 
is Update that catalog!  Choose Update from the Catalog menu, and 
you will see this dialog box:

Simply choose the volume name of the disk you want to 
update, then click OK.  CAUTION:  Once you choose OK, you MUST 
update the information in DiskIt from a diskette.  When you choose OK,
the information for that volume in DiskIt is erased.  After choosing OK, 
you will be prompted to insert a diskette in a drive.

Choosing Cancel at this point will abort the update.
If you would like to check the contents of a diskette before 

updating it, you can choose Add from the Catalog menu to view the 
contents of a disk.  You can then cancel the operation once you've 
verified the contents of the disk.
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Using Views

You can easily change the way you look at disk catalogs in DiskIt 
through the View menu.  The View menu contains two choices:  Disk 
and Files.  When you are are using DiskIt, you are always using one of 
these two views.  

The Disk view keeps files from the same disk together.  The 
display is also formatted differently.  Look at the following example of 
the Disk view:
Notice that the display looks much like a DOS directory would look on 
your computer screen.  The disk volumes are sorted in alphabetical 
order, and the files in each volume are sorted in any order you choose 
(from the Sort By menu).  
    If you pull down the View menu and choose Files, DiskIt re-sorts the 
same display to look like the following:
This is the File view.  Notice that this display looks much more like a 
database or spreadsheet listing than the Disk view.  In the File view, 
the sort criteria you choose in the Sort By menu applies to the entire 
file listing, not just the files within each volume.  All files in the catalog 
are listed consecutively.  

Sorting Views

Of course, the Disk And Files views do not have to be sorted by 
file name as in the previous two examples.  Use the mouse to pull 
down the Sort By menu (or press <ALT>-<O>); you will see a list of the
available sort attributes.  

Once you've pulled down this menu, simply choose the attribute 
you want to sort by with your mouse, or press the appropriate 
underlined letter.  After you've made your selection, DiskIt will re-sort 
the display.  If you are in Disk view, the files within each disk volume 
will be sorted in the order you chose.  If you are in Files view, the entire
catalog will be sorted.
    Note that if you save the catalog after changing the View or Sort by 
attribute, these new attributes will not be saved.  When you open a 
file, DiskIt automatically chooses the Disk view, and sorts the files by 
file name.

Changing The Display

By default, in the Disk view, DiskIt displays the file name, path, 
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file attributes, file data, file size, and description for each file in the 
view.  
    It is very easy to change the information DiskIt displays about 
each file.  Simply pull down the Display! menu with the mouse (or use 
<ALT>-<D>) to bring up the Display... dialog box.  
Each of the boxes functions as a toggle.  Clicking the mouse in the box 
next to an attribute turns the display of that attribute on or off.  You 
can also use the arrow keys to move the highlight box to each 
attribute.  Hitting <SPACE BAR> toggles the display attribute on and 
off.  You can then move the highlight box to the OK or Cancel button. 
    Choosing the Cancel button cancels any action; choosing the OK 
button tells DiskIt to re-display the current view showing only the 
attributes you have chosen.

Notice that turning the Volume Label display attribute on or off 
while in Disk view has no effect.  By default, the Disk view will always 
display the volume name.

Searching For Text   

Occasionally you may need to find some piece of text in your 
catalog; it could be a file name, a volume label, or part of a description.
You can use the Search menu in DiskIt to find any piece of text in you 
catalog.

Choosing the Search menu presents you with two choices:  Find...
and Find Next.  To find some string of text, choose Find... to bring up 
the Search For dialog box:
Simply type in the text string you want to search for (the search is not 
case-sensitive) and either click the OK button with the mouse, or hit 
the <ENTER> key.  To cancel this search, click the Cancel button.  

DiskIt will find the first occurrence of the text and highlight it.  If 
DiskIt cannot find the text, it will display the following dialog:
where 'text' will be replaced by the text string you were searching for.  

To perform a case sensitive search, simply click the mouse 
button in the Case Sensitive box.  If this box is not checked, DiskIt will 
search for any occurence of the text you specify, regardless of case.  

If DiskIt cannot find the text you specify, you will see the 
following dialog box, where 'drone' will be replaced by the text you 
were searching for:

To search for the next instance of the text string, choose Find 
Next from the Search menu.  

To search for a different string of text, simply repeat the process.

Using the Clipboard
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    As in most Windows applications, you can use the Clipboard to 
move data from one app to another.  Choosing Copy All from the Edit 
menu will copy the current view of the data file you are editing into the
Clipboard.  You can then paste this into another application.  

Getting Help

While you are using DiskIt, you can access online help through 
the Help menu. This menu has two choices:  Index... and About DiskIt...
Choosing Index brings up the following help window:
You can scroll through this window and pick topics  to find help on the 
major functions of DiskIt.  

To get help on a particular topic, just double click the mouse 
button on the topic, or highlight the topic and depress the Choose 
button.  For example, choosing DiskIt from the above dialog box and 
then pressing the Choose button brings up the following help dialog:

To close this help dialog, simply press the OK button with the 
mouse.

To close the Help For DiskIt window, just click the Cancel button.  
For further help, please consult the manual (if you don't have a copy, 
you can get one by registering DiskIt).

The second choice in the Help menu, About DiskIt... brings up the
following dialog box:
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Getting Help

There are several ways to get technical assistance for DiskIt.  You
can also give us feedback on DiskIt and its documentation.  We'd like 
to hear from you!  

The most fun way of getting help is through Compuserve or 
Internet email.  You can send mail to Stephen Drone via Compuserve; 
his user ID number is 70744,3621.  For a slightly less reliable yet 
infinitely more interesting way of sending email to us, use the Internet 
address SDRONE@CHINET.CHI.IL.US.  
    If for some unforseen reason you need to reach us immediately, 
you can phone us.  If you reach us at home, we will answer your 
questions.  If we are not at home, we will return calls from REGISTERED
USERS.  Here's how to reach us:

Richard Thompson (author of the DiskIt program)
401-964-1544 6 pm - 10 pm Eastern time, Monday to Friday

9 am - 5 pm Eastern time, Saturday and Sunday

Stephen Drone (program design and documentation)
708-853-1702 6 pm - 10 pm Central time, Monday - Friday

9 am - 5 pm Central time, Saturday and Sunday

You can also reach us at any time via Snail Mail (the U.S. Postal 
Service).  Address your lettters to Stephen Drone, P.O. Box 8041, 
Wilmette, IL, 60091.
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DiskIt Reference

File Menu
New Create a new catalog data file
Open... Open an existing catalog data file
Save Save the current catalog data file to disk
Save As... Save the current catalog data file under a new name
Print Print the current catalog to the default printer
Printer Setup... Change the setup of the default printer

Edit Menu
Copy All Copy the current view to the clipboard

Catalog Menu
Add... Add a new disk to the current catalog
Delete... Pick a volume to delete from the current catalog
Describe Files Add a description to a cataloged file name
Update... Update (from disk) a volume in the catalog

Search Menu
Find Search for text
Find Next... Find the next occurrence of a text string

View Menu
Disk Switch to the Disk view
Files Switch to the Files view

Sort By Menu Choose a file attribute to sort the display by

Display! Menu Choose the file attributes for the current view

Help Menu
Help Bring up the DiskIt quick reference
About... Display the DiskIt About box
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