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File menu commands

The File menu offers the following commands:

Open file Opens an existing document.
Close Closes an opened document.
New Search Opens the search window..
Open 
Search

Opens an existing search run

Save 
Search

Saves the currently active search

Save 
Search as

Saves the currently active search with a new name

Print Prints a document.
Print 
Preview

Displays the document on the screen as it would appear printed.

Print Setup Selects a printer and printer connection.
Exit Exits OOT.



Edit menu commands

The Edit menu offers the following commands:

Copy Copies data from the document to the clipboard.
Preview OLE 
Object

Previews the selected OLE object in the OLE pane.

Clear Preview Clear the preview pane. Use if you want to create a file based on the currently 
previewed object, because when in preview the object is locked and its 
impossible to create a file based on it.

Create File Prompts for a file name and writes the selected object to a file of its own.



View menu commands

The View menu offers the following commands:

Toolbar Document Shows or hides the toolbar.
Toolbar Search Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

Summary Switches to the Summary Information pane.
Storage Switches to the Storage pane.
Embedded Switches to the Embedded objects list pane
OLE Switches to the View OLE object pane.

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



Open command (File menu)

Use this command to open an existing document in a new window.    You can open multiple 
documents at once.    Use the Window menu to switch among the multiple open documents.  
See Window 1, 2, ... command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of file you want to open:

Document Files (*.doc) See also: Restrictions using Microsoft Word 6.0
Any Files (*.*)

Drives
Select the drive in which OOT stores the file that you want to open. 

Directories
Select the directory in which OOT stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your OOT session.    You can also use the Close command on the 
application Control menu.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in OOT, such as File Open.    A check mark appears next to the 
menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in OOT,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To
Open an existing document.    OOT displays the Open dialog box, in 
which you can locate and open the desired file.

Print the active document.

Copy the selection to the clipboard.

Preview the currently selected object.

Clear the preview pane.
Create a file based on the currently selected object.

Switches to the Summary pane.

Switches to structured storage pane.

Shows the list of all contained OLE objects.

In this pane the selected OLE object is previewed.

The first one opens the About Box, the second is used for context 
sensitive help.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the OOT window.    To display or hide the status 
bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate which of the following keys are latched down:

Indicator Description
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You
can open multiple document windows to display different parts or views of a document at 
the same time.    If you change the contents in one window, all other windows containing the 
same document reflect those changes.    When you open a new window, it becomes the 
active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.



1, 2, ... command (Window menu)

OOT displays a list of currently open document windows at the bottom of the Window menu. 
A check mark appears in front of the document name of the active window.    Choose a 
document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using OOT and various types of reference information.   

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of OOT.



Context Help command 

Use the Context Help command to obtain help on some portion of OOT.    When you choose 
the Toolbar's Context Help button, the mouse pointer will change to an arrow and question 
mark.    Then click somewhere in the OOT window, such as another Toolbar button.    The Help
topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:

Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the OOT window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window.    OOT determines which 
window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window.    OOT determines 
which window is previous according to the order in which you opened the windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the <<YourType>> window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Working with the Document

You do have multiple views of a document. Please refer to the View menu





No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that OOT is sending output to the printer.    
The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

Not applicable in this application (to this time of development).



What is it?
OOT (OLE Object Thief) is a program I´ve designed to work with all OLE 2.0 compound file 
specification compliant applications. Also added is a support for CorelDraw! 5, which doesn´t
have support for this file type. This support is added because of its predecessor, CFI, which 
was exclusivley designed to work with CorelDraw!.

For short: What can OOT do for you?

It simply opens the file, shows the Summary Information, the Storage structure, all 
contained objects and is capable of grabbing these objects and copying them to the 
clipboard, where you can reuse them. (that´s where the name comes from). Also added is 
support for printing objects and a list of all contained objects (to be extended in the future).

Searching capabilities are included like you know them from e.g. Word 6.0. Searching can be
done on all OLE 2.0 compatible file types. You can even specify to search only for a particular
application. See Search for more information.

Programmed with Visual C++ 1.5, mixed with own skill and time (as well as some tricks).



Registering
Send US$ 20 (eqivalent in European currencies like DM, FF, SF, ÖS accepted) with the 
completed form to the address below:

Christoph Wille
Noebauerweg 18
4820 Bad Ischl
AUSTRIA (EUROPE)

Registration Form for OOT
_______________________________________________________________________________

Name:___________________________________________________________

Address:_________________________________________________________

City:____________________________ Postal code:___________________

Country:________________

CIS:____________________ (if you have one, please include)

_______________________________________________________________________________

Version:___________ (see About for number)

What features do you want in future releases, what could be improved?

(from the extra space you see I really hope to get some hints...)
_______________________________________________________________________________



Known Problems
Word 6.0 doesn´t like this program, and vice versa. (in particular you can´t extract objects)    
Other programs do work well (as I have tested them). If you encounter problems with other 
programs, send me a description of the problem (sample file would be cool).

To do so:

Christoph Wille
Noebauerweg 18
4820 Bad Ischl
AUSTRIA (EUROPE)

CIS: 74372,3145



Summary

Like the Word Summary Information, but the way it was standardized by OLE 2.0. All 
programs using structured storage are supported. 
CorelDraw! 5 is also supported because I´m a great Corel enthusiast. The only items valid for
CorelDraw! 5 files are Template, Keywords and Comments. All other are not supported. 
Inserted objects nevertheless work fine.

List of items extracted

Title The title of the file. You normally entered it 
when first saving your file to disk.

Subject The subject you have been writing about.
Author Maybe you.
Keywords This keywords are used by the program to 

search for specified files. See Search 
command

Comments The description you added to characterize 
your document. 

Template Templates: The useful things to minimize your
effort. Always a good idea to know which one 
you used.

Application The application you used to create your file. 
This is the name you should enter when 
restricting the search for an application

Created The date the file was created.
Last saved The date you (or someone else) last saved 

the file.
Last saved by Here goes who last saved this file.
Last printed The date this file was printed the last time.
Revisionnumber Revisionnumber: How often you opened and 

saved your file till this day.
Edit time The time you had your file open the last time 

before you saved it to disk.



Storage
Shows the storage structure. This feature was included because I converted an SDK 
application to MFC C++ and I thought it would be interesting for people to see how 
programs store their data and where most megabytes are gone to. (to objects or to the 
native data of the program).

To expand the tree: CTRL + Right mouse button
To collapse the tree: SHIFT + Right mouse button



Embedded
A simple list of all embedded OLE objects. Printable. On screen an icon of the application 
used for creation of the object is displayed (if you do have installed this application). Clicking
on  Preview OLE object displays the object in the OLE pane.



OLE
The currently selected OLE object that has been viewed by Preview OLE object . This view is 
fully printable and you can copy the selection to the clipboard to use it in other applications. 
No edit is supported because this is too risky for the originating application.



Preview OLE Object
Previews the currently selected OLE object in the OLE pane. Doesn´t work correctly with 
Word 6.0.



View File command
See also

Select a file in the Found pane of the search window. Previews the selected object file.



Search command
See also

This command opens the search window. Only OLE file supported (no CorelDraw! 5 files). 
All items you add are searched for and compared to match all criterias. For viewing more 
help topics, click in the corresponding tabs.



License Agreement

This is a legal agreement between you ( either an induvidual or an entity ), the end user, 
and Christoph Wille. If you do not agree to the terms of this Agreement, promptly return the 
disks and the accompanying items ( if applicable ).

GRANT OF LICENSE: Christoph Wille grants you ( Recipient ) a limited, non-exclusive, 
nontransferrable license to make and use one (1) copy of the software accompanying this 
agreement ( Product ) on to be installed on one single CPU residing on Recipient´s premises. 
All other rights are reserved to Christoph Wille. Recipient shall not rent, lease, sell, 
sublicense, assign, or otherwise transfer the Product or any accompanying printed materials 
( Documentation ). Recipient may not reverse engineer, decompile the Product, except to 
the extent that the foregoing restriction is expressly prohibited by local law. Christoph Wille 
and its suppliers shall retain title and all ownership rights to the product, and this Agreement
shall not be constructed in any manner as transferring any rights of ownership or license to 
the Product or to the features or information therein, exceptas specifically stated herein.

DISCLAIMER OF WARRANTY: The product is provided as is without warranty of any kind. To 
the maximum extent permitted by applicable law, Christoph Wille futher disclaims all 
warranties, including without limitation any implied warranties of merchantability, fitness for 
a particular purpose and noninfringement. The entire risk arising out of the use or 
performance of the product and documentation remains with recipient.
To the maximum extent permitted by applicable law, in no event shall Christoph Wille or its 
suppliers be liable for any consequential, incidental, direct, indirect, special, punitive, or 
other damages whatsoever ( including, without limitation, damages for loss of business 
profits, business interruption, loss of business information, or other pecuniary loss ) arising 
out of the use of or inability to use the product or documentation, even if Christoph Wille has
been advised of the possibility of such damages. Because some states/jurisdictions do not 
allow the exclusion or limitation of liability for consequential or incidental damages, the 
above limitation may not apply to recipient.



Automation Support
This version now supports Automation. This means, you can program OOT via e.g: Visual 
Basic.

Document support: OOT.Document

Function Parameter Return

OpenDocument Filename as string Opens a document; return 
Values are True and False 
(failed to open document)

DocTitle No parameter Returns Title of document in a
string variable

DocAuthor
DocSubject
DocKeywords
DocComments
DocTemplate
DocDateCreated Returns Creation date in the 

following format: 01.01.1994, 
14:35

DocApplication
ShowWindow none; Shows application 

window.
HideWindow none; Hides application 

window.

Search support: OOT.Search

Function Parameter Return

SOTitle The title as string True/False
SOSubject The subject as string True/False
SOAuthor The author as as string True/False
SOKeywords The keywords as string True/False
SOApplication The application as string True/False
SOReset none True/False; Resets all search 

parameters
SOCreatedBetween Date after, date before as 

strings
True/False

SOCreatedInLastMonths Number of months as long True/False
SOCreatedInLastDays Number of days as long True/False
SOModifiedBetween see SOCreatedBetween
SOModifiedInLastMonths dito
SOModifiedInLastDays dito
SOIncludeSubDirectories True/False True/False; Selects wheter you

want to search subdirectories
SOAndSearch True/False True/False; If set to True, all 

items must match, else one 
items is enough.

OpenSearch True/False String containing the filename
of the searched search run. 
True if successfully opened.



SOAddDir2Search Directory as string True/False; Add a directory to 
your search list

Search none True/False; Starts the search
SRNumFoundFiles none Number of found files as long
SRGetFilePath Index of filename as long; 

Starts with 0, ends with 
SRNumFoundFiles - 1

Returns path of found files as 
string

ShowWindow none Shows search window
HideWindow none Hides search window

Visual Basic example:

Sub OpenDocFile ()
        

Dim x As Object
Dim result As Integer
Dim strText As String

Set x = CreateObject("OOT.Document")
result = x.OpenDocument("d:\christof\dokument\oot1.doc")
x.ShowWindow

strText = x.DocApplication
Debug.Print strText

strText = x.DocTitle
Debug.Print strText

strText = x.DocAuthor
Debug.Print strText

End Sub

Sub DoSearch ()
        
        Dim src As Object
        Dim result As Integer, i As Integer
        Dim strResult As String
        Set src = CreateObject("OOT.Search")

        result = src.SOTitle("OOT")
        result = src.SOAuthor("Chris")
        result = src.SOAddDir2Search("C:\HOMEDIR\CHRISTOF")
        result = src.Search()
        For i = 0 To src.SRNumFoundFiles - 1
                strResult = src.SRGetFilePath(i)
                Debug.Print strResult
        Next i

End Sub



String Search
Title Enter the substring you want to search in the 

title of files.
Subject same as above
Author same as above
Keywords Here only one string is allowed (no or search 

is possible)
Application Please enter the full (nearly) name of the 

application: e.g.: Microsoft Word 6.0 could 
abbreviate to Word 6 and the files would be 
found too.



Selecting directorys
Choose the drive in the drives combo box, then a list of all available directorys is displayed. 
Doubleclick to open a subdirectory. When you´ve reached the desired directory, select it and
click the Add button. To remove a directory from the selected directorys list, highlight it and 
click the Remove button. To remove all selected directorys, click the Remove all button. 
Entire drive chooses the currently selected drive to be searched.



Selecting a date range
Here you have the option of selecting the creation date options as well as the last modified 
date options. Because these two are very similar, I´ll describe these options only once.

in last month(s) If you have selected this option, you are 
searching the last X months you have 
selected.

          in last day(s) Same as above, but the last X days from 
today.

between ... and This represents a date range. The default 
range is from the first of the month to today. 
The notation is: dd/mm/YYYY (European date 
format).



Found list
Here all files matching your search criterias are displayed. Select a file and choose 
Search/View File displays the file contents.



Toolbar Search

This second toolbar is provided for searching. See the following table for description.
Click To

Opens a new Search window.
Opens an existing search run.
Saves the current search run.
Prints the list of found files.

Toggle buttons. Select and to match all criterias, select or the 
match at least on criteria.
Search for Title.
Search for Subject .
Search for Author .
Search for Keywords
Search for Comment . Not implemented.
Search for files created between a specified range of days.
Search for files that were last modified between a specified 
range of days.
Search for files of a specific Application  only.
Starts or cancels a search run. See also: Start search
View a file in the found pane. See also: View file.



Search menu
Click To

Search 4 Open popup menu
Title Search for title
Subject 
Author 
Keywords
Comment Not implemented
Date created
Date last saved
Application 

Match all Select this item to match all criterias you selected.
Match on (at 
least)

Select this item to search for files matching at least 
one of the selected criterias.

Start Search Starts the search
View File Views a selected file.



Search 4 Subject

 If the button(menu) is checked, the program will search for the text you´ve entered in the 
edit box Subject.



Search 4 Title

 If the button(menu) is checked, the program will search for the text you´ve entered in the 
edit box Title.



Search 4 Author

 If the button(menu) is checked, the program will search for the text you´ve entered in the 
edit box Author.



Search 4 Keywords

 If the button(menu) is checked, the program will search for the text you´ve entered in the 
edit box Keywords.



Search 4 Comment

Not yet implemented!



Search 4 Creation date

 If the button(menu) is checked, the program will search for the date range you have 
selected in the Date tab.



Search 4 Date last modfied

 If the button(menu) is checked, the program will search for the date range you have 
selected in the Date tab.



Search 4 Application

 If the button(menu) is checked, the program will search for the text you´ve entered in the 
edit box Application.



Start search

Choose this command(button) to start the search. While the search is running, the currently 
active directory is shown in the status bar. For canceling a search, click the button again (will
show the caption Cancel while searching). When the search is complete, the old caption will 
reappear and the status bar will show the message Search complete!



Technical Background Automation for OOT.Search
Following there is a snapshot from my sources for better understanding of the functions 
SOTitle and so on, which are setting string information:

BOOL SOSetAStringValue(String)
{

if Searching return FALSE;
if String is Zero length return FALSE;
Set value for searching
if all correct, return TRUE;

}

So the reasons for a FALSE return from this function are (marked blue):

Currently the program is searching (started with Search()), but not complete
The string you supplied is empty



Open search
Select this command to open an existing search run.



Match all
If this menu/button is checked, all items you have selected must be matched in the files you 
are searching for.



Match one (at least)
If this menu/button is checked, only one item you have selected needs to be matched in the 
files you are searching for.



Clear preview
Clears the currently displayed object from the preview pane. Use this command if you want 
to create a file based on this object. This is necessary, because for previewing the object is 
locked exclusively, so you can´t create the file.

See also: Create file



Create file
Creates a file based on the currently selected object. The following objects are supported: 
OLE 1 objects, OLE 2 normal DOS files and OLE 2 compound documents (those with the nice 
storage structure). If the program is in doubt what format to choose, you will be asked to 
select an appropriate format. If you are trying it for this kind of objects the first time, save to
both formats and then try which one will reopen in the object´s original application.

Limitations:
I´ve encountered problems with Microsoft´s Powerpoint, which, when used stand-alone, 
stores in compound files, but when used as object, stores as OLE 1 file. As you can guess, 
OOT therefore can´t recreate this file for you.
In general, OLE 1 objects may not be reproduced correctly (as Paintbrush does).



Storage folder

Like a DOS subdirectory. Doubleclick on it to open or close the folder.



Stream item

Like a DOS file. The name is displayed in parentheses, e.g. 'This_is_a_Stream'. To 
right you see the size of the item displayed in byte.



File

The file containing the storage structure. Exception are CorelDraw! 5 files: Here only
the object storage is displayed, not the entire file



Open File,View file



Clicking here will open the second tab and show all the files that matched your 
search. Will be opened automatically when the search is completed.



Lists all drives (including network drives) where you can search for files. Default 
selection is your first fixed disk in your system.



Clicking on this check box opens a dialog box where you can add / remove 
directories where the program should search specifically.



When this box is checked, all subdirectories below the ones you selected (or drive) 
are included in the search.



This drop-down combo box lets you specifiy two dates (or one), limiting the files to 
this specific range of dates. Editing is done directly in the combo box.

ATTENTION: date format is DD.MM.YYYY (European date format)



Like Creation options, but you can also specify the last editing author.



Click to start the search. While searching, the program displays Stop Search and 
shows the directory it currently is searching in the status bar. Hit it again to stop the
search.



Entering the Application will restrict the search only to files originated by this file.



The title you used for this file.



The author that created this file. Maybe you.



What shall I say: The subject!



Enter a keyword you know that´s contained in the file you are searching for.



Search






