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Using the keyboard with ARIS EDIT 2.0

Moving the cursor:

Generally you use the arrow keys and the page keys to move the cursor within an ARIS EDIT 
text window.
The keys HOME and END move the cursor to the start or the end of the current line 
respectively.
Below you will find an additional list of key combinations that allow to move the cursor 
within the text:

Alt +    down arrow Move down one paragraph (paragraphs are separated by empty lines)
Alt + up arrow Move cursor one paragraph up
Ctrl + END Move cursor to the end of the file
Ctrl + HOME Move cursor to the beginning of the file
Ctrl + left arrow Move cursor one word to the left
Ctrl + rigth arrow Move cursor one word to the right

Selecting text:

You can use any key for moving the cursor in combination with the shift key to highlight 
areas of text.
Just hold the shift key down while moving the cursor and you will see the area of selected 
text grow or shrink accordingly.
One additional key combination (Ctrl + M) allows you to highlight text enclosed by braces.

Clipboard functions:

- (Numeric keypad) Move current line to the clipboard
+ (Numeric keypad) Copy current line to the clipboard
Ctrl + B Append selection to clipboard
Ctrl + C Copy selection to clipboard
Ctrl + INSERT Copy selection to clipboard
Ctrl + V Insert clipboard at current cursor location
Ctrl + X Move (copy and delete) the current selection to the clipboard
Shift + DEL Move (copy and delete) the current selection to the clipboard
Shift + INSERT Insert clipboard at current cursor location

Menu shortcuts:

Alt + BACKSPACE Undo the last editing action
Alt + F3 Search for    a string or a regular expression
Ctrl + A Redo the last undone action
Ctrl + L Move to a specific line
Ctrl + N Open a new, empty editing window
Ctrl + O Open an existing file
Ctrl + P Print the current file
Ctrl + S Save the current file to disk
Ctrl + Z Undo the last editing action
Ctrl + F2 Toggle bookmark at current line
F1 Help
F2 Jump to next bookmark
F11 Start or stop macro recording
F12 Play a previously recorded macro
Shift + BACKSPACE Redo the last undone action



Shift + F1 Context sensitive help
Shift + F2 Jump to previous bookmark

Switching windows:

F6 Switch to the next window
Shift + F6 Switch to the previous window

Miscellaneous:

Alt + F5 Loads the file on whose name the cursor is placed.
Ctrl + W Outlines the current file.
Alt + left arrow Undindents current selection
Alt + right arrow Indents current selection by one tab
BACKSPACE Deletes the character left of the current cursor position
Ctrl + Y Deletes the current line
DEL Deletes the current selection or the character at the cursor position
INSERTToggles Insert/Overwrite mode
Shift + TAB Undindents current selection



File menu commands

The File menu offers the following commands:

New Creates a new file.
Open Opens an existing file.
Insert Inserts an existing file at the current cursor position
Directory Changes the current working directory
Close Closes an opened file.
Save Saves an opened file using the same file name.
Save As Saves an opened file to a specified file name.
Close all Closes all currently opened files. For any modified file you will 

be prompted whether to save it.
Save all Saves all currently opened files to disk if they have been 

modified.
Send current file Send the currently active file via Microsoft Mail. This menu item

is only available if Microsoft Mail is installed on your computer.
Send all open files Send all currently opened files via Microsoft Mail. This menu 

item is only available if Microsoft Mail is installed on your 
computer.

Print Prints a file.
Print Preview Displays the file on the screen as it would appear printed.
Print Setup Selects a printer and printer connection.
Exit Exits ARIS EDIT 2.0



Edit menu commands

The Edit menu offers the following commands:

Undo Reverse previous editing operation. You can undo the last 200 actions
Redo Repeats the previous undone action. You can redo the last 200 undone 

actions
Cut Deletes data from the file and moves it to the clipboard.
Copy Copies data from the file to the clipboard.
Paste Pastes data from the clipboard into the file.
Append to clipboard The selected data is appended to any previous contents of the 

clipboard.
Clipboard Starts the Windows clipboard viewer
Search Opens a dialog box where a search expression can be entered
Replace Opens a dialog box where a search and replace expressions can be 

entered
Uppercase Converts the characters in the current selection to uppercase
Lowercase Converts the characters in the current selection to lowercase
Decimal Converts a marked number to decimal
Hexadecimal Converts a marked number to hexadecimal
Octal Converts a marked number to octal.



View menu commands

The View menu offers the following commands:

Toolbar Shows or hides the toolbar.
Status Bar Shows or hides the status bar.

File Open Window Shows or hides the persistent open window
Document Tabs Shows or hides the document tabs
Toggle Bookmark Toggles the bookmark at the current line
Next Bookmark Jumps to next bookmark
Previous Bookmark Jumps to the previous bookmark
Clear all bookmarks Clears all bookmarks in the current window
Jump to    line Jumps to a specific line number
Word wrap Toggles the word wrap 
Outline Shows an outline window for the current file

Workset menu commands 

The Workset menu offers the following commands:

Open Opens an existing workset
New Creates a new workset
Edit Edits the currently loaded workset
Load from workset Loads a file from the currently loaded workset



Options menu commands

The Options menu offers the following commands:

Settings With this topic you can change several settings of 
ARIS EDIT 2.0

Font Changes the font of the currently active window
Tools Adds or deletes items of the Tools menu
Extensions Adds or deletes file types recognized by ARIS EDIT

2.0
Printing Changes printing options



Tools menu commands

The Tools menu offers the following commands:

 
Grep Invokes a search for a regular expression in the current directory
Program Opens a dialog for selection of the program to start
Custom items Additional tools menu items. You can add up to ten custom tools to this menu

with the topic Tools from the Options menu
DOS Opens a DOS commandline window.

Window menu commands

The Window menu offers the following commands, which enable you to arrange multiple 
views of multiple documents in the application window:

New Window Creates a new window that views the same document.
Cascade Arranges windows in an overlapped fashion.
Tile horizontal Arranges windows in non-overlapped tiles.
Tile vertical Arranges windows in non-overlapped tiles.
Arrange Icons Arranges icons of closed windows.
Window 1, 
2, ...

Goes to specified window.



Help menu commands

The Help menu offers the following commands, which provide you assistance with this 
application: 

Index Offers you an index to topics on which you can get help.
Using 
Help

Provides general instructions on using help.

About Displays the version number of this application.



New command (File menu)

Use this command to create a new file in ARIS EDIT 2.0.

You can open an existing file with the Open command.

Shortcuts

Toolbar:
Keys: CTRL+N



Open command (File menu)

Use this command to open an existing file in a new window.    You can open multiple files at 
once.    Use the Window menu to switch among the multiple open documents.    See Window 
1, 2, ... command.

You can create new documents with the New command.

Shortcuts

Toolbar:
Keys: CTRL+O



File Open dialog box

The following options allow you to specify which file to open:
File Name

Type or select the filename you want to open.    This box lists files with the extension you 
select in the List Files of Type box. 

List Files of Type
Select the type of files you want to see in the filename list

Drives
Select the drive in which ARIS EDIT 2.0 stores the file that you want to open. 

Directories
Select the directory in which ARIS EDIT 2.0 stores the file that you want to open.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



Close command (File menu)

Use this command to close all windows containing the active document. ARIS EDIT 2.0 
suggests that you save changes to your document before you close it.    If you close a 
document without saving, you lose all changes made since the last time you saved it.    
Before closing an untitled document, ARIS EDIT 2.0 displays the Save As dialog box and 
suggests that you name and save the document.

You can also close a document by using the Close icon on the document's window, as shown 
below:



Save command (File menu)

Use this command to save the active document to its current name and directory.    When 
you save a document for the first time, ARIS EDIT 2.0 displays the Save As dialog box so you
can name your document.    If you want to change the name and directory of an existing 
document before you save it, choose the Save As command.

Shortcuts

Toolbar:
Keys: CTRL+S



Save As command (File menu)

Use this command to save and name the active document. ARIS EDIT 2.0 displays the Save 
As dialog box so you can name your document.    

To save a document with its existing name and directory, use the Save command.



File Save As dialog box

The following options allow you to specify the name and location of the file you're about to 
save:
File Name

Type a new filename to save a document with a different name.    A filename can contain 
up to eight characters and an extension of up to three characters. ARIS EDIT 2.0 adds the
extension you specify in the Save File As Type box.

Drives
Select the drive in which you want to store the document.

Directories
Select the directory in which you want to store the document.

Network...
Choose this button to connect to a network location, assigning it a new drive letter. 



1, 2, 3, 4 command (File menu)

Use the numbers and filenames listed at the bottom of the File menu to open the last four 
documents you closed.    Choose the number that corresponds with the document you want 
to open.



Exit command (File menu)

Use this command to end your ARIS EDIT 2.0 session.    You can also use the Close command 
on the application Control menu. ARIS EDIT 2.0 prompts you to save documents with 
unsaved changes.

Shortcuts
Mouse: Double-click the application's Control menu button.

Keys: ALT+F4



Insert command (File menu)

Use this command to insert an existing file at the current cursor position. 



Directory command (File menu)

Use this command to change the current working directory. The appearing dialog box allows 
you to change the current directory as well as the current drive.
The persistent file open window showing your custom file types will be updated 
automatically.



Close all command (File menu)

Use this command to close all currently open files at once. ARIS EDIT 2.0 suggests that you 
save changes to any modified document before you close it.    If you close a document 
without saving, you lose all changes made since the last time you saved it.    Before closing 
an untitled document, ARIS EDIT 2.0 displays the Save As dialog box and suggests that you 
name and save the document.



Save all command (File menu)

Use this command to save all currently open files to their current name and directory.    
When you save a document for the first time, ARIS EDIT 2.0 displays the Save As dialog box 
so you can name your document.    If you want to change the name and directory of an 
existing document before you save it, choose the Save As command.



Send current file (File menu)

Use this command to send the currently active file with Microsoft Mail to another user. This 
command is not available if Microsoft Mail is not installed on your computer. Please refer to 
the documentation of MS Mail for further information.



Send all open files (File menu)

Use this command to send all currently open files with Microsoft Mail to another user. This 
command is not available if Microsoft Mail is not installed on your computer. Please refer to 
the documentation of MS Mail for further information.



Undo command (Edit menu)

Use this command to reverse the last editing action. You can undo the last 200 editing 
actions.

Shortcuts

Toolbar:
Keys: CTRL+Z or

ALT-BACKSPACE



Redo command (Edit menu)

Use this command to repeat a previously undone action. You can repeat the last 200 undone
actions.

Shortcuts

Toolbar:
Keys: CTRL+A or

Shift-BACKSPACE



Cut command (Edit menu)

Use this command to remove the currently selected data from the document and put it on 
the clipboard.    This command is unavailable if there is no data currently selected.

Cutting data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+X



Copy command (Edit menu)

Use this command to copy selected data onto the clipboard.    This command is unavailable if
there is no data currently selected.

Copying data to the clipboard replaces the contents previously stored there.

Shortcuts

Toolbar:
Keys: CTRL+C



Paste command (Edit menu)

Use this command to insert a copy of the clipboard contents at the insertion point.    This 
command is unavailable if the clipboard is empty.

Shortcuts

Toolbar:
Keys: CTRL+V



Append command (Edit menu)

Use this command to append the selected text to the current clipboard contents. If the 
clipboard is empty the current selection is copied to the clipboard.



Clipboard command (Edit menu)

Use this command to start the Windows clipboard viewer CLIPBRD.EXE. You can then inspect
the current contents of the Windows clipboard.



Convert uppercase command (Edit menu)

Use this command to convert the current selection to uppercase if possible. If no text is 
selected this command converts the character at the current cursor position to uppercase.



Convert lowercase command (Edit menu)

Use this command to convert the current selection to lowercase if possible. If no text is 
selected this command converts the character at the current cursor position to lowercase.



Convert decimal command (Edit menu)

Use this command to convert a marked hexadecimal or octal number to a decimal number. 
ARIS EDIT 2.0 recognizes the base of the marked number as follows:

Number is preceeded by the character x or by 0x: hexadecimal number
Number is preceeded by a zero: octal number



Convert hexadecimal command (Edit menu)

Use this command to convert a marked decimal or octal number to a hexadecimal number.



Convert octal command (Edit menu)

Use this command to convert a marked decimal or hexadecimal number to an octal number.



Toolbar command (View menu)

Use this command to display and hide the Toolbar, which includes buttons for some of the 
most common commands in ARIS EDIT 2.0, such as File Open.    A check mark appears next 
to the menu item when the Toolbar is displayed.

See Toolbar for help on using the toolbar.



Toolbar

The toolbar is displayed across the top of the application window, below the menu bar.    The 
toolbar provides quick mouse access to many tools used in ARIS EDIT 2.0,

To hide or display the Toolbar, choose Toolbar from the View menu (ALT, V, T).

Click To

Toggle visibility of the permanent file open window

Load a file from the current workset.

Open a new document.

Open an existing document. ARIS EDIT 2.0 displays the Open dialog box, in which you
can locate and open the desired file.

Save the active document or template with its current name.    If you have not named
the document, ARIS EDIT 2.0 displays the Save As dialog box.

Remove selected data from the document and stores it on the clipboard.

Copy the selection to the clipboard.

Insert the contents of the clipboard at the insertion point.

Search for a string or a regular expression.

Reverse the last editing.    Note:    You cannot undo some actions.

Reverse the last undo.

Cascade the currently opened windows.

Tile the open windows vertically.

Tile the open windows horizintally.

Print the active document.



Outline the active document.



Status Bar command (View menu)

Use this command to display and hide the Status Bar, which describes the action to be 
executed by the selected menu item or depressed toolbar button, and keyboard latch state. 
A check mark appears next to the menu item when the Status Bar is displayed.

See Status Bar for help on using the status bar.



Status Bar

The status bar is displayed at the bottom of the ARIS EDIT 2.0 window.    To display or hide 
the status bar, use the Status Bar command in the View menu.

The left area of the status bar describes actions of menu items as you use the arrow keys to 
navigate through menus.    This area similarly shows messages that describe the actions of 
toolbar buttons as you depress them, before releasing them.    If after viewing the description
of the toolbar button command you wish not to execute the command, then release the 
mouse button while the pointer is off the toolbar button.

The right areas of the status bar indicate the state of the current file or the state of system 
keys:

Indicator Description
REC ARIS EDIT currently records a macro.
OVR ARIS EDIT is in overwrite mode.
READ The active document is read-only.
CAP The Caps Lock key is latched down.
NUM The Num Lock key is latched down.
SCRL The Scroll Lock key is latched down.

000100 Indicates the current line in the active document
0001 Indocates the current column the cursor is in.



New command (Window menu)

Use this command to open a new window with the same contents as the active window.    You
can open multiple document windows to display different parts or views of a document at 
the same time.    If you change the contents in one window, all other windows containing the 
same document reflect those changes.    When you open a new window, it becomes the 
active window and is displayed on top of all other open windows.



Cascade command (Window menu)

Use this command to arrange multiple opened windows in an overlapped fashion. 



Tile command (Window menu)

Use this command to arrange multiple opened windows in a non-overlapped fashion.



Tile Horizontal command (Window menu)

Use this command to vertically arrange multiple opened windows in a non-overlapped 
fashion.



Tile Vertical command (Window menu)

Use this command to arrange multiple opened windows side by side.



Window Arrange Icons Command

Use this command to arrange the icons for minimized windows at the bottom of the main 
window.    If there is an open document window at the bottom of the main window, then 
some or all of the icons may not be visible because they will be underneath this document 
window.



1, 2, ... command (Window menu)

ARIS EDIT 2.0 displays a list of currently open document windows at the bottom of the 
Window menu.    A check mark appears in front of the document name of the active window.  
Choose a document from this list to make its window active.    



Index command (Help menu)

Use this command to display the opening screen of Help.    From the opening screen, you can
jump to step-by-step instructions for using ARIS EDIT 2.0 and various types of reference 
information.    

Once you open Help, you can click the Contents button whenever you want to return to the 
opening screen.



Using Help command (Help menu)

Use this command for instructions about using Help.



About command (Help menu)

Use this command to display the copyright notice and version number of your copy of ARIS 
EDIT 2.0.



Context Help command 

Use the Context Help command to obtain help on some portion of ARIS EDIT 2.0.    When you
choose the Toolbar's Context Help button, the mouse pointer will change to an arrow and 
question mark.    Then click somewhere in the ARIS EDIT 2.0 window, such as another Toolbar
button.    The Help topic will be shown for the item you clicked.

Shortcut
Keys: SHIFT+F1



Title Bar

<< Show your application's title bar here. >>

The title bar is located along the top of a window.    It contains the name of the application 
and document.

To move the window, drag the title bar.    Note: You can also move dialog boxes by dragging 
their title bars.

A title bar may contain the following elements:
Application Control-menu button
Document Control-menu button
Maximize button
Minimize button
Name of the application
Name of the document
Restore button



Scroll bars

Displayed at the right and bottom edges of the document window.    The scroll boxes inside 
the scroll bars indicate your vertical and horizontal location in the document.    You can use 
the mouse to scroll to other parts of the document.

<< Describe the actions of the various parts of the scrollbar, according to how they behave 
in your application. >>



Size command (System menu)

Use this command to display a four-headed arrow so you can size the active window with the
arrow keys.

After the pointer changes to the four-headed arrow:
1. Press one of the DIRECTION keys (left, right, up, or down arrow key) to move the pointer 

to the border you want to move.    
2. Press a DIRECTION key to move the border.
3. Press ENTER when the window is the size you want.

Note:    This command is unavailable if you maximize the window.

Shortcut
Mouse: Drag the size bars at the corners or edges of the window.



Move command (Control menu)

Use this command to display a four-headed arrow so you can move the active window or 
dialog box with the arrow keys.

Note:    This command is unavailable if you maximize the window.

Shortcut
Keys: CTRL+F7



Minimize command (application Control menu)

Use this command to reduce the ARIS EDIT 2.0 window to an icon.

Shortcut

Mouse: Click the minimize icon  on the title bar.
Keys: ALT+F9



Maximize command (System menu)

Use this command to enlarge the active window to fill the available space.

Shortcut

Mouse: Click the maximize icon  on the title bar; or double-click the title bar.
Keys: CTRL+F10 enlarges a document window.



Next Window command (document Control menu)

Use this command to switch to the next open document window. ARIS EDIT 2.0 determines 
which window is next according to the order in which you opened the windows.

Shortcut
Keys: CTRL+F6



Previous Window command (document Control menu)

Use this command to switch to the previous open document window. ARIS EDIT 2.0 
determines which window is previous according to the order in which you opened the 
windows.

Shortcut
Keys: SHIFT+CTRL+F6



Close command (Control menus)

Use this command to close the active window or dialog box.

Double-clicking a Control-menu box is the same as choosing the Close command.

Note:    If you have multiple windows open for a single document, the Close command on the
document Control menu closes only one window at a time.    You can close all windows at 
once with the Close command on the File menu.

Shortcuts
Keys: CTRL+F4 closes a document window

ALT+F4 closes the window or dialog box



Restore command (Control menu)

Use this command to return the active window to its size and position before you chose the 
Maximize or Minimize command.



Switch to command (application Control menu)

Use this command to display a list of all open applications.    Use this "Task List" to switch to 
or close an application on the list.

Shortcut
Keys: CTRL+ESC

Dialog Box Options
When you choose the Switch To command, you will be presented with a dialog box with the 
following options:
Task List

Select the application you want to switch to or close.
Switch To

Makes the selected application active.
End Task

Closes the selected application.
Cancel

Closes the Task List box.
Cascade

Arranges open applications so they overlap and you can see each title bar.    This option 
does not affect applications reduced to icons.

Tile
Arranges open applications into windows that do not overlap.    This option does not 
affect applications reduced to icons.

Arrange Icons
Arranges the icons of all minimized applications across the bottom of the screen.



Ruler command (View menu)

<< Write application-specific help here. >>



Choose Font dialog box

<< Write application-specific help here. >>



Choose Color dialog box

<< Write application-specific help here. >>



Search command (Edit menu)

Use this command to initiate a search for text or for a regular expression in the active 
window.

Shortcuts

Toolbar:
Keys: ALT+F3



Specifies the string of charcaters to find, or the regular expression to match.



Finds only text strings that match the case of the characters in the Find What string exactly. 
Otherwise, the command finds strings with either upper- or lowercase characters that match 
the characters in the Find What string.



The options have the following meanings:

Up Search from the current cursor position towards the beginning of the file.
Down Search from the current cursor position towards the end of the file.



Interprets special characters in the Find What box as patterns to match. Special characters 
and their matches are:

. Any single character.
* None or more of the preceding character or expression. For instance, ba*c matches 

bc, bac, baac, baaac, and so on.
+ At least one or more of the preceding character or expression. For instance, ba+c 

matches bac, baac,baaac, but not bc.
^ The beginning of a line.
$ The end of a line.
[] Any on of the characters contained in the brackets, or any of an ASCII range of 

characters separated by ahyphen. For instance, b[aeiou]d matches bad, bed, bid, bod
and bud, and r[eo]+d matches red, rod, reed, rood, but not reod or roed. x[0-9] 
matches x0, x1, x2 and so on.

\ Removes the pattern match characteristics from the special characters listed above. 
For instamce, 100$ matches 100 at the end of a line, but 100\$ matches the 
character string 100$ anywhere on a line.



Finds only text strings that match the    characters in the Find What string exactly. Otherwise,
the command finds also strings that are substrings of larger character strings.



Find dialog box

Use the Find dialog box to:

    Find a symbol or a sequence of symbols in a file.
    Find all symbols or sequences of symbols that match a given pattern.

Options

 Find What
 Match Case
 Match Whole Word Only
 Regular Expression
 Direction

Tips and Troubleshooting

If you are using regular expressions, remember to use a backslash in front of a special 
character if you 
want to use it without its special meaning. For instance, if you want to search for filenames 
ending 
with the extension .DOC or .DOT, and you use the regular expression .DO[CT], that 
expression also 
finds :DOC, @DOC, %DOT, _DOT, and so on. Those strings are not what you intended to find.
To 
match the period character (.) only, your regular expression should be \.DO[CT].



Replace command (Edit menu)

Use this command to replace one string or regular expression with another.



The string of characters to replace the characters found. You cannot use regular expressions 
in this string.



Replaces all strings that match the Find What string automatically, without requiring 
confirmation for each replacement.



Replace dialog box

Use the Replace dialog box to:

    Find and replace a symbol or a sequence of symbols in a file.
    Find and replace all symbols or sequences of symbols that match a given pattern.

Options

    Find What
    Match Case
    Replace With
    Match Whole Word Only
    Regular Expression
 Replace All

Tips and Troubleshooting

It is a good idea to test regular expressions using only the Find command before using the 
Replace 
command, because they may match expressions that you don't intend to match. You should 
test 
them especially if you intend to use the Replace All option, because you can only Undo the 
very last 
replacement if your regular expression replaces unintended matches.



Repeat command (Edit menu)

Use this command to repeat the last editing command carried out.    The Repeat menu item 
changes to Can't Repeat if you cannot repeat your last action.

Shortcut
Key: F4



Clear command (Edit menu)

<< Write application-specific help here. >>



Clear All command (Edit menu)

<< Write application-specific help here. >>



Next Pane

<< Write application-specific help here. >>



Prev Pane

<< Write application-specific help here. >>



Using the right mouse button

Whenever you press the right mouse button within an ARIS EDIT text window a small menu 
appears at the location of the mouse cursor. The contents of this menu depends on whether 
you have currently selected a protionof text or not. See the tables below for a description of 
these menus.

This table shows the contents of the menu if no text is selected:

Paste Inserts the contents of the clipboard at the current cursor position.
Insert file Inserts a disk file at the current cursor position.
Uppercase Converts the character at the current cursor position to uppercase if 

possible.
Lowercase Converts the character at the current cursor position to lowercase if 

possible.

This table shows the contents of the menu if some text is currently selected:

Cut Copies the selected text to the clipboard and deletes it from the text.
Copy Copies the current selection to the clipboard.
Paste Inserts the contents of the clipboard at the current cursor position.
Append Appends the current selection to the clipboadr contents.
Uppercase Converts the character at the current cursor position to uppercase if 

possible.
Lowercase Converts the character at the current cursor position to lowercase if 

possible.
Convert to decimal Converts the currently selected number to decimal, if possible.
Convert to hex Converts the currently selected number to hexadecimal.
Convert to octal Converts the currently selected number to octal.



Modifying the Document

<< Write application-specific help here that provides an overview of how the user should 
modify a document using your application.    

If your application supports multiple document types and you want to have a distinct help 
topic for each, then use the help context i.d. generated by running the MAKEHELP.BAT file 
produced by AppWizard.    Alternatively, run MAKEHM as follows:

makehm IDR_HIDR_,0x2000 resource.h

If the IDR_ symbol for one of your document types is, for example, IDR_CHARTTYPE, then the
help context i.d. generated by MAKEHM will be HIDR_CHARTTYPE.

Note, AppWizard defines the HIDR_DOC1TYPE help context i.d. used by this help topic for the
first document type supported by your application.    AppWizard produces an alias in the .HPJ 
file for your application, mapping HIDR_DOC1TYPE to the HIDR_ produced by MAKEHM for 
that document type. >>



Using drag and drop from the File Manager

You can use the drag and drop mechanism of the File Manager to open one or more files with
ARIS EDIT. In order do do so, simply select the files you want top open in the File Manager 
and drag them with the mouse inside the ARIS EDIT main window. This process is very 
similar to copying files with drag and drop. ARIS EDIT will instantly open the dropped files 
and, in case it was iconized, it will restore ist window to its former size and location. If you 
drop any file already opened by ARIS EDIT this file will not be opened again.



Using drag and drop with text

ARIS EDIT allows you to move or copy text by simply dragging it with the mouse. You can 
move and copy text within the same ARIS EDIT window or you can copy text across different 
windows by using drag and drop.

To move any text to another location within a file simply select this portion of text, place the 
mouse cursor with the highlighted area, press the left mouse button and start dragging the 
text to ist new location while holding the left mouse button down.

 The mouse cursor changes accordingly, indicating that you are currently dragging text.

When you release the left mouse button the selected text will be moved to the new position.
If you hold down the Ctrl-key while dragging the text it will be copied to the new location 
instead of being moved.

NOTE: If you have to scroll the window to reach the position where you want to drop the 
selected text, keep the mouse cursor withing the boundaries of the window (on the 
horizontal scrollbar to scroll down or on the caption to scroll up).

To copy a selected text across different ARIS EDIT windows simply drag the cursor to the 
destination window and drop the text as before. Please note that across windows you can 
only copy text rather than moving it.



Opening files with ARIS EDIT

Since opening files is one of the most used functions in almost any application ARIS EDIT 
provides 5 different ways to open files. Try any of the functions listed below to determine 
which one is the most convinient for you.

1. Using the file open dialog

2. Using drag and drop

3. Using the permanent File open window

4. Using associations with the File Manager

5. Specifying files on the command line



Specifying files on the command line

If you want ARIS EDIT to load one or more files on startup you can simply specify these files 
on the command line. Use Alt-Enter with ARIS EDITs icon in the Program Manager highlighted
and edit the entry Command Line accordingly.
Please note that you must specify a fully qualified file name when the file is not present in 
the initial working directory.



Using associations with the File Manager

Within the Windows file manager you can easily associate file types you frequently edit with 
ARIS EDIT. As ARIS EDIT registers itself in the Windows registration database all you have to 
do is to select the topic Associate... from the file managers File menu, enter an extension 
(i.e. .CPP) and choose ARIS EDIT from the list of available applications.

From there on a simple double click on a file with such an extension in the Windows file 
manager automatically launches ARIS EDIT with this file. Subsequent double clicks (with 
ARIS EDIT already started) simply open additional windows within ARIS EDIT, because its 
capabilities as a DDE server. 
You can even print with ARIS EDIT without specifically launching it. Simply drag a file whose 
extension is associated with ARIS EDIT to your Windows Print Manager. Windows will then 
launch ARIS EDIT (or using an already running instance), instruct it to print the dragged file 
and terminate it in case it was not already running.

Note: You must start ARIS EDIT at least once before you can associate a file 
extension to it, as it creates the entries in the Windows registration 
database on startup rather than during installation.



Using the permanent file open window

On the left side of the ARIS EDIT window you can see the permanent file open window. If you
dont see this window you can make it visible by using the command File Open Window from 
the View menu or by using the toolbar button .

Initially you will see little folder icons  that correspond to your adjustments of ARIS EDITs 
default extensions.

By double clicking on such a folder the folder will open  and a list of files with the 
corresponding extensions will be shown. Double clicking on an open folder closes the list 
again.

You can now easily open files in the current directory by simply double clicking on its name 
in the list. If you attempt to open a file already loaded by ARIS EDIT this file will get the input
focus rather than be loaded again.

If you changed the contents of the current directory, for example by using the file manager 
to delete, move or copy some files from or to the current directory, an expanded list in the 
file open window will not automatically reflect these changes. To update the list simply close 
the appropriate folder and re-open it again.



No Help Available

No help is available for this area of the window.



No Help Available

No help is available for this message box.

<< If you wish to author help specific to each message box prompt, then remove the 
AFX_HIDP_xxx values from the [ALIAS] section of your .HPJ file, and author a topic for each 
AFX_HIDP_xxx value.    For example, AFX_HIDP_INVALID_FILENAME is the help topic for the 
Invalid Filename message box. >>





Print command (File menu)

Use this command to print a document.      This command presents a Print dialog box, where 
you may specify the range of pages to be printed, the number of copies, the destination 
printer, and other printer setup options.

Shortcuts

Toolbar:
Keys: CTRL+P



Print dialog box

The following options allow you to specify how the document should be printed:
Printer

This is the active printer and printer connection.    Choose the Setup option to change the
printer and printer connection.

Setup
Displays a Print Setup dialog box, so    you can select a printer and printer connection.

Print Range
Specify the pages you want to print:
All Prints the entire document.
Selectio
n

Prints the currently selected text.

Pages Prints the range of pages you specify in the From and To boxes.
Copies

Specify the number of copies you want to print for the above page range.
Collate Copies

Prints copies in page number order, instead of separated multiple copies of each page.
Print Quality

Select the quality of the printing.    Generally, lower quality printing takes less time to 
produce.



Print Progress Dialog

The Printing dialog box is shown during the time that <<YourApp>> is sending output to the
printer.    The page number indicates the progress of the printing.

To abort printing, choose Cancel.



Print Preview command (File menu)

Use this command to display the active document as it would appear when printed.    When 
you choose this command, the main window will be replaced with a print preview window in 
which one or two pages will be displayed in their printed format.    The print preview toolbar 
offers you options to view either one or two pages at a time; move back and forth through 
the document; zoom in and out of pages; and initiate a print job.



Print Preview toolbar

The print preview toolbar offers you the following options:
Print

Bring up the print dialog box, to start a print job.
Next Page

Preview the next printed page.
Prev Page

Preview the previous printed page.
One Page / Two Page

Preview one or two printed pages at a time.
Zoom In

Take a closer look at the printed page.
Zoom Out

Take a larger look at the printed page.
Close

Return from print preview to the editing window.



Print Setup command (File menu)

Use this command to select a printer and a printer connection.    This command presents a 
Print Setup dialog box, where you specify the printer and its connection.



Print Setup dialog box

The following options allow you to select the destination printer and its connection.
Printer

Select the printer you want to use.    Choose the Default Printer; or choose the Specific 
Printer option and select one of the current installed printers shown in the box.    You 
install printers and configure ports using the Windows Control Panel. 

Orientation
Choose Portrait or Landscape.

Paper Size
Select the size of paper that the document is to be printed on.

Paper Source
Some printers offer multiple trays for different paper sources.    Specify the tray here.

Options
Displays a dialog box where you can make additional choices about printing, specific to 
the type of printer you have selected.

Network...
Choose this button to connect to a network location, assigning it a new drive letter.



Page Setup command (File menu)

<< Write application-specific help here. >>

    




