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File Menu
For more information on working with maze files, see Working with Maze Files.

New:
This command deletes the current maze design, resizes and rescales the maze based on
the default values in the Options command,    creates a default square that matches the 
maze size, moves the start block to the upper left corner, moves the stop block to the 
lower left corner, and switches the display to the design mode if not already there. The 
shortcut key combination is CTRL + N.

Open:
This command displays a dialog box allowing you to open a maze from a file on disk.    If 
the file is a valid Maze Master file, the program will delete the current    maze design and
load the design in the file.    If the file includes maze data as well as design data, the 
program will shift to the play and solve mode and the maze will be displayed. If there is 
only maze design data, the program will shift to the design mode.      The shortcut key 
combination is CTRL + O.

Save:
This command will save the current border design if you are in the design mode, and it 
will save the current maze data as well if you are in the play and solve mode.    The 
maze will be saved with its current file name.    If the current maze does not yet have a 
name, a dialog box will be displayed allowing you to assign a name.    The shortcut key 
combination is CTRL + S.

Save As:
This command is similar to the Save command, except it will always show the dialog box
allowing a new name to be selected.    The shortcut key combination is    CTRL + A.

Create Bitmap:    (Registered Version ONLY)
This command is only available in the play and solve mode, and will save the currently 
displayed maze into a bitmap file.    A dialog box will always be shown allowing you to 
assign a file name.    The shortcut key combination is CTRL + B.

Print:
This command displays the Print Maze dialog.    See Printing Mazes for a detailed 
description of the Print Maze dialog.      The shortcut key combination is CTRL + P. 

Printer Setup:
This command displays the standard Windows dialog for changing the default printer.

Exit:
This command will cause the program to terminate.    (Be sure to save any mazes before
exiting.)    The shortcut key combination is ALT + F4.



Edit Menu
The Edit menu commands are only available in the design mode.

Cut:
This command is only available if a line is selected.    It deletes the line from the design 
area, but retains its information in a buffer so it can be recalled with the paste 
command.    The shortcut key combination is CTRL + X. 

Copy:
This command is similar to the Cut command, except it    does not delete the selected 
line from the design area.    The shortcut key combination is CTRL + C.

Paste:
This command is only available when a line has been copied or cut.    It will place a copy 
of the line in the paste buffer at the extreme upper left portion of the design area.    
Selecting Paste more than once will place multiple copies of the line on the same spot.    
Be sure you move or delete any multiple copies or you will get a validation error when 
you try to switch to the play and solve mode.    The shortcut key combination is CTRL + 
V.

Delete:
This command is only available when a line is selected.    It will delete the line from the 
design area, but does not retain its information in the paste buffer.    The shortcut key 
combination is DEL.

Delete All:
This command will delete ALL lines on the design area.    You cannot undo this operation 
so be sure you really want to delete all lines before selecting this command.    The 
shortcut key combination is SHIFT + DEL.

Reset:
 This command will delete ALL lines on the design area, and add four border lines to 
define a simple square with maximum height and width.    It will also move the start 
block to the upper left corner, and the stop block to the lower right corner.    The 
shortcut key combination is CTRL + R.

Size:
This command will display the size dialog box.    You can change the size of the maze to 
any value from 10 to 100 in both the horizontal and vertical directions.    If the new size 
is larger than before, there is no effect on currently drawn lines.    If the new size is 
smaller, any lines that are completely outside the new maze size will be deleted, and 
any lines that partially extend into the new size will be truncated at the edge of the new
size.    There is no undo, so be sure you really want to change the size before you    make
it smaller.    The shortcut key combination is F8.

Flip Line:
This command will flip the selected line about the horizontal axis (which for a single line 
is the same as flipping about the vertical axis).    The shortcut key combination is CTRL +
F.



Maze Menu
Maze menu items allow you to change the way your maze and the maze design area are 
displayed.

Redraw:
This command will generate a new random maze based on the current border design.    
If you are in the design mode, the program will automatically check your design for 
validation errors, and then switch to the play and solve mode.    If you are already in the 
play and solve mode,    the current maze will be deleted and a new maze will be 
generated.    The shortcut key combination is F7.

Scale:
You can select one of five different scale options:

Large:    This displays your maze at 3 blocks per inch.    You will probably have to do
a lot of scrolling to view your maze at this scale, especially if it is large in size.    The
shortcut key combination is SHIFT + F1.

Medium:    This displays your maze at 6 blocks per inch.    The shortcut key 
combination is SHIFT + F2.

Small:    This displays your maze at 12 blocks per inch.    This is the smallest scale 
at which mazes can be easily viewed on the screen.    The shortcut key combination 
is SHIFT + F3.

Fit to Window:    This will adjust the scale of the maze or design area so that it 
fully fills up the program window based on the window's current size, within the 
limits of maximum and minimum scale sizes.    The maximum scale size is 3 blocks 
per inch, and the minimum is 12 blocks per inch.    If you subsequently change the 
size of the program window, the scale factor will not change.      The shortcut key 
combination is SHIFT + F4.

AutoScale:    This will adjust the scale of the maze or design area    in the same 
manner as Fit to Window.    However, any subsequent changes in the size of the 
program window will cause the scale to be readjusted each time.    The shortcut key 
combination is SHIFT + F5.

Options:
This command will display the Options dialog box.      The shortcut key combination is    
F6.

Design Mode:
This command toggles between the design mode and play and solve mode.    You can 
also click on the mode indicator to switch between modes.    If you select Redraw from 
the Maze menu while in the design mode, you will automatically be shifted to the play 
and solve mode.    If you load a maze that includes maze data you will automatically be 
shifted to the design mode.    If you load a maze that contains only border design data 
you will automatically be shifted to the design mode.    If you select New from the file 
menu, you will automatically be shifted to the design mode.    The shortcut key 
combination is F5.



Solution Menu
This menu is only available in the play and solve mode.

Show Hint:
This command will show a small portion of the solution to allow you to see if you are 
going in the right direction.    It will show you the solution from the point where the last 
hint ended (or the beginning if no hints have been shown yet) up to the first point where
there are two or more choices for direction.    To see which way to go, you have to show 
another hint.    If you continue to show hints until the entire solution is shown, you will 
hear a sound expressing disappointment for your failure to solve the maze yourself.    
After the entire solution is shown, you will also no longer be able to use the path marker.
The shortcut key combination is F3.

Show Solution:
This command will show the entire solution.    You will also hear the sound and you will 
no longer be able to use the path marker.    The shortcut key combination is F4.



Help Menu
Contents:
Displays the Maze Master Help File Table of Contents

Search for Help on:
Displays a dialog box that allows you to search for help on any topic.

How to Use Help:
Displays the Windows Help on Help topic.

About Maze Master:
Displays the Maze Master version and copyright notice.



Registration
Click here to view the Registration Form

Why should I Register?
Just because this program is distributed as shareware does not give you the right to use this 
software.    You can try Maze Master for 30 days, but after that you must either register your 
copy or discontinue to use it and remove it from your hard drive.    If you do not do either of 
these things, you are breaking the law.    Besides, a lot of effort was put into this program by 
the authors and they certainly have a right to expect fair compensation if their product is 
being used by others.
Registering will also get rid of those annoying startup and exit dialog boxes, allow you to 
export your mazes as bitmap graphics, allow you to save your default option settings, and 
allow the program to run indefinitely.    The unregistered version will not run if it has been on 
your system for more than 60 days.    Registered users will receive free technical support.    
They will also receive free minor upgrades and be eligible for discounts on future major 
upgrades and other program releases.    Upgrades will normally be available on CompuServe 
in the WINSHARE or WINFUN forums.

What do I get for registering?
Registered users will receive the following:

A diskette containing the program files, along with a registered copy of MAZEMSTR.DLL. 
The presence of this file will determine if you are a registered user.    Under NO 
CIRCUMSTANCES shall copies of the registered version of MAZEMSTR.DLL be provided to
any other person, or uploaded to any bulletin board or on-line service or otherwise 
distributed without the express written consent of C & E Software Co.

Free technical support for one year., via e-mail, and regular mail.

Free minor version upgrades, and discounts on major revisions and other programs 
released by C & E Software Co.

Free sample maze designs that you can use or edit.

How do I Register?
It's easy to register!      You can register by filling out the Registration form and mailing it to C
& E Software Co.    Registration costs $15.00 (U.S. funds, only, please).

If you are a member of CompuServe, you can register by using the CompuServe 
registration service.    The registration fee will then be charged to your CompuServe Account. 
Just GO SWREG.    The program ID for Maze Master is 12384.    You will be asked for your 
address and phone number.    Please provide both.    Your account will be charged $17.65, 
which includes the price for the registered version disk and the 18% CompuServe processing
fee.



Printing Mazes
You may wish to have a printed copy of your mazes.    You can easily print any maze 
generated by Maze Master.    You can adjust margins, the horizontal and vertical scaling of 
the printed maze,    whether or not to print colors or the solution, or scale to automatically fit
on one page.

To Print a maze:
Select Print from the File menu.    You will be shown the Print dialog:

(Click on any area for more detailed information.)

The scale of your maze can be adjusted in the horizontal and vertical directions 
independently. You can set the actual width and height of your maze (and the scale will be 
calculated) or enter the scale and the height and width will be calculated.    The scale can be 
any value from 3 blocks per inch (for really large mazes that will probably take up several 
pages) to 18 blocks per inch (to give you really small mazes).    Selecting Fit on One Page (if 
it is available) forces the maze to automatically scale itself to fit on one page.    If the maze 
does fit on one page, you can have it print in the upper left corner, or have it centered on 
the page. 

You can choose to print mazes in color (if your printer supports it).    The color, width and 
style of lines that are set in the Options command will be the ones that the printer uses 
when it prints your maze. You can also choose to print the solution along with the maze.

If you want to change the current printer, select the Print Setup button.    This calls the 
standard Windows dialog for changing the default printer.      You can adjust the margins if 
desired.

When you have set all options to the desired values, select the Print button to commence 
printing.

If you change your mind, and want to cancel, press Cancel at any time to close the dialog 
box. 





Playing    and Solving Mazes
After you have designed your maze by defining its borders, you can generate a random 
maze based on your border, and display it.    You can change the scale either in the design 
mode, or after the maze has been generated.    Use the scroll bars if the maze is too large to 
fit in the window, or resize the window.    Try to solve the maze by moving from the start 
block to the end block.    For each maze, there is one and only one possible solution.    If you 
want to leave a trail to help you keep track of your progress, you can leave a path marker.    
If you want help solving the maze, you can get a hint, which will show a small portion of the 
solution, or show the entire solution if you give up.

In the play and solve mode, the program window will look something like this:

The maze is displayed in the colors set in the Options command on the Maze menu.    If the 
maze is too large for the program window, scroll bars will be visible to the right and bottom 
of the maze.    The mode indicator in the upper left corner shows the icon for play and solve 
mode.

To Play and Solve Mazes:  
First switch out of the design mode by clearing the check box on the Design Mode command 
on the Maze menu, or by clicking on the mode indicator.    Depending on the size and 
complexity of your maze borders, it may take a few seconds to generate and display your 
maze.    If your design has no validation errors, it will be displayed, otherwise a dialog box 
will pop up that explains the problem, and offer you a chance to return to the design mode, 
or continue with a plain square maze.

To enable or disable the path marker:
If you want to solve the maze yourself, click once on the maze to enable the path marker.    
Click again on the maze to disable it.    When the path marker is enabled, use your mouse to 
trace out your path on the maze.    If you make it to the end, you will be rewarded with a 



sound of congratulations.

To show hints or the entire solution:
If you want help solving the maze, select Show Hints from the Solution menu.    This will 
show a small portion of the correct path, and let you see if you are on the right path.    If you 
give up, or just want to see the solution without solving the maze yourself, select Show 
Solution from the Solution menu.    The entire solution will be displayed.    If you use Show 
Solution, or if you use Show Hints enough times so that the end is reached, you will hear a 
sound of disappointment for failing to solve the maze yourself.    Once the entire solution is 
shown, the path marker will be disabled until a new maze is generated.

To generate a new maze:
Select Redraw maze from the Maze menu.    Another random maze based on this border 
design will be constructed and displayed.

]To change the scale of the maze:
The scale of the maze refers to the actual size of the blocks that make up your maze.    Large
scale means the blocks are large, and small scale means the blocks are small.    You can 
adjust the scale to    one of three standard values, Small, Medium, and Large by choosing 
them from the Scale command on the Maze menu.    You can also select two automatic 
scaling options- Fit to Window and AutoScale.    Fit to Window will adjust the scale of the 
maze so it fills up the program window based on the window's current size.    However, any 
changes in window size    after selecting Fit to Window won't affect the scale; it will stay the 
same. AutoScale is similar to Fit to Window, except    the maze will continuously update to fill
the program window with any and all changes to the program window's size.



Designing Mazes
Maze Master is different from all other maze programs in that you have the ability to design 
your own custom borders; you are not limited to squares and rectangles.

Designing your own borders is as simple as drawing an outline of the shape in which you 
want your maze to be drawn.    There are some restrictions, however ,as to how the lines you
use to define your borders can be arranged.    Basically, you must draw completely 
connected loops, with one loop defining the outside border of your maze, and any number of
smaller loops defining inside borders.    See Validation Errors for a more detailed discussion 
on what arrangements of lines are allowed and disallowed.

In the design mode, the program looks like this:

The main area of the program window is the design area.    The design area includes a grid 
pattern to aid in placement while you are adding or editing lines.    To the left and top of the 
design area are rulers that also act as aids in placing lines.    They also help visualize the 
overall size of your maze.    If the design window is larger than the program window, scroll 
bars will be visible to the right and bottom of the design area.    The small icon in the upper 
left corner of the design area is the mode indicator.    Border lines are indicated by solid black
lines, and the currently selected line appears green with two black squares called handles at 
either end.

 To design your own maze border:
First shift to the design mode by selecting Design Mode in the Maze menu, or by clicking on 
the mode indicator.    The current maze design will be indicated by black lines.    A small 
green square indicates the starting position for when you want to solve your maze, and a 
small red square marks the ending position.    You can select lines that are already drawn 
when you are in the Edit Line mode.    The mouse cursor will be a normal pointing arrow.    Or 
you can add lines when you are in the Add Line mode.    The cursor will be a cross hair.    Use 
the Edit Line/Add Line toggle command on the Edit menu or right click on the design area to 
change between modes.



To draw a new line:
Position the cross hair near the grid point where you want to start the line.    Drag with the 
left mouse button (press and hold the left mouse button while you move the mouse).    A 
green line will extend from the starting point to the current mouse position. When the line is 
positioned where you want it, release the left mouse button.

To edit already existing lines:
Click on a black line to select it.    The line will now be displayed in green with two black 
squares marking start and end points.
You can move the line by dragging it (press and hold the left mouse button while you move 
the mouse).    The black squares will disappear, and the green highlighted line will follow the 
mouse pointer across the screen.    Let up on the left mouse button when the line is in the 
position you desire.
You can move either end point by dragging the black square; the cursor will switch to a cross
hair, and allow you to move the endpoint just like you were drawing a new line.    Click once 
with the left mouse button when the endpoint is where you would like it.
You can cut, copy or delete the line by selecting the appropriate menu command, or using a 
shortcut key.    You can also flip the line.

To paste a cut or copied line:
If you cut or copy a line, you can paste it on the design area, and then move it to a new 
location.    Select Paste from the Edit menu.    The newly pasted line will be positioned at the 
extreme upper left corner of the design area.    If you select Paste more than once, you will 
get multiple copies of the line at the same position.    Be sure to move these lines before 
trying to draw a maze, as they may cause a validation error.

To delete all lines:
Select Delete All Lines from the Edit menu to remove all lines, including the default square 
lines from the design area.    If you select Delete All Lines, there is no undo or paste 
command available, so be sure you want all lines deleted.

To reset the design to a square:
Select Reset from the Edit menu to reset the current design to a square with maximum 
height and width.    This will also return the starting block to the upper left corner, and the 
ending block to the lower right corner.    All lines except the four edges will be deleted.    
There is no undo or paste available if you select this command, so be sure you don't want 
the current design before you reset.

To change the size of the maze:
Select Size... from the Edit menu if you want to make the maze design area larger or smaller.
You will be shown the size dialog box:

You can make the maze as wide as 100 squares, or as narrow as 10.    The height of the maze
has the same limitations.    Make any changes you want to the maze size, then select OK.      
If you change your mind, select Cancel.



After you make a change is size, your current design is affected as follows:    If the new size 
is larger, then no changes are made to any lines currently on the design area. If the new size
is smaller,    all lines that are completely outside the new size are deleted, and lines that are 
partially in the new size are truncated to the lower or right edge as appropriate.    If lines are 
deleted or modified due to resizing the design area, there is no undo.

To change the scale of the design area:
The scale of the design area refers to the actual size of the blocks that make up your maze.   
Large scale means the blocks are large, and small scale means the blocks are small.    You 
can adjust the scale to    one of three standard values, Small, Medium, and Large by choosing
them from the Scale command on the Maze menu.    You can also select two automatic 
scaling options- Fit to Window and AutoScale.    Fit to Window will adjust the scale of the 
design area so it fills up the program window based on the window's current size.    However,
any changes in window size    after selecting Fit to Window won't affect the scale; it will stay 
the same. AutoScale is similar to Fit to Window, except    the design area will continuously 
update to fill the program window with any and all changes to the program window's size.



Menu Commands
Choose the menu item for which you need more information:

File
Edit
Maze
Solution
Help



Introduction
Maze Master is    program that allows you to construct, display and print randomly generated
mazes up to 100 squares by 100 squares.    You can solve the mazes on the screen, get hints 
on the solution, or show the entire solution.    You can print mazes in color, and include the 
solution if you want.

But Maze Master doesn't stop there!    Squares can get real boring real fast!    Maze Master 
allows you to custom design the border that defines your maze.    Now you can make 
virtually any shape into a maze.    Your only limitation is your imagination!

Maze Master has a very user friendly interface.    To generate new mazes based on the 
current border, just choose Redraw from the Maze menu.

You can try to solve the maze yourself by clicking on the maze display to activate the path 
marker.    Click again to deactivate the path marker.    Change the display scale of the maze 
to make the squares large or small.

If you want some help, try showing a hint.    Or if you give up, show the solution.

Switch to the design mode to draw your own border shapes.    You can add lines, edit lines 
and move lines with commands similar to most line draw programs.

Save your designs and mazes so you can use them again later, and print out your designs 
(including solutions if you want).      You can adjust the scale when you print to enlarge or 
shrink the maze to nearly any size you want.    If your maze is too large for one page, just cut
and paste the printed pages along the guide lines to form jumbo mazes.    You can also 
export your mazes as a standard bitmap graphic which you can import into other programs. 
(Registered version ONLY) 

For more detailed information on program operation, see

Designing Mazes
Playing and Solving Mazes
Printing Mazes.

 Working with Maze Files

For more detailed information on menu commands, see Menu Commands.

Maze Master is distributed as shareware.    You are granted a 30 day trial period to evaluate 
this program.    If you find it useful, you are required to register your copy for further use.    
See Registration.



Technical Support
Whether or not you are registered, we are very interested in your feedback.    Please send us 
your comments and suggestions.

Support for Registered Licensees:
If you have registered your copy of Maze Master, you will be entitled to free technical 
support for one year.      You can reach C & E Software Co.    as follows:

Mailing address:
C & E Software Co.
8210 University Point Cr.
Bremerton, WA 98311-9420

Phone:    (360)-613-5448      (9:00AM - 3:00 PM,    MON through FRI, Pacific Coast 
Time)

CompuServe e-mail address:    73363,2052

Internet e-mail address:    73363.2052@compuserve.com

If you have a problem, or encounter what you think is a bug, please contact us, and we will 
get the situation resolved as quickly as possible.



MAZEMSTR.INI
(Registered version ONLY)

If your copy of Maze Master is registered, you will have the ability to save your options in an 
initialization file.    Changes you select in the Options dialog box will automatically be saved 
in this file, along with the program window's last size and position.

You can edit this file using a standard text file if you desire.    The entries allowed in each 
section of MAZEMSTR.INI are as follows:

[ProgramOptions]
This section contains the values for the initial position of the program window.    Enter 
values using the units of measure that Windows uses to measure the overall size of your 
screen (usually twips, which are 1/1440 of an inch in size).    For program state, enter 0 
for normal, and 2 for maximized.

[Recent Files]
This section contains values representing the directories and names of the four most 
recent files used by the program. RecentFile# values should be a directory and filename 
pointing to a valid MZM file.

[MazeParameters]
This section contains the default values for maze height and width, resolution, and startup
mode.    
MazeWidth and MazeHeight values must be whole numbers, not less than 10 and not 
greater than 100.    
Resolution must be a whole number selected from the following table:

0 Large scale
1 Medium scale
2 Small scale
4 Fit to Window    mode
5 AutoScale mode

StartMode must be 0 to force design mode on startup, and -1 to force play and solve 
mode on startup.

[LineDefaults]
This section contains the default colors and line styles    for maze walls, the solution, the 
path marker and the    maze background color.
Color values must be one of the numbers from the following table:

0 Black
1 Dark Blue
2 Dark Green
3 Dark Cyan
4 Gray
5 Blue
6 Green
7 Cyan
8 Dark Red
9 Dark Purple
10 Dark Yellow
11 Dark Gray



12 Red
13 Purple
14 Yellow
15 White

Style values must be one of the numbers from the following table:
0 Dotted Line
1 Dashed Line
2 Thin Solid Line
3 Medium Solid Line
4 Thick Solid Line

[Sounds]
Enabled should be a 0 to disable sounds, and -1 to enable sounds.
Sound# values should be a directory and filename pointing to a valid WAV file

[PrintOptions]
Margins can be any number between 0 and 2. 
PrintBW should be -1 to print black and white mazes, and 0 to print color mazes.
PrintSoln should be -1 to print solutions with mazes and 0 to not print solutions. 



Working with Maze Files
File handling procedures in Maze Master are similar to most other windows programs.    You 
can save files with the same name or different names, load files, or start a new file.    You can
also copy the maze image you created into a standard Windows bitmap file.    This allows you
to import the maze into other programs such as word processors and layout designers where
you can add text and other graphics to your maze designs.

To start a new maze based on default values:
To start a new maze, select New from the File menu.    This will delete any currently stored 
maze from memory      and change the maze size and scale back to the values listed in the 
Options dialog box.    A default square will be loaded, and the display will shift to the design 
mode.

To save a maze or maze design:
 Selecting Save from the File menu will save the current maze and maze design to disk.    If 
the maze already has a filename, it will automatically be saved with the same name, erasing
the previous version.    If the maze does not have a name, you will be prompted for a name.   
You can select Save As to save a maze with a different name than the one it currently has.     
Note that if you are in the design mode when you save a maze, only the maze design will be 
saved.    If you are in the play and solve mode, the individual maze data, including your 
progress with the path marker,    will be saved along with the maze design.

To load    a maze or maze design:
Selecting Open from the File menu will open a dialog box asking for the name of the maze 
file to open.    If the maze file contains only design data, you will automatically be shifted to 
the design mode.      If the file contains a maze as well,    you will be shifted to the play and 
solve mode and the maze will be displayed.

To create a bitmap file: (Registered version ONLY)
Select Create Bitmap from the File menu.    When prompted, select a name for the bitmap 
file.    This option is only available in the play and solve mode.



Mode Indicator:
The small square in the upper left corner of the main window.    It shows     if in the play 
mode, and    

    if in the design mode.



Short Cut Keys
The following shortcut key combinations are available:

Working with files:
Starting a new file: CTRL + N
Opening a file: CTRL + O
Saving a file: CTRL + S
Saving a file with a new name: CTRL + A
Saving a maze as a Bitmap file: CTRL + B    (Registered version ONLY)
Printing a maze: CTRL + P
Exiting Maze Master: ALT + F4

Editing maze designs:
Cutting a line: CTRL + X
Copying a line: CTRL + C
Pasting a line: CTRL + V
Deleting a line: DEL
Deleting ALL lines SHIFT + DEL
Resetting maze: CTRL + R
Changing maze size: F8
Flipping a line: CTRL + F

Modifying the display:
Changing to/from design mode: F5
Displaying maze Options dialog: F6
Redrawing a new maze: F7
Display maze in Large scale: SHIFT + F1
Display maze in Medium scale: SHIFT + F2
Display maze in Small scale: SHIFT + F3
Display maze in Fit to Window Scale: SHIFT + F4
Display maze in AutoScale: SHIFT + F5

Playing and Solving mazes:
Enable/Disable path marker: SPACEBAR
Show a hint: F3
Show entire solution: F4

Context sensitive Help: F1



Validation Errors
Whenever Maze Master builds a new random maze, it will first validate the border design 
that you specified.

If a problem with the border is encountered,    a dialog box will be shown that explains the 
error, and you will be given a    chance to continue without a custom maze border, or return 
to the design mode and correct your border design.

The error messages that can be generated    and an explanation of how to correct them are 
as follows:

"Must have at least three connected lines."
 It is impossible to define an enclosed area with less than three lines.    You need to have at 
least three lines (which would form a triangle) to define a custom border.    Solution:    Add 
enough lines to at least form a triangle.

"Lines cannot cross each other."
 Border lines cannot cross over each other.    A valid set of lines will define a separate 
enclosed area, and crossed over lines would not define an separate enclosed area. You will 
also get this error if lines lie on top of each other.    If you choose to return to the design 
mode, the lines in question will be highlighted in red.    Solution:    Delete or edit any lines 
that cross over each other or that lie on top of each other.

"Lines must be connected end to end." 
A valid set of lines must define an enclosed space.    This means your lines need to be 
connected end to end to form a complete and closed loop. If you don't draw complete loops, 
or have any extra lines that are not attached to anything, you will get this error.    If you 
choose to return to the design mode, the line in question will be highlighted in red.    
Solution: Edit or delete lines so that they all meet end to end, and there are no stray lines.

 "Only two lines can meet at one point."
To define a valid arrangement of lines, you can only have two lines meeting at a single point.
Three or more lines meeting at a single point can form complex arrangements that could 
result in several different interpretations as to what is an enclosed area.    Solution:    Edit or 
delete lines so only two lines meet at one point..

"Invalid arrangement of borders."
If you are defining outside and inside borders, you need to ensure that there is only one 
outside border that includes all inside borders.    Also, none of the inside borders can be 
inside each other.    Solution:    Edit or delete lines so there is only one outside border 
surrounding all your inside borders, and that your inside borders do not surround each other.

The way that Maze Master tests to see if one group surrounds another is by the maximum 
and minimum values in both the horizontal    and vertical direction for each group of lines.    
Here are some samples to explain how borders can and can't be arranged:



This example shows a valid arrangement of borders.    The large square surrounding the 
other shapes is the outside maze border.    The max and min values (the blue lines) for the 
two triangles and the smaller square are all inside the large square.    None of two triangles 
or small square have max and min values that are completely inside each other.      Notice 
that some of the max and min values of the inside borders overlap; this is okay as long as 
one inside border shape is not completely inside another.

This example shows an invalid arrangement.    The large shape surrounds all the other 
shapes so it is the outside border.    The smaller triangle that is inside the larger square is not
allowed, because its max and min values (the blue lines) are completely inside the square.    
If the smaller triangle were moved outside of the square it would be valid.



 
This example also shows an invalid arrangement.    It looks like it should be okay- the 
large penant like shape defines the outside border, and the two other shapes are inside 
borders.    The small triangle is not inside the diamond-like shape, so it should be okay, 
but because Maze Master tests to see if one group surrounds the others by their max and
min values, the smaller triangle is invalid.    Its max and min values (the blue lines) are 
completely inside the diamond-like shape's max and min values.    Moving the small 
triangle so it is not completely inside the max and min values (overlapping is okay) of the
diamond shape would make this a valid arrangement.

"There is a problem with this border; maze cannot be built."
Sometimes, a complex maze may appear to have a valid border, but no maze can be 
constructed.    If Maze Master encounters difficulty while trying to build a maze, it will return 
you to the design mode.    In this case, you will need to    examine your design to ensure you 
don't have any areas that are blocked off by narrow corridors from the main areas of your 
maze.



Page Layout:
This section gives a graphical view of how your maze size compares to the printed page size.
The number of pages it will take to print your maze is shown underneath the layout view.    
The gray area indicates the overall width and height of your maze, and the blue dotted lines 
indicate the size of the printable area on each page.



Print Options:
You can choose from the following options:

Print colors as Black and White:    If your printer supports colors, you have the 
choice of printing your maze in the same colors as they are displayed, or as black lines 
on a white background. This check box will be disabled if your printer does not support 
color.

Print Solution:    If selected, this will cause the program to print the solution to the 
maze along with the maze itself.    

Scale to Fit Page:    If selected, the scale will be adjusted to cause the maze to fit 
exactly on one printed page.    Height and width will be scaled equally.    If the maze 
cannot fit on one page, even at the smallest scale,    this check box will be disabled.

Center Maze on page:    If the maze is small enough to fit on one page, it will be 
printed in the upper left corner of the page, unless this option is selected.    This option 
forces the maze to be centered on the page both horizontally and vertically.    If the 
maze is larger than one page, this check box will be disabled.



Maze Size and Scaling:
Use these sections to adjust the size and scale of your printed maze.    You can enter the 
maze width or height directly (in inches) and the scale will automatically be calculated, or 
enter a scale, and the size will automatically be calculated.    You cannot select a scale 
smaller than 3 blocks per inch or larger than 18 blocks per inch.    The program will limit 
maze height and width entries to keep the scale value within limits.



Margins:
Enter the margins you want for the top, bottom, left and right sides of the printed page.    
Entries will automatically be corrected so they fall in between the printer's minimum values 
and two inches.    Changing the default printer will automatically adjust margins to the new 
printer's minimums if necessary.



Program Options
There are several parameters affecting the display and designing of mazes that you can 
control.    The Options command in the Maze menu includes most of these parameters.    
When you select the Options command, you will be shown the Options dialog:

(Click on any area for more detailed information.)

You can change the colors and styles by clicking on the appropriate boxes.

You can change the startup options by editing the appropriate items.

Changes in colors, styles and Sound Enabling    will be immediate after you select Save 
Options.    Default    maze height and width, default scale and startup mode will only have an 
effect the next time you select New from the File menu.

(Registered Version ONLY):    All changes to these options are stored in a file called 
MAZEMSTR.INI in your program directory, and will be effective the next time you start the 
program.



Colors and Styles

You can change the colors and styles for the lines that the program uses to draw the maze 
walls, the solution, and the path marker.    You can also change the background color on 
which the maze is drawn.

To change the color of a line:
Double click on the color box for the line you want to change (or use the TAB key to 
move to the color box and press SPACEBAR).    Double click on the color that you 
want( or use the cursor keys to highlight the color you want and press ENTER).

To change the style of a line:
Double click on the style box for the line you want to change (or use the TAB key to 
move to the style box and press SPACEBAR).    Double click on the style that you 
want( or use the cursor keys to highlight the style you want and press ENTER).



Startup Options

The following options can be changed:

Default Maze size:
Enter the values here that you want the program to use when you first load the program,
or select New from the File menu.

Startup Mode:    
If you want Maze Master to be in the design mode when you first load the program or 
select New from the File menu, select Design; if you want to have a maze generated 
immediately, select Play and Solve

Default Scale:
Select the scale mode that you want the program to be in when you first load the 
program, or select New from the File menu.

Enable Sounds:
Clear the check box if you want sounds disabled.



Click here to print this form now!

Registration Form
Complete and Mail to :

C & E Software Co.
8210 University Pt Cr.
Bremerton, WA 98311-9420

Ship To:

Name: ________________________________________________________

Address: _______________________________________________________

City:__________________________________ST:_______ZIP:___________

Phone:       ( ________ ) ___________________________

[        ]    Send me a single user license to register my copy of Maze Master for $15.00:

[        ]    Enclosed is a check or money order made payable to C & E Software Co.
[        ]    Charge my        Mastercard      /      VISA        (circle one) account:

Account No:___________________________________Exp Date:___________

Name    as it appears on Card _________________________________________
(if different from Ship To name):
Signature:________________________________________________________
(Required for credit card orders)

[        ]  Washington State Residents include 8.1% sales tax.      (additional $1.22)
[        ]    For shipment to country other than US or Canada, include $3.00 shipping fee

[        ]    Please send me information about multi user licenses (discounts apply)

Total Amount of check, or amount charged:_____________________



Legal Remarks
By using this program, you are accepting the following terms regardless of local law:

This software and documentation are provided 'as is' without warranty as to their 
performance, merchantablility or fitness for any particular purpose.    In no event shall the 
author or anyone else who has been involved in the creation, production or delivery of this 
software and documentation be liable for any direct, incidental or consequential damages, 
including, but not limited to, loss of anticipated profits, benefits, use, or data loss resulting 
from the use of this software and documentation, or arising out of any breach of any 
warranty.

Using an unregistered version of this software for more than 30 days is prohibited.

With a single user license, you may install copies of this product on all machines that the 
licensee personally uses, as long as only ONE person (including the licensee) is using the 
installed copies of the software at a given time.    Multiple users requires a multi-user license.
Contact C & E Software Co. for information on multi-user licenses.

Copies of the UNREGISTERED version of Maze Master may be freely distributed to other 
persons, or uploaded to bulletin boards and on-line services as long as it includes all files 
listed in FILELIST.TXT, and the files are NOT MODIFIED in any way.    Under NO 
CIRCUMSTANCES shall copies of the registered version of MAZEMSTR.DLL be provided to any 
other person, or uploaded to any bulletin board or on-line service or otherwise distributed 
without the express written consent of C & E Software Co.

Maze Master and this Maze Master Help file are copyrighted ©1996 by C & E Software Co.    
All rights reserved.






