
WinLock Help Index
The Index lists Help topics available for WinLock. Use the scroll bar to see entries not currently visible in 
the Help window.

To learn how to use Help, press F1 or choose Using Help from the Help menu.
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Overview
WinLock protects your Microsoft Windows and LAN environment from unauthorized users. 
The easy to use security features locks Windows at start up, on demand, and automatically 
when your away from your desk. When locked all mouse and keyboard activity is restricted. 
Intruders are met with a flashing red screen, an audible alarm, and deterrent messages. The 
security audit trail provides you with a record of unauthorized password attempts. Your 
Windows environment remains secure even when your PC is rebooted from floppy. Since, 
WinLock is compatible with most commercially available screen savers you can enable your 
favorite screen saver without locking your system. WinLock provides an additional level of 
security to any Novell, LAN Manager, or Banyan network. 



How to register Winlock 
                
If you like WinLock and you use it on your PC, please fill out the online order form and send it
to:
                TeraVision, Inc.
                785 Virginia Avenue              
                Campbell CA 95008                  
                Phone: 408-378-9328
                FAX:      408-378-9374

We will send you a codeword and License-To-Use authorizing you to continue using WinLock. 
We can also inform you of new versions and enhancements.                  
 



Starting WinLock           
Activating WINLOCK.EXE will start the program.    When starting WINLOCK.EXE, the WinLock 
program will automatically create a WINLOCK directory on your C: drive and the correct files 
will be loaded into it. 

WinLock will also add "C:\WINLOCK\WINLOCK.EXE" to the "run=" command in your WIN.INI 
file.    This allows WinLock to automatically start up every time you start Windows 3.0, to give
you maximum security.                  
                  
When WinLock is first executed, you will be prompted for your first password. Type (and 
retype) your password.    DO NOT FORGET YOU PASSWORD, WRITE IT DOWN AND KEEP IT IN 
A SAFE PLACE.    If you lose or forget your password, you must remove WinLock from your 
system and reinstall.    
      
WinLock must be running in order for the screen to lock.    You can tell it is running by the 
WinLock "safe" icon at the bottom of the screen.                  
                              



Entering Your First Password

- Point the mouse on PASSWORD field                  
- Single click                  
- Type in password                  
- Press TAB key                  
- Retype password in RETYPE PASSWORD field                  
- Click on OK                  
- Do not forget password; write it down                  



Setting Timer                
                  
- Point and click on the WinLock icon.
- Point and click on menu item "Control Panel..." 
- Type in your password, then press the OK button
- The WinLock Control dialog box will appear
- Click on down-arrow in TIMER field                  
- Select number of minutes before locking                  
 



 Changing Your Password         
                  
- Point and click on the WinLock icon.
- Point and click on menu item "Control Panel..." 
- Type in your password, then press the OK button
- The WinLock Control dialog box will appear
- Press the Password button
- Point the mouse on OLDPASSWORD field                  
- Single click                  
- Type in old password                  
- Press TAB key                  
- Type in new password in NEWPASSWORD field                  
- Press TAB key                  
- Retype new password in RETYPE PASSWORD field                  
- Click OK                  
- Do not forget new password                  
                  



Lock Screen Now                

- Point and click on the WinLock icon.
- Point and click on menu item "Lock..."
or 
- Point and click on the WinLock icon.
- Press the right button on your mouse.
              



If You Forget Your Password            
                  
- Turn off your PC                  
- Turn on PC                  
- Before your PC loads windows, press Ctrl-C (or you can just reboot your PC from a floppy 
instead of the above three steps).                  
-    At the DOS prompt, type "DEL C:\WINLOCK\*.*" [ENTER]                
-    Restart Windows, type "WIN" [ENTER]                  
-    Windows will try to start WinLock, but will give an error message instead.                  
- Now you must re-install WinLock                  
                  



Deleting WinLock From Your System
                      
- Click once on WinLock "safe" icon                  
- Select "CLOSE"                  
- Execute editor                  
- Bring up the WIN.INI file                  
- Edit the file by deleting the    "C:\WINLOCK\WINLOCK.EXE" from the run=      command line. 
NOTE: do not remove "run=".                  
- Delete all files under the C:\WINLOCK directory                  
- Delete the C:\WINLOCK directory                  



Disclaimer                
LIMITED LIABILITY - IN NO EVENT WILL TERAVISION, INC.    BE LIABLE TO YOU FOR ANY 
DAMAGES, INCLUDING ANY    LOST PROFITS, LOST SAVINGS OR OTHER    INCIDENTAL OR 
CONSEQUENTIAL DAMAGES EVEN IF    TERAVISION, INC. OR ANY TERAVISION, INC. 
REPRESENTATIVE HAS BEEN ADVISED OF THE POSSIBILITY OF    SUCH DAMAGES, OR FOR ANY
CLAIM BY ANY OTHER PARTY.                  



File Menu

The File menu includes commands that enable you to open and save files, establish a new 
workspace, and to print.
For more information, select the File menu command name.

Exit
New
Open
Print
Save
Save As



GlosXsary

clipboard



Copying Text

This topic explains how to copy text to and from the clipboard.    (This topic is associated with
the keywords "copy" and "clipboard.")



Deleting Text

This topic explains how to delete text.    (This topic is associated with the keywords "delete" 
and "clipboard.")



Exiting

This topic explains how to exit HelpEx.



Edit Clear Command

This topic explains the Edit menu's Clear command.



Edit Copy Command

This topic explains the Edit menu's Copy command.



Edit Cut Command

This topic explains the Edit menu's Cut command.



Edit Paste Command

This topic explains the Edit menu's Paste command.



Edit Undo Command

This topic explains the Edit menu's Undo command.



File Exit Command

This topic explains the File menu's Exit command.



File New Command

This topic explains the File menu's New command.



File Open Command

This topic explains the File menu's Open command.



File Print Command

This topic explains the File menu's Print command.



File Save Command

This topic explains the File menu's Save command.



File Save As Command

This topic explains the File menu's Save As command.



Context Sensitive Topics

This Help system includes topics that you can call directly from the Helpex sample 
application. To get context-sensitive help from Helpex, press Shift+F1 and click on any 
element of the Helpex application window. You can also highlight any Helpex menu 
command using the keyboard and press F1 to get help on the command. Each topic has a 
unique context identifier, listed in the [MAP] section of the Help project file:

[MAP]
#define HELPID_EDIT_CLEAR     100
#define HELPID_EDIT_COPY      101
#define HELPID_EDIT_CUT       102
#define HELPID_EDIT_PASTE     103
#define HELPID_EDIT_UNDO      104
#define HELPID_FILE_EXIT      200
#define HELPID_FILE_NEW       201
#define HELPID_FILE_OPEN      202
#define HELPID_FILE_PRINT     203
#define HELPID_FILE_SAVE      204
#define HELPID_FILE_SAVE_AS   205
#define HELPID_EDIT_WINDOW    300
#define HELPID_MAXIMIZE_ICON  301
#define HELPID_MINIMIZE_ICON  302
#define HELPID_SYSTEM_MENU    305
#define HELPID_TITLE_BAR      306
#define HELPID_SIZING_BORDER  307



Edit Window

The edit window in the sample application really doesn't let you edit anything.



Maximize Icon

This topic describes the maximize icon.



Minimize Icon

This topic describes the minimize icon.



Sizing Border

This topic describes the sizing border that surrounds the application window.



System Menu

This topic describes the system menu.



Title Bar

This topic describes the title bar that is used for application and document windows.



Bitmaps by Reference

A bitmap can be placed in a sentence , just like any character. Click on the maximize 
button bitmap to open a pop-up box with more information.

You can also put bitmaps at the left margin of the Help window. Text will automatically wrap 
along the right edge of the bitmap.

Or the bitmap can be at the right window margin, and text will automatically wrap along its 
left edge.



The coding for this bitmap is:
text... text...

Note: You cannot code bml or bmr bitmaps 
as hotspots in this version of Help.



Visually Placed Bitmap

The Microsoft logo shown here was pasted from Clipboard into the Help topic file using Word 
for Windows.

Try clicking on the logo.



The Microsoft logo is a registered trademark of Microsoft Corporation.



Windows System Fonts

This is Courier 10 point.

This is Helv 10 point. 

This is Modern 12 point.

This is Roman 12 point.
This is TMS RMN 12 point.



Note: Although they are available in Windows, 
the Script and Symbol fonts do not display 
with this version of Help shipped with the 3.0 SDK.

This is Script 12 point.
This is Symbol 12 point (Symbol font).



Vowels and Consonants

Find the vowels and consonants in the word below by clicking on them one at a time.

Microsoft



The letter M is a consonant.



Yes, the letter i is a vowel.



No, the letter c is not a vowel.



R is a consonant.



This letter o is one of two in the word Microsoft.



The letter s is between two vowels in this word.



This o is the second one in Microsoft. Did you find the other one?



No, f is not a vowel.



The trailing t in Microsoft is a consonant.



Tutorial Lesson

There are three things to remember about your life vest:



Tutorial Lesson

There are three things to remember about your life vest:

Where it is.



Tutorial Lesson

There are three things to remember about your life vest:

Where it is.
How to put it on.



Tutorial Lesson

There are three things to remember about your life vest:

Where it is.
How to put it on.
How to inflate it.



Help can be authored with interactive instructional segments:



Congratulations!

You have found a topic that has no context-string identifier. It is accessible from a browse 
sequence only.

Can you think of a reason to author such a topic?



Simulation

Help can be used for simple simulations.

Click the check boxes in any order to change the format of the word WinHelp below:

WinHelp 

          bold
          italic
          underline
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Eureka!

You found a topic that is accessible from a keyword search only. This topic is not linked 
through hypertext in any way.

You can use this technique to access topics without having to index them and author jumps. 
You can also access topics like this directly from your application through the use of multiple 
keyword tables.





Windows Keys

The keyboard topics below come from Help for Windows. You can create similar keyboard 
topics for your application's Help. Choose from the following list to review the keys used in 
Windows:
Cursor Movement Keys
Dialog Box Keys
Editing Keys
Help Keys
Menu Keys
System Keys
Text Selection Keys
Window Keys



Cursor Movement Keys

Key(s) Function

DIRECTION key Moves the cursor left, right, up, or down in a field.
End or Ctrl+Right Arrow Moves to the end of a field.
Home or CTRL+Left Arrow Moves to the beginning of a field.
PAGE UP or PAGE DOWN Moves up or down in a field, one screen at a time.



Dialog Box Keys

Key(s) Function

TAB Moves from field to field (left to right and top to bottom).
SHIFT+TAB Moves from field to field in reverse order.
ALT+letter Moves to the option or group whose underlined letter matches 

the one you type.
DIRECTION key Moves from option to option within a group of options.
ENTER Executes a command button.

Or, chooses the selected item in a list box and executes the 
command.

ESC Closes a dialog box without completing the command. (Same as
Cancel)

ALT+DOWN ARROW Opens a drop-down list box.
ALT+UP or DOWN ARROW Selects item in a drop-down list box.
SPACEBAR Cancels a selection in a list box.

Selects or clears a check box.
CTRL+SLASH Selects all the items in a list box.
CTRL+BACKSLASH Cancels all selections except the current selection.
SHIFT+ DIRECTION key Extends selection in a text box.
SHIFT+ HOME Extends selection to first character in a text box.
SHIFT+ END Extends selection to last character in a text box



Editing Keys

Key(s) Function

Backspace Deletes the character to the left of the cursor.
Or, deletes selected text.

Delete Deletes the character to the right of the cursor.
Or, deletes selected text.



Help Keys

Key(s) Function

F1 Gets Help and displays the Help Index for the application. If the 
Help window is already open, pressing F1 displays the "Using 
Windows Help" topics.
In some Windows applications, pressing F1 displays a Help topic
on the selected command, dialog box option, or system 
message.

SHIFT+F1 Changes the pointer to  so you can get Help on a specific 
command, screen region, or key. You can then choose a 
command, click the screen region, or press a key or key 
combination you want to know more about.

(This feature is not available in all Windows applications.)



Menu Keys

Key(s) Function

Alt Selects the first menu on the menu bar.
Letter key Chooses the menu, or menu item, whose underlined letter 

matches the one you type.
Alt+letter key Pulls down the menu whose underlined letter matches the one 

you type.
LEFT or RIGHT ARROW Moves among menus.
UP or DOWN ARROW Moves among menu items.
Enter Chooses the selected menu item.



System Keys

The following keys can be used from any window, regardless of the application you are 
using.

Key(s) Function

Ctrl+Esc Switches to the Task List.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+PrtSc Copies the entire screen to Clipboard.
Ctrl+F4 Closes the active window.
F1 Gets Help and displays the Help Index for the application. (See 

Help Keys)



Text Selection Keys

Key(s) Function

SHIFT+LEFT or RIGHT ARROW Selects text one character at a time to the left 
or right.

SHIFT+DOWN or UP Selects one line of text up or down.
SHIFT+END Selects text to the end of the line.
SHIFT+HOME Selects text to the beginning of the line.
SHIFT+PAGE DOWN Selects text down one window.

Or, cancels the selection if the next window is 
already selected.

SHIFT+PAGE UP Selects text up one window.
Or, cancels the selection if the previous 
window is already selected.

CTRL+SHIFT+LEFT or RIGHT ARROW Selects text to the next or previous word.
CTRL+SHIFT+UP or DOWN ARROW Selects text to the beginning (UP ARROW) or 

end (DOWN ARROW) of the paragraph.
CTRL+SHIFT+END Selects text to the end of the document.
CTRL+SHIFT+HOME Selects text to the beginning of the document.



Window Keys

Key(s) Function

ALT+SPACEBAR Opens the Control menu for an application window.
ALT+Hyphen Opens the Control menu for a document window.
Alt+F4 Closes a window.
Alt+Esc Switches to the next application window or minimized icon, 

including full-screen programs.
Alt+TAB Switches to the next application window, restoring applications 

that are running as icons.
Alt+ENTER Switches a non-Windows application between running in a 

window and running full screen.
DIRECTION key Moves a window when you have chosen Move from the Control 

menu.
Or, changes the size of a window when you have chosen Size 
from the Control menu.





Clipboard

This is a topic that describes the Windows term "clipboard". If you click the "clipboard" term 
within the Copying Text or Glossary topic, this Help topic will be displayed in a pop-up 
window.

This topic is also tagged with the keyword "clipboard," for use with the WinHelp Search 
option.



 


