Avoiding irrelevant pages

Why do some search engines return irrelevant information?

" Your search is not exclusive enough.
Tip: Search for words that are related to your subject but uncommon.

Tip: Avoid selecting Page Has At Least One Of The Words (unless you are searching for exceptionally uncommon words). Use
the Page Has All Of The Words or Page Contains Exact Phrase options, instead.

" The words you searched for are common in several contexts.
For example, if you search for "windows architecture," most search engines will find pages dealing with the computer
architecture of Windows 95 and pages on the role of windows (the glass kind) in Architectural design.

Tip: Include words in your search that are specific to your subject but not to other subjects.

" Methods used by some search engines are simplistic.
Because the amount of information on the Internet is so vast, many search engines use relatively simple methods for indexing
the contents of Web pages. In many cases, the search engine simply makes a list of all words found in a document and treats
each one as a "keyword," regardless of how "key" it actually is to the subject of the page.

Tip: On the Options tab page, turn off search engines that consistently return irrelevant information.
Tip: Search for words that are related to your subject but uncommon.

Tip: From the WebFind search results page, link directly to any of the search engines and take advantage of their advanced
search capabilities.

" Some Web pages contain "spam.”
Some devious Web authors "hide" words and phrases in their Web pages to trick search engines into finding them.

Tip: Use uncommon search words and select Page Contains Exact Phrase.



Avoiding irrelevant sites

When I click the site at the top of each group, | get pages that have nothing to do with my search.

" The host site is not focused on content.
When you click the site at the top of each group of matching pages, you link to the home page for the host site for all pages in
that group. Since each host site can contain many pages on many different subjects, the home page for the host site may not

pertain directly to your search. This is common when the host site is an Internet Service Provider (ISP) that serves customers
that have widely divergent interests.

Tip: You may find it more convenient to sort the WebFind search results page by page rather than by site.



Configuring WebFind searches
You can configure WebFind to accommodate your search preferences and system performance.

To select Search Engines:

1 Click the Options tab.

2 In the list labeled Use The Following Search Engines,
check the search engines you want to include, and
uncheck the search engines you want to exclude.

To change the number of pages returned from each search engine:
1 Click the Options tab.
2 Enter a new number for Return The Top [__] Matches From Each Search Engine.

To adjust the duration of each search:
1 Click the Options tab.
2 Enter a new number for Search A Maximum Of [__] Seconds.



Deleting previous WebFind search results

WebFind stores the last ten search results pages and the last ten search words or phrases so that you can retrieve them at a later
time if you want. The previous search results pages are available on the File menu, and the previous search words are available in
the Search For drop-down list on the Search tab. To maintain security or privacy, you can delete both lists if you want.

To delete previous search results:

¥ Select Clear History from the File menu.
This will:
" remove the list of previous search results from the File menu,
. remove the list of previous search words from the Search For drop-down list, and

" delete the HTML documents associated with the searches from the Internet FastFind\Results folder.



Faster searches

How can | get results faster?

On the Options tab page, lower the number of matches retrieved from each search engine.
On the Options tab page, uncheck search engines that are slow.

On the Options tab page, reduce the maximum number of seconds allowed for the search.
On the Options tab page, uncheck Discard Invalid Links.

Upgrade to a faster modem.

Upgrade to a faster CPU.



Finding what you want

| can't find what | want but | know it's out there somewhere.
" If you know the exact name (or even part of the name) of the file you are looking for, use NetFileFind instead of WebFind.

. Search for the "root" of a word to find variations on that word.
For example, search for "recycl" to find pages containing "recycling," "recyclable," and "recycle."



Integrating WebFind with Windows

You can integrate WebFind with Windows by adding it to the Tools | Find menu of Explorer and the Start | Find menu of the taskbar.
You can also add a WebFind button to the title bar of your Web browser.

To add WebFind to Windows Find menus:

1 Launch the Internet FastFind console.

2 Click Options.

3 Check WebFind under Additions To The Start Menu Find Command.

To add a WebFind button to your browser:

1 Launch the Internet FastFind console.

2 Click Options.

3 Check WebFind Button under Additions To The Browser.

To remove WebFind from Windows Find menus and your browser:

1 Launch the Internet FastFind console.

2 Click Options.

3 Uncheck WebFind under Additions To The Start Menu Find Command.
4 Uncheck WebFind Button under Additions To The Browser.



Jumping to a search engine site

From the search results page, you can jump to the site of any of the search engines that returned matching links. This can be useful
if you want to use the advanced capabilities of a specific search engine to fine-tune your search.

To jump to a search engine site:
1 Scroll to the top of the search results page in your Web browser.
2 Click the link to the search engine.



Launching WebFind

Launch WebFind in any of the following ways:
On the Windows taskbar:

" Start | Programs | Internet FastFind | WebFind

. Start | Programs | Internet FastFind | Internet FastFind. Click WebFind.

" Start | Find | WebFind (Available only if configured; see note below.)

On the desktop:

" Double-click the Internet FastFind icon. Click WebFind.

In Windows Explorer:

" Select Find from the Tools menu. Select WebFind. (Available only if configured; see note below.)

In your Web browser:

. Click the WebFind button in the title bar of your Web browser. (Available only if configured; see note below.)
Note:

. By default, the Internet FastFind installation adds WebFind to the Find menu and adds a WebFind button to the title bar of

your Web browser. You can change thisconfiguration if you want. Click here
2 for instructions.



Scoring and weighting pages

How does WebFind score or weight the found Web pages?

" If the search engine returns a page score (it usually does), WebFind uses it. (This score is between 0 and 100 and rates
the degree to which the page matches your search criteria.)
" If the search engine does not return a page score, WebFind gives it a score of 100.

" If more than one search engine returns a page, WebFind adds the scores returned from each search engine.



Searching for Web pages

To search for Web pages that contain information you want:

1 Launch WebFind.

2 Click the Search tab.

3 Inthe box labeled Search For, enter one or more words that the Web pages you want must contain.
(Tip: You can reuse previous search words by selecting them from the drop-down list.)

4 Specify how WebFind should treat those words:

Page has all the words
Page has some of the words
Page contains exact phrase

[Optional] Specify additional options on the Options tab page. (See Configuring WebFind Searches.)
6 Click Find Now.




Sorting the search results
You can sort the search results page either by Web Site or by Web Page.

To sort search results by Web Site:
1 Find the Sort By buttons at the top of the search results page.
2 Click Site.

Notes:

" When sorted by site, the WebFind search results page groups together all matching Web pages found on the same
Internet computer, or "Web site." The site with the most pages is listed first. The site listing includes a hypertext link to that site and a
listing for each page found at that site. Within the site group, pages with the highest score are listed first.

" The Web page with the highest score is not necessarily at the Web site with the most matching pages.

To sort search results by Page:
1 Find the Sort By buttons at the top of the search results page.

2 Click Page.

Note:
" When sorted by page, Web pages with the highest scores are listed first on the WebFind search results page.
Tip:

- To set either sort method as the default, select the preferred method from the View menu.



Sorting search results

Does WebFind sort the pages returned by the search engines?
Yes. WebFind sorts the search results two ways:
¥ By Site
The WebFind search results page groups together all pages found on the same Internet computer, or "host site." The site
with the most pages is listed first. Within the site group, pages with the highest score are listed first.
¥ By Page
The WebFind search results page lists all found pages according to their score, regardless of host site.
Tip:
" To set either sort method as the default, select the preferred method from the View menu.



Changing the default sorting method for search results
WebFind can sort search results by page or by site. (See Sorting search results)
To specify a default sorting method:

1 Open the View menu in WebFind. The current setting is checked.
2 Select either Sort Results By Page or Sort Results By Site.



Specifying effective searches
How can | specify more effective searches?

Tip: Enter enough words to find just what you want, and nothing more.

" To find information on a person, enter their name and select Page Contains Exact Phrase.

" To find information on a specific person with a common name, include an additional word or two that might identify the
right person. For example, search for "Paul Simon senate" or "Paul Simon music" depending on which Paul Simon you are
interested in.

" To find information on "windows" (the building component) but not "Windows" (the software), search for "windows glass
and select Page Has All Of The Words....

Tip: Enter the "root" of a word to find variations on that word:

" For example, search for "recycl" to find pages containing "recycling," "recyclable," and "recycle."
Tip: Disable search engines that are too slow or that do not return useful information.

" To select search engines:
1 Click the Options tab.

2 In the list labeled Use The Following Search Engines, check the search engines you want to include, and uncheck the
search engines you want to exclude.

Tip: If you want more hits ...

. Enter fewer search words.

. Use the Page Has At Least One Of The Words option.
Tip: Avoid irrelevant information

. Click here

ﬁl for tips.



Stopping a search in progress

To stop a search in progress:
1 Click Stop any time during the search.

A message box will appear asking if you want to display the search results for pages found so far.
2 Click Yes or No.

OR
b Click New Search any time during the search.
This will stop the search, discard any results found so far, and restore the Search tab to its default settings.
Note:
" There may be a delay after you click Stop and before the message box appears while the search engines respond to the

"stop searching" command from WebFind. Please be patient.



Using the search results page

When a search is complete, WebFind collects the names of the pages returned by each search engine, eliminates duplicates,
eliminates advertising, scores the pages, creates a Web page on your PC containing the search results, launches your default Web
browser, and loads the search results page into it.

The listing for each matching page includes:

The title of the page (a hypertext link)

A descriptive summary of the page, usually several lines long
The URL of the page (a hypertext link)

The score of the page

A list of the search engines that found the page

To jump to any page listed in the search results:
¥ Click the title of the page or the URL of the page in its listing.
To jump to a Web site containing matching pages:

¥ Click the URL of the site.
(Available only when the search results are sorted by site.)

To jump to the site of a search engine:
¥ Click the name of the search engine at the top of the search results page.



Viewing previous search results
WebFind lets you review the search results from any of your previous ten searches.

To view previous search results:
1 Open the File menu in WebFind.
The search words for the last ten search results pages are listed on the menu. The most recent results are at the top.
2 Click the search word (or phrase) you want and the corresponding search results page will be loaded into your Web browser.



Adds 30 seconds to the countdown timer.



Executes the search using the current settings in the Search and Options tabs.



Prepares WebFind for a new search:

Stops the search in progress, if any, discarding any partial search results.
Clears the Search For words.

Selects Page Has All The Words But In Any Order on the Search tab.
Retains all settings on the Options tab.

Contracts the dialog box, if the results of a previous search are still visible.



Check the Search Engines you want to include in your searches. Uncheck the Search Engines you want to exclude from your
searches.



Enter the amount of time, in seconds, you want WebFind to search for documents. When this time expires, the search will stop,
even if some Search Engines have not returned the requested number of documents.

Note:
" You can add time in increments of 30 seconds during the search.



Enter the number of matching documents you want to get from each Search Engine. The Search Engines will search for documents
that best meet your search criteria and return this many of them from the top of the list.



The number of matching pages returned by the search engines.



Names of the search engines being used for the current search.



Graphic indication of the progress of each search engine in finding the requested number of matches.



The status of the search engines being used for the current search.



Tells WebFind to search only for documents that contain all of the words you entered. Documents that contain only some of the
words will not be returned.



Tells WebFind to search for documents that contain all the words you entered as a unit, with no words in between.



WebFind will search the World Wide Web for documents that contain the words you enter here.



Tells WebFind to search for documents that contain any of the words you entered. For example, if you entered two words, WebFind
will return documents that contain the first word or the second word, or both.



Displays several tips and tricks for entering search specifications.



Tells WebFind to discard any links returned by the search engines that are not currently accessible Web pages.

Note:

When you use a search engine to search for Web pages, it doesn't actually search the entire World Wide Web right then
— it searches an index of web pages that it maintains "behind the scenes." Some Web pages may have been removed from the
Web since that index was created. Therefore, some of the links returned by the search engines may not exist anymore.

When this option is checked, WebFind tests each link returned by the search engines to see if the Web page still exists
before adding that page to the search results. The number of sites discarded will be displayed at the top of the search results page.

Caution:

Checking this option can slow down your searches. Because WebFind tries to connect briefly to the Web site of every
matching link, any sites that are down or responding slowly will delay the display of search results.



Stops the search in progress. WebFind will process any matches returned before you clicked the button.



Search timer. When this countdown timer reaches 0:00, WebFind will stop the search (even if the Search Engines have not returned
the requested number of pages) and process any pages returned so far.



Tips and Troubleshooting

Click the button next to any question or topic:

¥

How can | specify more effective searches?

Explain the search options a little bit.

When | click the site at the top of each group, | get pages that have nothing to do with my search.
Why do some search engines return irrelevant information?

How can | get results faster?

What's the difference between sorting by site and sorting by page?

| can't find what | want but | know it's out there somewhere.

How does WebFind score Web pages?

¥

el



Search options explained

Explain the available search options a little bit.
On the Search tab page:

ﬁl Search for

ﬁl Page has all of the words, but in any order

ﬁl Page has at least one of the words

El Page contains exact phrase

On the Options tab page:

ﬁl Use the following search engines

.2' Retrieve the top [ ] matches from each search engine

El Search a maximum of [ ] seconds




What does WebFind do?

WebFind searches the Internet's World Wide Web for pages containing words or phrases that you specify, and displays the
results using your Web browser.

WebFind takes the word or words you enter and sends them to several search engines on the Internet. These search engines look
for World Wide Web documents, or "Web pages," that contain those words and then send the names and addresses of those pages
back to WebFind. The search engines also send back a score or rating for each page indicating how well or how closely the pages
match your search words.

WebFind collects the names and addresses of these pages, eliminates duplicates, eliminates advertising, and sorts them. It then

creates an HTML document on your PC containing descriptions of each document and a hypertext link to it. WebFind opens that

document with your Web browser. You can then scroll through this page, find the specific links that interest you, and jump to them
with the click of a mouse button.

ﬂl Internet FastFind Help Contents



Uniform Resource Locator (URL)

The "address" of a document on the Internet. It includes components that define:

ﬁl the type of connection required to interpret the document (ftp, http, telnet, mailto, etc.),

ﬁl the address of the computer system where the document resides (which sometimes includes a port number),
ﬂl the "path" to the document within the computer system, and

ﬁl the name of the document itself.
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