
FileMaker Pro 4.0 for Windows
Easy information management -- from desktop to the web

TRIAL SOFTWARE GUIDE

FileMaker Pro 4.0 is the database software program that has both the power and flexibility to 
handle all your everyday home and business functions. From preparing invoices, mailing lists, 
purchase orders and reports to inventory management and project tracking, FileMaker Pro 
software gives you the power to accomplish even your most complex data management tasks.

With its new web features, FileMaker Pro 4.0 becomes the easiest way to manage information -- 
on your desktop, across a network, or over the World Wide Web. FileMaker Pro databases are 
accessible to ordinary web browsers; you don't need to have a web server or to write HTML code.
Authorized users can even edit, delete, and update records. 

Whether you are a first-time database buyer or an advanced user, FileMaker Pro can help make 
you productive in minutes. FileMaker Pro puts you in control -- giving you easy access to 
sophisticated features without having to learn complex programming skills.

Using this Guide

This Guide uses an interactive approach to show you why FileMaker Pro is the database for the 
real world. To see how FileMaker Pro can help make you productive in minutes, follow the steps 
in this Guide to explore the relational and web features of FileMaker Pro 4.0. See how easy it is 
to:
•  use templates to create new files
•  set up a relationship between files
•  work with related fields and portals
•  merge information
•  create mailing labels
•  format text paragraphs
•  publish FileMaker Pro databases on the web*

Note This trial version of FileMaker Pro 4.0 is limited in the following ways:
•  You can create a maximum of 50 records. 
•  You won't be able to import graphics. 
•  When you print, a banner with the words "FileMaker Pro" appears in the background of each 
page.
•  You won't be able to share files across a network.
•  The onscreen Help, spelling checker, and tutorial files are not included, and only some of the 
templates and examples are included.

All of these items are included with the retail version of FileMaker Pro 4.0.

Using templates to create files

A quick way to create a database file is to modify an existing template file. FileMaker Pro 4.0 
includes many useful business, educational, and home templates. In the following steps, you'll be 
using templates that contain example data. You can modify the templates to contain your own 



data.

To work with the FileMaker Pro templates:

1.  Start the FileMaker Pro 4.0 Trial by choosing Programs, then FileMaker Pro 4.0 Trial from 
the Start menu.

2.  In the New Database dialog box, click Create a new file using a template.

3.  Choose Business from the drop-down menu, select the template file set Task System, and 
then click OK.

4.  Click Save to save the file set.
Make sure you're saving the files to the FileMaker Pro 4.0 Trial folder.  FileMaker Pro copies and 
opens each of the files (Choices, People, ToDo) in the set. 

To create a record:

1.  In the ToDo file, click the New Record button to create a new To Do item.
If the ToDo file is not visible, bring it to the front by selecting ToDo from the Window menu.

2.  Select 01 Davidson, Julie from the Contact ID pop-up menu. 
The related information fills in automatically.

3.  Press Tab twice to move to the Time field and type 9:00.

4.  Finish filling out the To Do item by tabbing to the Item field and typing Call Julie’s agent, RE: 
Closing.

5.  Click the Return button to switch to the People file.

You see Julie’s record in the related file, People. The new task appears in the To Do Items list.

Exploring a relational database

When you connect files based on common fields, you create a relationship between two files. 
Relationships let you share data among files without having to duplicate the data in each file.

To view a relationship:

1.  In the People file, choose Define from the File menu and then choose Relationships.
In the Define Relationships dialog box, notice that the People file is related to the ToDo file by the 
common field Contact ID. People is also related to the Choices file.

2.  Click Done.

To insert a related field on a layout:

1.  Choose the Form 2 layout from the layout pop-up menu in the status area (in the upper-left 
corner of the screen above the book icon).

2.  Choose Layout from the Mode menu to switch to Layout mode.

3.  Click the field tool (in the status area) and drag a new field into the blank area just under the 
“To Do List” section.



4.  In the Specify Field dialog box, choose ToDo from the relationship drop-down list. 
This displays a list of the fields in the ToDo file.

5.  If the Create field label option is checked, deselect it. 

6.  Click ::Item, and then click OK. 

7.  Drag the field to make it wider (so that it is approximately 1/2 inch from the green borderline).

8.  Choose Browse from the Mode menu to switch to Browse mode.
You see the first To Do item for each contact. Using the book icon, scroll through several records 
to see the data change for each person.

Working with portals 

To see all the To Do items related to the People file, you can create a window, called a portal, into
the data stored in the ToDo file. With a portal you see all of the To Do items for each contact, not 
just the first task entered. 

To create a portal to view all the To Do items:

1.  In the People file, choose Layout from the Mode menu.

2.  Click the portal tool, and drag a new portal below the ::Item field you previously added. 
The portal tool is next to the button tool on the tool panel and looks like a separated square. If you
can't find it, use the layout pop-up menu to switch to the Tools layout, where you can see labels 
for the tools in the status area.

3.  From the relationship drop-down list, choose ToDo.

4.  Select the Show vertical scroll bar checkbox.

5.  Select the Alternate background with checkbox, and then choose any color from the bottom 
row of colors on the first color palette.

6.  Click OK.

7.  Click the pointer tool and drag the ::Item field into the top row of the portal.

8.  Choose Browse from the Mode menu.
You can now see all the To Do items for each contact inside the People file.

9.  Scroll through the first 3 or 4 records to see a list of activities for each person.

Finding records and merging information

You can search for specific information in your database by using Find mode. Use a find request 
when you want to locate records with specific data or work with a subset of records (for example, 
to print a found set records).

To search for contacts interested in a specific neighborhood:

1.  In the People file, switch to the Form View layout using the layout pop-up menu.



2.  Choose Find from the Mode menu. 

3.  Press Tab twice to move to the Neighborhood Preference field.

4.  Choose Coastside from the list, choose.

5.  Click the Find button.

The found set has 5 records. 

To send a letter to the contacts in the found set:

1.  Choose the Letter layout from the layout pop-up menu.

2.  Choose Layout from the Mode menu.

3.  Select the text tool from the tool panel.

4.  Insert the cursor before the “n” in “neighborhood” in the second line.

5.  Choose Paste Special from the Edit menu and Merge Field from the submenu.

6.  Choose People from the Current File list.

7.  Double-click the field Neighborhood, and then press the Space bar to insert a space after the
merge field.

8.  Select the merge field (including the << >> angle brackets), and make it bold by clicking the B 
on the text ruler. 
If the text ruler is not displayed, choose Text Ruler from the Show menu.

9.  Choose Browse from the Mode menu to see the letter with the merged information.

Creating mailing labels

In FileMaker Pro 4.0, mailing labels are easier than ever to create. The People file includes a 
special layout for mailing labels.

To create mailing labels:

1.  In Layout mode, choose New Layout from the Mode menu.

2.  In the New Layout dialog box, choose Labels.

3.  Type Mailing Labels in the Layout Name box.

4.  Click OK.

5.  In the Use label measurements for drop-down list, choose Avery 5160. If you don't see the 
Avery 5160 labels, choose Avery 7160.

6.  Click OK.

7.  In the Specify Layout Contents dialog box, you choose which fields will appear on the label. 
Double-click the First Name field to add it to the layout.



8.  To add a space, press the Space bar.

9.  Double-click the Last Name field.

10.  Press the Enter key to move to the next line.

11.  On the next line, double-click the Neighborhood field.

12.  Add additional fields, or click OK to finish the label.

13.  Choose Preview from the Mode menu to view the mailing labels. 
You see five labels (everyone found in the “Coastside” find request).

14.  To see the completed mailing labels, choose the Avery 5160 layout from the layout pop-up 
menu.  If you don't see a layout named Avery 5160, choose Avery 7160.

You can print the labels by choosing Print from the File menu. Be sure to print Records being 
browsed.

Formatting text

You can enter, edit, and format text in Browse, Layout, and Find modes, just as you do with word 
processing software.

To change the formatting of a letter:

1.  Choose Followup Letter from the layout pop-up menu.

2.  Choose Layout from the Mode menu.

3.  Select the text tool from the tool panel.

4.  Select the text in the three bulleted items.

5.  From the left side of the text ruler, drag the bottom indent triangle to 3/4 inches.

6.  Drag the top indent triangle back to 1/2 inches to align the paragraph.

7.  Choose Browse from the Mode menu to see the results.

8.  To close the files, press Command-W four times.

Publishing FileMaker Pro data on the web

With FileMaker Pro 4.0, you can publish your database on the World Wide Web -- without any 
additional software -- using FileMaker Pro Web Companion and your TCP/IP access. Your 
database can be viewed, edited, sorted, and searched by anyone who has web browser software 
and access to the Internet or an intranet network. Your file is available to anyone who has access 
to the World Wide Web. 

There are two ways you can publish your database on the web using FileMaker Pro 4.0: Instant 
Web Publishing and  Custom Web Publishing. Regardless of the method you choose, you'll need 



to provide web users with the IP address of the machine hosting the FileMaker Pro 4.0 
databases.

To publish a database on the web, you must have:
•  A computer running Windows 95, Windows NT, or the Mac OS with an IP address on the 
Internet or an intranet. Internet connections are usually provided though an Internet service 
provider. If your company has an intranet, you can make your database available within your 
company or workgroup.
•  FileMaker Pro 4.0 (for Windows or Mac OS) with the FileMaker Pro Web Companion and 
supporting files installed. 

It is best if the computer running your FileMaker Pro database has a full-time dial-up, ISDN, T1, 
T2, or T3 connection to the Internet (or similar capabilities). Without continuous Internet access, 
you can publish a database on the web, but your database is only available while your computer 
is connected to the Internet.

Configuring the Web Companion without an Internet connection

To use the FileMaker Pro 4.0 Web Companion without an Internet connection, you can configure 
a Windows 95 computer to behave as if it were connected to a TCP/IP network -- even if you do 
not have a modem or Ethernet adapter. The following section explains how to do this. 

Important  Following these instructions will remove any network connection currently in place on 
your Windows 95 PC. If your PC is already connected to a network or to an ISP, carefully note 
your original configuration before making these changes. These changes are listed solely for the 
benefit of those who want to test the new Web features in FileMaker Pro 4.0 without having an 
actual network connection.

1.  Open the Network control panel (in the Control Panels folder).

2.  If you have any network adapter, network clients, or network protocols installed, remove them.

3.  Click the Add button. Then, double-click the Adapter item in the menu.

4.  Select Microsoft from the list of manufacturers. 

5.  Select Dial-Up Adapter from the right-hand menu, then click OK.

6.  In the Network control panel, click the Add button again. 

7.  Double-click Protocol.

8.  Select Microsoft from the list of manufacturers. 

9.  Select TCP/IP from the right-hand menu, then click OK.

10.  In the Network control panel list, you should see both a Dial-Up Adapter and the TCP/IP 
protocol. If you see anything else, such as an IPX/SPX or NetBEUI protocol, remove it.

11.  Double-click the TCP/IP protocol to edit its properties. 

12.  Specify the following settings.
•  Enter 10.10.10.10 as the IP address
•  Disable the WINS and DNS services
•  Enter 10.10.10.1 as the gateway. 



13.  Click OK.

14. Click OK, and restart your computer.

Now you're able to use your PC to test the Web features in FileMaker Pro 4.0. For example, you 
can open a database you've created in FileMaker Pro 4.0, and configure the Web Companion to 
share a database using Instant Web Publishing. To see what it looks like to a web user, open 
Microsoft Internet Explorer or Netscape Navigator, and type http://10.10.10.10/ into the Address 
field. Your web browser should then connect to the FileMaker Pro 4.0 Instant Web Publishing 
feature.

TCP/IP port numbers

By default, FileMaker Pro 4.0 uses the TCP/IP port number ordinarily assigned to http (port 80). 
However, if you already have a web server running on your computer, and you want to use the 
Instant Web Publishing feature, you must set FileMaker Pro 4.0 to use an alternative TCP/IP port 
number. Claris has reserved port number 591 with the Internet Assigned Numbers Authority 
(IANA) for this use, and we recommend you choose port number 591 in the Web Companion 
Configuration dialog box if port number 80 is already in use.

Introducing Instant Web Publishing

FileMaker Pro Instant Web Publishing lets you publish your database on the web quickly and 
easily. You do not need to change your database, use any additional software, or design web 
pages. You can control what web users can do in the database, for example, viewing, adding, 
editing, deleting, searching, or sorting records. Depending on how you've set up Instant Web 
Publishing, web users can see different views -- or HTML pages -- for working with data in your 
database:
•  a Table View, for working with several records at a time
•  a Form View, for working with one record at a time
•  a Search page, for finding data that matches criteria you type
•  a Sort page, for sorting records (if you enabled sorting when you set up the views)

Accessing a database on the web

When web users type the IP address of the machine publishing a FileMaker Pro 4.0 database on 
the web, they see an automatically generated home page that has links to the databases. 
Detailed help is available to web users who click the Help (?) button on the web page. If you are 
familiar with HTML editing, or have HTML editing software such as Claris Home Page 3.0**, you 
can create a personalized home page to be used with Instant Web Publishing. You must include a
hyperlink with the IP address of the computer where the database you want to publish on the web
is open.

The following steps show you how to publish the ToDo database on the web. By modifying and 
then publishing the ToDo database on the web, you'll be able to enter new tasks in it from any 
web browser.

To publish the ToDo database on the web using Instant Web Publishing:

1.  Choose Preferences from the Edit menu, and then choose Application.

2.  In the Application Preferences dialog box, choose the Plug-Ins tab.

3.  Select the Web Companion checkbox.
Now web sharing is available for any database you open. The following steps 4-7 apply to any 



database you want to publish on the web. 

4.  Open the ToDo database (or bring it to the front by selecting it from the Window menu).

5.  Choose Sharing from the File menu.

6.  In the Companion Sharing area, select the checkbox next to Web Companion.

7.  Click OK.

Note  You must have Export records access privileges to publish a database on the web.

To choose which fields are displayed:

1.  In the File Sharing dialog box, click the Set Up Views button.

2.  Choose a view from the tabs to set up which fields appear in that browser view.

In general, choose layouts that contain the fields you want displayed in the web user's browser. 
Selecting a layout does not display that layout in the browser -- it only indicates which fields you 
want displayed in the browser.

Choosing All Fields (no layout) displays all fields in the database (but not related fields). 

Introducing Custom Web Publishing

Although FileMaker Pro Instant Web Publishing provides you with a quick and easy way to 
publish your database on the web, you are limited in what you are able to do and in the 
appearance of the interface. To have much more control over how your data is published on the 
web, use Custom Web Publishing. 

With Custom Web Publishing, you create format files in an HTML editing application and use the 
FileMaker Pro CDML Tool to add Claris Dynamic Markup Language (CDML) tags. 

If you want to have format files created for you, use the FileMaker Pro Connection Assistant 
feature in Claris Home Page 3.0**. Otherwise, you must have web page authoring software such 
as Claris Home Page 3.0** and an understanding of HTML and CDML.

Custom Web Publishing -- an overview

The following is an overview of the minimum steps required to publish your database on the web 
using FileMaker Pro Custom Web Publishing: 

1.  Create the database or open an existing database.

2.  Use the CDML Reference and the CDML Tool (available in the retail version of FileMaker Pro 
4.0) to create format files in a web page authoring application such as Claris Home Page 3.0**. 
The CDML Tool organizes CDML tag syntax, which can then be pasted into an HTML editing 
application.

3.  Make sure FileMaker Pro Web Companion is enabled in the Application Preferences dialog 
box.

4.  If you're not using it for other databases, disable Instant Web Publishing in the Web 
Companion Configuration dialog box.



5.  Change the home page from Built-In to one that contains a hyperlink to your database(s).

6.  For the database that you want to publish, enable Web Companion Sharing in the File 
Sharing dialog box.

Hosting the Guest Book web solution

The Guest Book solution provides an example that allows web users to add records in the Guest 
Book.fp3 FileMaker Pro database using the gb_new.htm format file. When a record is added 
successfully, the gb_sum.htm format file provides feedback, letting web users know that their 
record has been added. The gb_err.htm format file notifies web users if the record could not be 
added. In addition to these three files, the solution includes a home page, default.htm, which 
contains a link to the gb_new.htm format file, and image files.

To publish the Guest Book.fp3 database file on the web:

1.  Verify that the FileMaker Pro Web Companion is enabled in Application Preferences.

2.  Open the Guest Book.fp3 database, located in the Web folder inside the FileMaker Pro 4.0 
folder.

3.  Choose Sharing from the File menu.

4.  In the Companion Sharing area of the File Sharing dialog box, select the checkbox next to 
Web Companion.

5.  Click OK.

To specify which home page the Web Companion uses:

1.  Choose Preferences from the Edit menu, and then choose Web Companion.

2.  In the Web Companion View Setup dialog box, click Configure.

3.  For Home Page, choose default.htm.

4.  Click OK.

Any HTML file located in the Web folder inside the FileMaker Pro 4.0 folder can be specified as 
the Home Page. Your home page must provide links to format files that interact with the 
FileMaker Pro 4.0 database files.

For more information on Custom Web Publishing, visit the FileMaker Pro web site: 
www.filemaker.com.

Benefits of using FileMaker Pro
•  Publish your databases on the web
•  Get started easily
•  Access and manage data with powerful tools
•  Make data look the way you want
•  Share information easily and securely



Publish your databases on the web:

Instant Web Publishing  Built-in HTTP support lets authorized users search, edit, delete, and 
update FileMaker Pro records using today’s most popular web browsers. You don’t need to write 
HTML code or have a separate web server!

Custom Web Publishing  Using the built-in CGI capabilities of FileMaker Pro 4.0, connect your 
databases to web pages in order to collect custom information and share data with visitors to your
web site.

Integration with Claris Home Page 3.0  Design custom web pages that interact with FileMaker 
Pro 4.0 databases via the FileMaker Connection Assistant in Claris Home Page 3.0.**

Integrate Multimedia  Enhance your custom web solution by incorporating JPEG and GIF 
images, animated GIF images, AIFF sound files, QuickTime movies, and Java applets into HTML 
pages served by the FileMaker Pro 4.0 Web Companion.

Get started easily:

Web Templates   Use the Shopping Cart, Guest Book, Employee Database, and instructional 
HTML templates to collect and share information over the Internet.

Professional Solutions  Get started quickly with solutions for business, education and home -- 
including invoicing, mailing lists, contact management, project tracking, inventory management, 
school records, and more.

Microsoft Excel File Conversion  Turn many versions of Microsoft Excel spreadsheets into fully 
functional FileMaker Pro databases quickly, then manipulate the data in ways not possible with a 
spreadsheet program.

Versatile Data Import  Automatically create FileMaker Pro databases using raw data from 
spreadsheets, word processors, and other databases.

Data Handling Flexibility  Add, change or remove fields, layouts and calculations at any time 
without rebuilding the database.

Auto Indexing  Find records fast without the complexity of managing index files -- automatically 
indexes fields.

Access and manage data with powerful tools:

Relational Database Capabilities  Enter data just once, then use it anywhere by creating one-
to-one, one-to-many and many-to-many relationships between files. Sort information from related 
databases.

Data-Lookup Capabilities  Automatically copy and paste data between related files to avoid 
repetitive data entry.

ScriptMaker  Automate routine tasks and menu commands -- anything from launching URLs, to 
dialing the phone, to sending email.***

Versatile Find Function  Retrieve only the information you need by specifying search 
parameters: range, less than, greater than, and/or/not, exact match, empty, duplicate, wildcard, or



literal. Search for an exact value in a field.

Custom Field Formats  Accelerate data entry with customizable radio buttons, check boxes, 
pop-up menus and more -- even use data from related files.

Automatic Data Entry  Save time by inserting the current date or time, specific text, serial 
numbers, calculated values, and other data.

Built-in Spelling Checker  Eliminate spelling errors from records, reports, and layouts.

More than 100 Calculation Functions  Streamline data entry, validation, and analysis with 
simple or complex calculations.

User-definable Buttons  Easily customize the appearance and operation of your files with 
buttons you create in a single step.

Make data look the way you want:

Powerful Design Capabilities  Create compelling reports and forms with comprehensive built-in 
graphic tools. Rotate text, fields, and layout objects in 90-degree increments for a customized 
look.

Drag-and-Drop Support  Design multiple layouts to enter, view and print information by simply 
dragging and dropping fields from the current file or related files.

Multimedia “Container” Fields  Enhance your fields easily by integrating video footage, 
animations, sounds, still images stored in popular formats such as JPEG, and GIF, and other 
multimedia content.

Mail-Merge Support  Create customized letters and other documents within FileMaker Pro -- no 
need to export data to a word processing program.

Integrated Text Handling  Add up to 64,000 characters in any text field and use built-in word 
processing capabilities to format the font, style, tabs, indents, and so on.

Share information easily and securely:

Cross-Platform Compatibility  Share files seamlessly between Windows and Mac OS versions 
of FileMaker Pro 3.0 and 4.0 -- including concurrent users over your local area network, an 
intranet or the Internet.

Instant Peer-to-Peer Networking  Convert a database into a networked solution in one simple 
step.

Password Control  Allow authorized users to search, edit, delete and update records. Protect 
your data on the layout and field level.

Automatic Record Locking  Ensure the integrity of your data in multi-user networked 
environments.

Instant File Updating  Automatic updating keeps you current by reflecting changes made by any 
user accessing your database over a network.



For large networks of users, Claris also produces FileMaker Pro Server, client-server file sharing 
for faster multi-user performance. To license FileMaker Pro 4.0 or FileMaker Pro Server 3.0, call 
1-800-544-8554 in the US, 1-800-361-6075 in Canada, or talk to a Claris reseller near you.
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