home *** CD-ROM | disk | FTP | other *** search
/ 3D Game Programming for Teens (2nd Edition) / 3DGPFT2E.iso / Source / Chapter03 / demo03-10.bb < prev    next >
Text File  |  2009-01-20  |  742b  |  36 lines

  1. ;demo03-10.bb - Draws out 25 '*'s and 25 '+'s
  2.  
  3. ;create the array
  4. Dim starsplusses$(2,24) 
  5.  
  6. ;initialize the array. The first dimension will contain *'s and the second will contain +'s
  7. For rows = 0 To 1 
  8.     For columns=0 To 24
  9.         ;Assign either + or *, depending on the return value of FindChar$()
  10.         starsplusses$(rows,columns) = FindChar$(rows)
  11.     Next
  12.     
  13. Next
  14.  
  15. ;display the array
  16. For rows = 0 To 1 
  17.     For columns = 0 To 24
  18.         ;Write each value to the screen
  19.         Print starsplusses$(rows,columns)
  20.     Next
  21.     ;write a new line after each row
  22.     Print "" 
  23. Next
  24.  
  25. ;Delay five seconds
  26. Delay 5000
  27.  
  28. ;FUNCTION FINDCHAR$(i)
  29. ;returns * or +
  30. Function FindChar$(i)
  31.     If i = 0
  32.         Return "*"
  33.     Else If i = 1 
  34.         Return "+"
  35.     EndIf
  36. End Function