home *** CD-ROM | disk | FTP | other *** search
/ 3D Game Programming for Teens (2nd Edition) / 3DGPFT2E.iso / Source / Chapter04 / demo04-01.bb next >
Text File  |  2009-01-20  |  913b  |  31 lines

  1. ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
  2. ; HelloWorld.bb;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
  3. ; By Maneesh Sethi;; ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
  4. ; This program prints "Hello World to the screen.;;;;;
  5. ; There are no input variables required;;;;;;;;;;;;;;
  6. ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
  7. ;VARIABLES
  8. ;The hello string to be printed on the screen
  9. hellostr$ = "Hello World!" 
  10. ;END VARIABLES
  11.  
  12. ;MAIN PROGRAM
  13. ;Pass "hellostr$" to PrintString function
  14. PrintString(hellostr$) 
  15.  
  16. ;Wait for five seconds before closing
  17. Delay 5000
  18.  
  19. ;END MAIN PROGRAM
  20.  
  21. ;FUNCTIONS
  22. ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
  23. ;Function PrintString(str$);;;;;;;;;;;
  24. ;This function prints the variable str$
  25. ;Parameters: str$ - the string to be printed
  26. ;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;
  27. Function PrintString(strng$)
  28. ;Print str$ on screen
  29. Print strng$ 
  30. End Function
  31. ;END FUNCTIONS