home *** CD-ROM | disk | FTP | other *** search
/ 3D Game Programming for Teens (2nd Edition) / 3DGPFT2E.iso / Source / Chapter05 / demo05-05.bb < prev    next >
Text File  |  2009-01-20  |  524b  |  27 lines

  1. ; demo05-05.bb - Putting a texture on a sphere
  2. ; ------------------
  3. Graphics3D 640,480 
  4. SetBuffer BackBuffer()
  5.  
  6. Const ESC_KEY = 1
  7. ; Create camera 
  8. camera = CreateCamera()
  9. ; Create a light 
  10. light = CreateLight()
  11.  
  12. ; Create our sphere 
  13. sphere=CreateSphere(32) 
  14. PositionEntity sphere,0,0,5 
  15. ScaleEntity sphere, 2,2,2
  16.  
  17. ; Create the texture 
  18. tex=LoadTexture( "texture.bmp" ) 
  19. EntityTexture sphere, tex
  20.  
  21.  
  22. ; This following code makes our program run 
  23. While Not KeyDown(ESC_KEY)
  24.     RenderWorld 
  25.     Flip
  26. Wend
  27. End