home *** CD-ROM | disk | FTP | other *** search
/ 3D Game Programming for Teens (2nd Edition) / 3DGPFT2E.iso / Source / Chapter11 / demo11-03.bb < prev    next >
Text File  |  2009-01-20  |  1KB  |  50 lines

  1. ;demo11-03.bb - Collisions and types with EntityRadius
  2. ; ------------------
  3. Graphics3D 640,480 
  4. SetBuffer BackBuffer()
  5.  
  6. Const ESC_KEY = 1
  7. Const LEFT_KEY = 203
  8. Const RIGHT_KEY = 205
  9. Const UP_KEY = 200
  10. Const DOWN_KEY = 208
  11.  
  12. ; Creating the types
  13. type_player=1
  14. type_obstacle=2
  15.  
  16. ;The camera
  17. camera=CreateCamera()
  18. ; Creating a light
  19. light=CreateLight()
  20. ; Creating a sphere
  21. sphere=CreateSphere()
  22. ScaleEntity sphere, 0.5,0.5,0.5
  23. PositionEntity sphere, -3,0,5
  24. EntityType sphere,type_player
  25. EntityRadius sphere, 0.2
  26.  
  27. ; Creating a cone
  28. cone=CreateCone()
  29. PositionEntity cone, 1,0,5
  30. ScaleEntity cone, 1.5,1.5,1.5
  31. EntityType cone,type_obstacle
  32.  
  33. Collisions type_player,type_obstacle,2,2
  34.  
  35. ; This following code makes our program run
  36. While Not KeyDown(ESC_KEY)
  37.     x#=0
  38.     y#=0
  39.     z#=0
  40.     If KeyDown(LEFT_KEY)=True Then x#=-0.1
  41.     If KeyDown(RIGHT_KEY)=True Then x#=0.1
  42.     If KeyDown(DOWN_KEY)=True Then y#=-0.1
  43.     If KeyDown(UP_KEY)=True Then y#=0.1
  44.     MoveEntity sphere,x#,y#,z#
  45.     RenderWorld
  46.     UpdateWorld
  47.     Flip
  48. Wend
  49. End
  50.