home *** CD-ROM | disk | FTP | other *** search
/ 3D Game Programming for Teens (2nd Edition) / 3DGPFT2E.iso / Source / Chapter11 / demo11-04.bb < prev    next >
Text File  |  2009-01-20  |  1KB  |  58 lines

  1. ;demo11-04.bb - Collisions and types with ClearCollisions
  2. ; ------------------
  3. Graphics3D 640,480 
  4. SetBuffer BackBuffer()
  5.  
  6. Const ESC_KEY = 1
  7. Const LEFT_KEY = 203
  8. Const RIGHT_KEY = 205
  9. Const UP_KEY = 200
  10. Const DOWN_KEY = 208
  11. Const SPACE_BAR = 57
  12. Const ONE_KEY = 2
  13. ; Creating the types
  14. type_player=1
  15. type_obstacle=2
  16.  
  17. ;The camera
  18. camera=CreateCamera()
  19. ; Creating a light
  20. light=CreateLight()
  21. ; Creating a sphere
  22. sphere=CreateSphere()
  23. ScaleEntity sphere, 0.5,0.5,0.5
  24. PositionEntity sphere, -3,0,5
  25. EntityType sphere,type_player
  26. EntityRadius sphere, 0.2
  27.  
  28. ; Creating a cone
  29. cone=CreateCone()
  30. PositionEntity cone, 1,0,5
  31. ScaleEntity cone, 1.5,1.5,1.5
  32. EntityType cone,type_obstacle
  33.  
  34. Collisions type_player,type_obstacle,2,2
  35.  
  36. ; This following code makes our program run
  37. While Not KeyDown(ESC_KEY)
  38.     x#=0
  39.     y#=0
  40.     z#=0
  41.     If KeyDown(LEFT_KEY)=True Then x#=-0.1
  42.     If KeyDown(RIGHT_KEY)=True Then x#=0.1
  43.     If KeyDown(DOWN_KEY)=True Then y#=-0.1
  44.     If KeyDown(UP_KEY)=True Then y#=0.1
  45.     MoveEntity sphere,x#,y#,z#
  46.     While KeyHit( 57 ) 
  47.         ClearCollisions
  48.     Wend
  49.     While KeyHit( 2) 
  50.         Collisions type_player,type_obstacle,2,2
  51.     Wend
  52.  
  53.  
  54.     RenderWorld
  55.     UpdateWorld
  56.     Flip
  57. Wend
  58. End