home *** CD-ROM | disk | FTP | other *** search
/ 3D Game Programming for Teens (2nd Edition) / 3DGPFT2E.iso / Source / Chapter11 / demo11-06.bb < prev    next >
Text File  |  2009-01-20  |  1KB  |  83 lines

  1. ;demo11-06.bb - Hiding on collision
  2. ;_______________
  3.  
  4.  
  5. Graphics3D 640,480
  6. SetBuffer BackBuffer()
  7.  
  8. Const ESC_KEY = 1
  9. Const LEFT_KEY = 203
  10. Const RIGHT_KEY = 205
  11. Const UP_KEY = 200
  12. Const DOWN_KEY = 208
  13.  
  14. ; Create camera
  15. camera=CreateCamera()
  16.  
  17. ; Creating a light
  18.  
  19. light=CreateLight()
  20.  
  21. ; Creating the types
  22.  
  23. type_player=1
  24. type_obstacle=2
  25.  
  26. ; Creating a sphere
  27.  
  28. sphere=CreateSphere()
  29. ScaleEntity sphere, 0.5,0.5,0.5
  30. PositionEntity sphere, -3,0,5
  31. EntityType sphere,type_player
  32. EntityRadius sphere, 0.2
  33.  
  34.  
  35. ; Creating a cone
  36.  
  37. cone=CreateCone()
  38. PositionEntity cone, 1,-1,5
  39. ScaleEntity cone, 1.5,1.5,1.5
  40. EntityType cone,type_obstacle
  41.  
  42. Collisions type_player,type_obstacle,2,2
  43.  
  44. ; Creating a cone
  45.  
  46. cone1=CreateCone()
  47. PositionEntity cone1, 1,2,5
  48. ScaleEntity cone1, 1.5,1.5,1.5
  49. EntityType cone1,type_obstacle
  50.  
  51. Collisions type_player,type_obstacle,2,2
  52.  
  53.  
  54. ; This following code makes our program run
  55.  
  56. While Not KeyDown(ESC_KEY)
  57.  
  58. x#=0
  59. y#=0
  60. z#=0
  61.  
  62. If KeyDown(LEFT_KEY)=True Then x#=-0.1
  63. If KeyDown(RIGHT_KEY)=True Then x#=0.1
  64. If KeyDown(DOWN_KEY)=True Then y#=-0.1
  65. If KeyDown(UP_KEY)=True Then y#=0.1
  66.  
  67.  
  68.  
  69. If CountCollisions (sphere)
  70. crash=CollisionEntity (sphere,1)
  71. HideEntity crash
  72. EndIf
  73.  
  74.  
  75. MoveEntity sphere,x#,y#,z#
  76.  
  77. UpdateWorld
  78. RenderWorld
  79.  
  80. Flip
  81. Wend
  82.  
  83. End