home
***
CD-ROM
|
disk
|
FTP
|
other
***
search
/
3D Game Programming for Teens (2nd Edition)
/
3DGPFT2E.iso
/
Source
/
Chapter13
/
demo13-05.bb
< prev
next >
Wrap
Text File
|
2009-01-20
|
1KB
|
53 lines
; demo13-05.bb - Bomb
; --------------------
Graphics3D 640,480
SetBuffer BackBuffer()
Const ESC_KEY = 1
; Create camera
camera=CreateCamera()
; Creating a light
light=CreateLight()
; This is the code for creating the cone
bomb=CreateSphere()
PositionEntity bomb,0,0,5
EntityColor bomb, 230,34,75
EntityOrder bomb, -1
; This is the code for creating the shrapnel
shrapnel=CreateSphere()
PositionEntity shrapnel,0,0,5
ScaleEntity shrapnel, 0.1,0.1,0.1
EntityColor shrapnel, 230,34,75
shrapnel1=CreateSphere()
PositionEntity shrapnel1,0,0,5
ScaleEntity shrapnel1, 0.1,0.1,0.1
EntityColor shrapnel1, 230,34,75
shrapnel2=CreateSphere()
PositionEntity shrapnel2,0,0,5
ScaleEntity shrapnel2, 0.1,0.1,0.1
EntityColor shrapnel2, 230,34,75
shrapnel3=CreateSphere()
PositionEntity shrapnel3,0,0,5
ScaleEntity shrapnel3, 0.1,0.1,0.1
EntityColor shrapnel3, 230,34,75
; This code makes the program run
While Not KeyDown( ESC_KEY )
RenderWorld
Flip
Wend