home *** CD-ROM | disk | FTP | other *** search
/ Game Programming for Teens / GameProgrammingForTeens.iso / Source / chapter05 / demo05-04.bb < prev    next >
Text File  |  2003-04-06  |  504b  |  27 lines

  1. ;;;;;;;;;;;;;;;;;;;;;;
  2. ;demo05-04.bb
  3. ;By Maneesh Sethi
  4. ;Demonstrates the problems with masking
  5. ;No Input Parameters required
  6. ;;;;;;;;;;;;;;;;;;;;;;
  7.  
  8.  ;Initialize graphics
  9. Graphics 640,480
  10.  
  11. ;Load Background
  12. lilliesimage = LoadImage("lillies.bmp") 
  13. ;Draw the background
  14. DrawImage lilliesimage,0,0 
  15.  
  16. ;Load the frog
  17. frogimage = LoadImage("frog.bmp")
  18.  
  19. ;Center the frog
  20. MidHandle frogimage
  21.  
  22. ;Draw it in the center
  23. DrawImage frogimage,320,240
  24.  
  25.  
  26. ;Wait for user to press a button
  27. WaitKey