home *** CD-ROM | disk | FTP | other *** search
/ Game Programming for Teens / GameProgrammingForTeens.iso / Source / chapter05 / demo05-05.bb < prev    next >
Text File  |  2003-04-06  |  540b  |  27 lines

  1. ;;;;;;;;;;;;;;;;;;;;;;
  2. ;demo05-05.bb
  3. ;By Maneesh Sethi
  4. ;Demonstrates the use of masking
  5. ;No Input Parameters required
  6. ;;;;;;;;;;;;;;;;;;;;;;
  7. ;Initialize graphics
  8. Graphics 640,480 
  9.  
  10.  ;Load Background
  11. lilliesimage = LoadImage("lillies.bmp")
  12. ;Draw background
  13. DrawImage lilliesimage,0,0 
  14.  
  15.  
  16. ;Load the frog
  17. frogimage = LoadImage("frog.bmp")
  18. ;Center the frog
  19. MidHandle frogimage
  20. ;Mask the Frog Image
  21. MaskImage frogimage,0,0,10 
  22. ;Draw it in the center
  23. DrawImage frogimage,320,240
  24.  
  25. ;Wait for user to press a button
  26. WaitKey
  27.