home *** CD-ROM | disk | FTP | other *** search
/ Game Programming for Teens / GameProgrammingForTeens.iso / Source / chapter05 / demo05-06.bb < prev    next >
Text File  |  2003-04-06  |  579b  |  30 lines

  1. ;;;;;;;;;;;;;;;;;;;;;;
  2. ;demo05-06.bb
  3. ;By Maneesh Sethi
  4. ;Demonstrates the Color function, draws ellipses
  5. ;No Input Parameters required
  6. ;;;;;;;;;;;;;;;;;;;;;;
  7. Graphics 800,600
  8.  
  9. ;Seed random generator
  10. SeedRnd (MilliSecs())
  11.  
  12.  
  13. ;Max width of ellipse
  14. Const MAXWIDTH = 200 
  15.  ;Max Height of ellipse
  16. Const MAXHEIGHT = 200
  17.  
  18. ;Main Loop
  19. While Not KeyDown(1) 
  20.  
  21. ;Set the color to a random value
  22. Color Rand(0,255), Rand(0,255), Rand(0,255) 
  23.  
  24.  
  25. ;Draw a random oval
  26. Oval Rand(0,800),Rand(0,600),Rand(0,MAXWIDTH),Rand(0,MAXHEIGHT), Rand(0,1) 
  27.  
  28. ;Slow down!
  29. Delay 50 
  30. Wend