home *** CD-ROM | disk | FTP | other *** search
/ Amiga Plus 2000 #1 / Amiga Plus CD - 2000 - No. 1.iso / Games / PD / Freeciv / data / trident / cities.spec < prev    next >
Encoding:
Text File  |  1999-12-03  |  1.7 KB  |  79 lines

  1. ;
  2. ; The names for city tiles are not free and must follow the following rules.
  3. ; The names consists of style name, _ , size. The style name is as specified
  4. ; in cities.ruleset file. The size indicates which size city must
  5. ; have to be drawn with a tile. E.g. european_4 means that the tile is to be
  6. ; used for cities of size 4+ in european style. Obviously the first tile
  7. ; must be style_name_0. The sizes must be in ascending order.
  8. ; There must also be a style_name_wall tile used to draw the wall and
  9. ; an occupied tile to indicate a miltary units in a city.
  10. ; The maximum size supported now is 31, but there can only be MAX_CITY_TILES
  11. ; normal tiles. The constant is defined in common/city.h and set to 8 now.
  12. ;
  13.  
  14. [spec]
  15.  
  16. ; Format and options of this spec file:
  17. options = "+spec2"
  18.  
  19. [info]
  20.  
  21. artists = "
  22.     Jerzy Klek <jekl@altavista.net>
  23.  
  24.     european style based on trident tileset by
  25.     Tatu Rissanen <tatu.rissanen@hut.fi>
  26. "
  27.  
  28. [file]
  29. gfx = "trident/cities"
  30.  
  31. [grid_main]
  32.  
  33. x_top_left = 0
  34. y_top_left = 0
  35. dx = 30
  36. dy = 30
  37.  
  38. tiles = { "row", "column", "tag"
  39.  
  40. ; default tiles
  41.  
  42.  1,  2, "cd.city"
  43.  1,  3, "cd.city_wall"
  44.  1,  4, "cd.occupied"
  45.  
  46. ; used by all city styles
  47.  
  48.  0,  0, "city.disorder"
  49.  
  50. ;
  51. ; city tiles
  52. ;
  53.  
  54.  1,  0, "city.european_0"
  55.  1,  1, "city.european_5"
  56.  1,  2, "city.european_10"
  57.  1,  3, "city.european_wall"
  58.  1,  4, "city.european_occupied"
  59.  
  60.  1,  0, "city.classical_0"
  61.  1,  1, "city.classical_5"
  62.  1,  2, "city.classical_10"
  63.  1,  3, "city.classical_wall"
  64.  1,  4, "city.classical_occupied"
  65.  
  66.  1,  0, "city.industrial_0"
  67.  1,  1, "city.industrial_5"
  68.  1,  2, "city.industrial_10"
  69.  1,  3, "city.industrial_wall"
  70.  1,  4, "city.industrial_occupied"
  71.  
  72.  1,  0, "city.modern_0"
  73.  1,  1, "city.modern_5"
  74.  1,  2, "city.modern_10"
  75.  1,  3, "city.modern_wall"
  76.  1,  4, "city.modern_occupied"
  77.  
  78. }
  79.